Fehlende Umlaute in eMails mit PHP als Fast-CGI

Discogalaxy

Registered User
Hallo zusammen.
Ich habe von Apache-Modul auf Fast-CGI umgestellt.
Seitdem werden in eMails (z.B. Systemmails von Wordpress / Kontaktforumlare) keine Umlaute mehr im Mailbody angezeigt. Im Betreff sind sie vorhanden. Sie werden auch nicht falsch kodiert, sie sind einfach nicht da :-(
Sonderzeichen werden wunderbar angezeigt

Ich habe schon diverse Sachen in der php.ini verändert, aber alles ohne Erfolg. Einzig wenn ich zurück auf Apache-Modul wechsle, dann sind die Umlaute wieder da.

Kennt jmd dieses Phänomen oder kann mir eventuell bei der Suche helfen?
 

Joe User

Zentrum der Macht
Ich gehe einfach mal von einem korrekt konfiguriertem UTF-8 System aus:
Relevante Settings in der php.ini
Code:
default_charset = "UTF-8"
exif.encode_jis = "UTF-8"
exif.encode_unicode = "UTF-8"
iconv.input_encoding = "UTF-8"
iconv.output_encoding = "UTF-8"
iconv.internal_encoding = "UTF-8"
input_encoding = "UTF-8"
internal_encoding = "UTF-8"
mbstring.detect_order = "auto"
mbstring.http_input = "pass"
mbstring.internal_encoding = "UTF-8"
mbstring.http_output = "pass"
mbstring.strict_detection = "1"
output_encoding = "UTF-8"
In der httpd.conf:
Code:
AddDefaultCharset UTF-8
 

Discogalaxy

Registered User
Hallo Joe,
danke für Deine Antwort.

Habe den Fehler soeben finden können.
Hatte einen "Wrapper" zwischen Php und sendmail gesetzt um Spam-Scripts zu finden. Dieser hat die Umlaute geschluckt.

Trotzdem Danke!
 
Top