• This forum has a zero tolerance policy regarding spam. If you register here to publish advertising, your user account will be deleted without further questions.

exim4 mit confixx und procmail zerschossen

Garp

Registered User
Letzten Sonntag ist es passiert. Irgendwer hat ein Rootkit auf meinem suse s4y server appliziert und netterweise nur 130 gig verbraten. Also neuinstallieren. Nach Konsultation mit dem support wurde es debian mit exmin/procmail zu confixx.

War alles primeur.

Nur eins hatte nie funktioniert: Man konnte zwar mails abholen und auch welche an local_domains schicken, aber der Versandt an andere Domains per smtp über den Server hat nix getan.

- exim4 -d -bt somebody@yahoo.com:
Mailing to remote domains not supported

Nun habe ich Noob rumgeguckt und rumgelesen und tat dann auf diese Idee kommen:

dpkg-reconfigure exim4-config

super idee das. Theoretisch würde nun - exim4 -d -bt somebody@yahoo.com: schön funktionieren. Nur - es kommt keine Mail mehr durch:

mydomain.net in "+local_domains"? yes (matched "+local_domains" - cached)
checking local_parts
garp in "root"? no (end of list)
mail4root router skipped: local_parts mismatch
no more routers
garp@mydomain.net is undeliverable:
Unrouteable address

Ich habe dummerweise die autogenerated.conf bei exim4 nicht gesichert ... traurig und doof.

Kann mir jemand helfen? Mein Supportticket in dieser Angelegenheit (geposted bevor ich die autogenerated.conf zerschossen hatte) schmort weiter vor sich hin.

Helfen würde mir:
- eine autogenerated.conf die ich als template nutzen könnte.
- ein Link zu einem HowTo exim4 procmail debian confixx

Und jeder gute Rat, der meinen Mailbetrieb wieder zum laufen bringt.
 
Ja das habe ich mit grossem Interesse gelesen. Das in diesen Posts beschriebene Problem ist, dass die auth fehlschlägt.

Intergenia scheint das Problem gelöst zu haben. In meiner Installation befindet gibt es ein exim4/confixx Ordner und ein pl Skript, dass anscheinens die Userdaten kopiert.

Mein Problem ist ja etwas anders gelagert. die user vor dem @ werden nicht erkannt und daher werden die Mails zurückgewiesen.

Mir scheint die Pfadangabe zu den 'shadow Kopien' (wenn es denn solche sind) für procmail zu fehlen.

Oder liege ich da ganz falsch? nicht procmail prüft, ob der ident part berechtigt ist?

Ich werde jetzt mal einen Versuch mit * catchall für eine Domain zu machen, wenn es das Problem ist, kann ich es glaube ich lösen - mit der einen oder anderen Hilfestellung :)

:)

Wenn ich das Problem nicht lösen kann, bleibt mir nur die Rückkehr zu suse, weil für eine komplette Neuinstallation mit debian möchte s4y 4 AE berechnen. Das kann ich mir im Moment nicht leisten, sonst kriegen die Kinners keine neuen Jamba Klingeltöne und das Geschrei ist gross.
 
Seuft * als catch all löst das Problem nicht.

Was ich bräuchte wäre eine confixx debian exim procmail howto :)

Der sonst so beredsame dr google schweigt zu diesem Thema eisern.

Also dann doch back zur etwas komplizierten Mutter Suse? Zu Hülfe!

-- Ja da hatte ich den richtigen Riecher. http://www.debianhowto.de/howtos/de/exim4-vexim-sarge/index.html - den Hint habe ich hier im Bord gefunden. Super, es läuft alles. Zwar ohne Confixx - aber danach kräht kein Hahn :)
 
Last edited by a moderator:
Back
Top