Exchange 2010 - IPV4 erzwingen?

Raven6299

Blog Benutzer
Hallo Gemeinde,

nachdem ich heute morgen bereits im DNS Forum mein Problem gepostet habe, wirds jetzt Exchange spezifisch, daher hier im Windows Forum :D

Kurz zur Vorgeschichte:

Windows SBS 2012 mit Exchange (konfiguriert und läuft seit Jahren)
Subdomain remote.XXX.de bei Mittwald und verweise per A Record auf die fixe IPV4 des Servers (Portweiterleitung im Router, etc gesetzt und ist erreichbar)
Bei der Telekom für die fixe IP einen reverse DNS auf die Subdomain angelegt.
Reverse Auflösung klappt einwandfrei, Mails im IPV4 Netz laufen.

Jetzt vor 2 Wochen zwangsweise Umstellung auf All-IP mit Upgrade der Telefonanlage (Hardwareupgrade für VoIP)
In diesem Zuge haben wir auch eine neue fixe IP bekommen da beim Upgrade des Tarifes irgendwas nicht geklappt hat und trotz Token die IP nicht übernommen werden konnte. Egal habe die IP die wir jetzt zugewiesen bekommen haben entsprechend auch auf der Mittwald Subdomain geändert und der Mailverkehr läuft wieder sauber bis am Wochenende mein Chef an eine Gmail Adresse gemailt hat. Eine Fehlermeldung kam zurück dass der reverse DNS Record nicht passt. Bei genauer Prüfung habe ich festgestellt, dass sich unser Server seit der Tarifumstellung der Telekom mit seiner eigenen IPV6 Konfiguraion (im lokalen LAN läuft ebenfalls alles per IPV4, die Kiste hat aber natürlich dennoch eine eigene V6 IP) bei Google meldet. Da klappt die Rückwärtsauflösung natürlich noch nicht. Jetzt wollte ich auch für die IPV6 einen passenden Eintrag bei der Telekom setzen. Hierzu muss ich aber erstmal bei Mittwald die Subdomain per AAAA Record ebenfalls auf die richtige IPV6 leiten bevor die Telekom den Reverse Eintrag frisst (solange der nicht gesetzt ist meldet das Telekom Webinterface einen "internen Fehler")
Und hier gehen meine Probleme los... Zuerst habe ich den AAAA Record bei Mittwald nicht gefunden und (oh schreck) nach dem ich den Kundenservice kontaktiert habe wurde mir mitgeteilt dass ich für den AAAA Record auf einen Managed Server Tarif upgraden muss :confused::confused::confused:
Also ich muss von meinem Hostingprodukt auf dem ne winzige kleine Typo3 basierte Firmenpräsentation läuft zwingend einen 10 mal so teuren Tarif buchen nur um ein Feature zu nutzen, welches demnächst jeder Provider auch bei billifsten Tarifen aus dem F-F können muss :confused::confused::confused::confused::confused:
Einen ganzen Managed Server Tarif nur für eine simple DNS Einstellung :confused:

Daher meine Frage (und daher auch im Windows Forum): Kann ich nicht irgendwie dem Exchange Server austreiben, dass er über IPV6 sendet? Sprich irgendwie dem Sendeconnector irgendwie zwangsweise nur IPV4 erlauben?

Liebe Grüsse
 

Whistler

Blog Benutzer
Was für einen Router verwendet Ihr für die ALL-IP-Leitung?
Das Telekom-Speeddingens oder einen Lancom?
Da würde ich zuerst ansetzen.
Entweder Du treibst ihm IPv6 komplett aus oder verhinderst wenigstens die Weitergabe eines Präfix in das lokale Netz.
Auf dem Netzwerkinterface des Exchange kann man IPv6 ebenfalls abschalten.
Ihr habt hoffentlich kein DSL lite (wäre für einen Geschäftskundenanschluß unüblich).
 

Lord Gurke

Nur echt mit 32 Zähnen
Bist du sicher, dass Mittwald dein Anliegen richtig verstanden hat?
AAAA-Records gehören inzwischen zum allgemeinen Standard - ich vermute daher momentan, dass der Supportmensch dort interpretiert hat, dass du auch deine Webseite, welche bei denen gehosted wird, per IPv6 erreichbar haben willst.
Auch das halte ich zwar für einen Quasi-Standard im Jahr 2017, aber frage doch nochmal explizit nach einem reinen AAAA-Record für eine Subdomain, welche mit deinem Webhosting dort nichts zu tun hat sondern auf euren Exchange zeigt.
 

Raven6299

Blog Benutzer
Also es handelt sich um diesen "DeutschlandLAN" BNG Anschluss der Telekom. Ich müsste mal gucken aber ich glaube der hat tatsächlich echtes Dual Stacking. Allerdings leider nur mit mickriger Bandbreite von 2mbit... Der Telekom Geschäftskundenaussendienst hat noch getönt es wären 16Mbit machbar (wir hatten 1mbit) und als dann der TK Anlagen Dienstleister (bei dem wir unsere Alcatel OmniPCX Office im Service haben) mit dem Upgrade beauftragt und der Anschluss bestellt war hat uns dann die Telekom Technikabteilung die Hiobsbotschaft überbracht.... Daher auch momentan statt 4 nur 2 VoIP Sprachkanäle... Angeblich soll im Laufe 2018 aber VDSL 50 verfügbar sein...

Hardwaretechnisch werkelt bei uns diese "Digitalisierungsbox Premium" also dier Bintec.ip Elmeg Router. Du denkst dass ich vielleicht diesem direkt die IPV6 Geschichte austreiben sollte? Das wäre mal ein Versuch wert. Das prüfe ich direkt am Donnerstag mal (zwecks Feiertag sind wir erst am Donnerstag wieder in der Firma). Und wenn das nichts hilft dann IPV6 am Exchange unterbinden. Ist das machbar ? Beim Googeln bin ich nur über die Option gestoßen dem ganzen Server per Registryeintrag die IPV6 Funktion zu nehmen. Ich habe aber Exchange spezifisch hoffentlich auch eine Fernwartung mit unserem IT Dienstleister der hat sich nur gestern auf mein Ticket nicht mehr gemeldet daher hoffe ich dass der sich das am Donnerstag mal ansieht.

@Lord Gurke Das kann natürlich gut sein dass mich der Supportler einfach missverstanden hat. Ich werde da am Donnerstag mal anrufen sobald ich wieder im Büro bin (eingehende Mails funktionieren ja zum Glück). Wobei... was für die Aussage des Supportlers spricht ist, dass wenn ich auf die Mittwald Seite gehe und da unseren gebuchten Typo3 Hosting Tarif ansehe dann steht bei den Tarifdetails unter DNS nur der A Record... Wobei bei den "IPV6 ready" Managed Servern der selbe Mist steht:

Mit dem DNS-Editor haben Sie die Möglichkeit, schnell und einfach die DNS Resource Records Ihrer Domains zu verwalten. Mithilfe des DNS-Editors können folgende Resource Record Typen durch Sie gesetzt werden: - A Resource Record - CNAME Resource Record - MX Resource Record - TXT Resource Record - SRV Resource Record

In den FAQ´s widerrum ist auch von AAAA die Rede :confused: Ich denke um das Mysterium zu klären rufe ich da direkt mal an....

Liebe Grüsse
 

danton

Debian User
Beim Googeln bin ich nur über die Option gestoßen dem ganzen Server per Registryeintrag die IPV6 Funktion zu nehmen.

Da braucht es keinen Registry-Eintrag für, sondern es reicht aus, die Bindung von IPv6 an der Netzwerkkarte in der Systemsteuerung zu entfernen.
Sofern Mittwald externe Domains unterstützt, könntest du auch eure Domain zu einem Domain-Anbieter umziehen (z.B. INWX oder UnitedDomains oder Schlundtech) und dort die ganzen DNS-Einträge vornehmen.
 

Raven6299

Blog Benutzer
Ja das war auch noch so ein Gedanke von mir ... Ich muss da auch am Donnerstag mal bei Mittwald wenn ich den Supportler drann habe fragen ob unser Tarif externe Domains erlaubt. Ich hab nämlich sowieso noch ne .com Domain bei Domainfactory liegen, wir sind dort sowieso schon als Kunde angelegt daher wäre das von der Seite her problemlos möglich die einfach auf unseren DF Account mit aufzubuchen. DF kann nämlich mit AAAA Records umgehen....
Ansonsten versuch ich mal zunächst an der Digibox die IPV6 Funktion zu deaktivieren (das müsste bei der Box gehen) und wenn das nichts bringt eben am Server die IPV6 Bindung. Aber das wäre eben nur "unschöne" Lösungen da wir selbst ja bereits Hard und Softwaretechnisch mit IPV6 umgehen könnten. Ich hätte nie daran gedacht dass ein Webhoster da hinten drann ist, gerade bei so einem wichtigen Thema wie IPV6.....

Liebe Grüsse
 

Raven6299

Blog Benutzer
Kurzes Update: Also es scheint tatsächlich so zu sein dass die normalen Hostingprodukte aktuell noch IPV4 only sind... Erst ab der teuren Managed Server Kategorie findet man"IPV6 ready" Tarife...
Daher habe ich jetzt folgendes gemacht: In der Digibox IPV6 deaktiviert und auch sicherheitshalber nochmal das weiterleiten des Präfixes ins LAN abgeschalten. Ist in der Digitalisierungsbox Premium zum Glück alles Einstellbar. Ergebnis: Die Problemkinder Freenet und Gmail empfangen wieder sauber Mails.
Ich hoffe jetzt mal dass ich das aussitzen kann bis unser Hoster IPV6 technisch nachzieht. Im Moment läuft ja V4 und V6 parallel und irgendwann werden die das hoffentlich mal upgraden. Wenn nicht muss ich wohl wirklich die DE Domain umziehen.... Schade eigentlich da ich mit dem Hoster sonst sehr zufrieden bin ....

Liebe Grüsse :)
 
Top