E-Mails erreichen nicht den Empfänger (Plesk)

menirules

New Member
Hallo,

Ich habe mehrere Domains auf meinem VServer laufen und alles war in Butter.
Plötzlich haben E-Mails die verschickt wurden den Empfänger nicht mehr erreicht.
Es kommt kein Error Reply. Die IP des VServers ist auf keiner Spamliste. Die Emails sind im "Gesendet" Ordner. Aber egal ob sie aus Outlook, Android Browser oder Webmailer raus gehen, sie erreichen den Empfänger nicht.
Ich bin sehr ratlos. Insbesondere, weil ich nirgends rum geschraubt oder was verändert habe an den Mail Einstellungen des Servers.

Jemand eine Idee?

Danke

Meni
 

GwenDragon

Registered User
Würden die Mails den Empfänger nicht erreichen bekämst du längst eine Fehler-E-mail vom Server.

Wahrscheinlich landen die beim Empfänger im Spamordner.
 

menirules

New Member
Nein, die landeten nirgends im SPAM Ordner und es kam auch kein Error zurück.
Habe von 5 verschiedenen Adressen aus an 10 verschiedene Empfänger geschickt und nirgends kam was an.
Auch nicht an meinen test Empfänger, der komplett ohne SPAM Filter läuft und wirklich jede Viagra Werbung erhält :)
Habe gestern das Upgrade auf Plesk Version 17 gezogen (die letzte Stable) und seit dem kommen die Emails auch wieder an. Keinen blassen schimmer was das für ein Misterium war.
 

menirules

New Member
Ok, es ist doch nicht gelöst. Es hat sich gerade heraus gestellt, dass nur Web.de und GMX.de die emails nicht annehmen. da jüngste tests an google und eine andere domain funktioniert hatten ging ich davon aus es sei gelöst.

Folgender Fehler in der maillog:
refused to talk to me: 554-web.de (mxweb111) Nemesis ESMTP Service not available 554-No SMTP service 554-Bad DNS PTR resource record. 554 For explanation visit http://postmaster.web.de/error-messages?ip=178.254.34.247&c=rdns)

In der erklärung steht, dass Web.de emails von servern ablehnt, die Standardnamen des provicers haben. in meinem fall ist das wolh vxxxxx.1blu.de
 

greystone

Member
Das ist durchaus verbreitet. Du könntest aber versuchen den Mailhostnamen bzw. Servernamen auf vxxxxx.1blu.de zu ändern. Dann wäre der Bad PTR-Record auf jeden Fall schon mal weg. Kann sein, dass der Server dann immer noch abgelehnt wird, vielleicht aber auch nicht.

Anschliessend den Mailserver nochmal auf grobe Konfigrationsfehler testen. Z. B. auf www.mxtoolbox.com

P. S.: Bitte für Logausgaben und Scripte [noparse]
Code:
 ...
[/noparse]
- Tags verwenden. Das erhöht die Lesbarkeit enorm und damit die Wahrscheinlichkeit, dass Du Antworten auf Deine Fragen bekommst.
 
Last edited by a moderator:

menirules

New Member
Das ist das Problem. Der Mailhost ist eben diese 1blu.tld und web.de lehnt generische Mailservernamen scheinbar seit dem 23.5. komplett ab.
Bedeutet, dass die niemals emails von vxxxxx.1blu.de annehmen werden (ich X`e das nur aus, weil ich den namen gerade nicht im Kopf habe).

Ich muss also in Postfix den namen ändern und dann an 1blu melden.
Siehe hier in den FAQ`s:
http://faq.1blu.de/solution_id_1850.html

Was für ein unfassbarer Mist...

Ich weiß eh nicht wie ich das jetzt machen soll. Wenn ich da mail.homepage-boom.de als Namen eintrage, so wie es empfohlen wird, funktioniert das dann überhaupt für andere Domains mit selber IP auf meinem Server?
Wenn also info@trabrennbahn-maisach.de eine Email verschickt über einen Mailserver mit dem namen mail.homepage-boom.de, funktioniert das überhaupt? Und falls ja, wird das denn nicht noch viel mehr von anderen Providern abgelehnt?
Bin gerade irgendwie ratlos.
 

greystone

Member
Der PTR ist unabhängig von den Domains, die darüber verschickt werden. D. h. du musst den PTR bzw. Mailserver-Hostnamen nur einmal richtig einrichten.
 

nexus

Well-Known Member
Wenn also info@trabrennbahn-maisach.de eine Email verschickt über einen Mailserver mit dem namen mail.homepage-boom.de, funktioniert das überhaupt? Und falls ja, wird das denn nicht noch viel mehr von anderen Providern abgelehnt?

Nein, die werden nicht abgelehnt, wenn es richtig konfiguriert ist.
Du gibst doch im MX-Record der sendenden Domain (in deinem Beispiel trabrennbahn-maisach.de) den Namen des Mailservers (in deinem Beispiel mail.homepage-boom.de) an, der für die sendende Domain zuständig ist. So weiß der empfangende Mailserver, daß das so seine Richtigkeit hat und nimmt die Mail auch an.
 

menirules

New Member
Ok, also richte ich es so ein:

Ich benenne in Postfix den Host um in mail.homepage-boom.com
also in der main.cf folgender Eintrag:
myhostname = mail.homepage-boom.de

Anschliessend richte ich bei allen Domains die auf meinem Server liegen einen MX Record von domain.de auf mail.homepage-boom.de

Sollte korrekt sein, oder?
 

menirules

New Member
Ähm ok... Verstehe nur Bahnhof :p

Sorry, bin was Postfix angeht absoluter Laie. Musste da noch nie viel machen was über die Bedienung der grafischen Benutzeroberfläche hinaus geht.

Wie müssen dann die Einträge in der main.cf aussehen?

Die sollten ja auch ziemlich simple parameter haben wie:

virtual_mailbox_domain = domain1.de
virtual_mailbox_domain = domain2.de

Oder liege ich jetzt komplett daneben?

Muss das wirklich gemacht werden? Es funzt ja eigentlich alles, von allen Domains aus, nur lehnen manche Empfänger die Emails eben ab wegen dem generischen Hostnamen. Da müsste es doch erledigt sein wenn ich den Hostnamen ändere?
 
Last edited by a moderator:

menirules

New Member
Update:

1blu hat den neuen Hostnamen durch gewunken und schon wuppen von allen Domains die Emails wieder überall hin. Sogar ohne dass ich bei den einzelnen Domains noch extra MX Records angelegt habe.

Vielen Dank für die Tipps :)
 

greystone

Member
Die MXe würde ich aber trotzdem richtig setzen.

E-Mailserver ist ein Thema, bei dem die Prüfung der Einhaltung der Konformität nur in eine Richtung geht: Sie wird stetig strenger.

Und irgendwann merkst Du, dass Dein E-Mailserver nicht mehr funktioniert und nach Stunden des suchens kommst Du dann auf solche Sachen.

Also: Lieber gleich richtig machen!
 

menirules

New Member
Würde ich, aber da virtuell sehr viel "Selbstläufer" ist, bin ich mir nicht so sicher ob das nicht mehr schadet als was nützt?
Im Endeffekt ist das doch eine Serverinterne Sache? Wenn mein Mailserver die Emails annimmt und verschickt, interessiert doch den empfangenden Server gar nicht was ich so für MX Records am laufen habe, oder?
 

greystone

Member
Vielleicht kommt ja ein sendender Server auf die Idee den MX gegen den HELO-Hostnamen(Den Servernamen, den Dein MTA beim Zugriff auf ihn selbst sendet) zu prüfen. Wenn das nicht passt, bricht der Sender den Vorgang evtl. ab.

Hatte ich jetzt AFAIR noch nicht. Ist aber nicht weit hergeholt.

Ich hatte schon z. B. den Fall, dass eine Maileinlieferung abgebrochen wurde, weil ein MX auf einer Blacklist stand, welche ja üblicherweise nur beim annehmen von E-Mails geprüft werden und nicht beim Versand.
 
Top