DynDNS Control Panel

haggybear

Registered User
Version 1.2

Neue Version die die geänderte vhost Struktur von Plesk 11.5 berücksichtigt und damit das Update via TOKEN-URL bei neu angelegten DynDNS-Hosts wieder ermöglicht.

Download -> http://haggybear.de/de/dyndns-control-panel
//EDIT: Attachment gelöscht, nur noch der letzte Post enthält die aktuelle Version.

Gruß
Haggy
 
Last edited by a moderator:

martinJhenne

New Member
Bug?

Erstmal vielen Dank für dieses super Tool :)

Ich konnte es auf meinem vServer von Strato mit Plesk 11.5.30 allerdings nur zum laufen bringen (Die IP-Updates) wenn ich die Datei dcp.class.php zusätzlich in den Ordner /opt/psa/admin/htdocs/dcp/dynupd kopiert und in der index.php die Zeile
Code:
require("dcp.class.php");
entsprechend geändert habe.

Weiterhin wächst das error-log durch folgende Fehler:
Code:
PHP Notice: Constant DB_PWD already defined in /opt/psa/admin/htdocs/dcp/config.inc.php on line 5       
PHP Notice: Constant PSA_PATH already defined in /opt/psa/admin/htdocs/dcp/config.inc.php on line 16    
PHP Notice: Constant VHOSTS_PATH already defined in /opt/psa/admin/htdocs/dcp/config.inc.php on line 17 
PHP Notice: Undefined index: cl_id in /opt/psa/admin/htdocs/dcp/dynupd/dcp.class.php on line 43

Die Möglichkeit das ganze über https laufen zu lassen und gültige IP-Bereiche anhand der resolvten IP zu definieren wäre super. Würde ein Stückchen mehr Sicherheit bedeuten. Die IP-Adressen meines Providers haben z.B. immer das Format ***.dynamic.mnet-online.de.

viele Grüße
Martin
 

haggybear

Registered User
Die Möglichkeit das ganze über https laufen zu lassen und gültige IP-Bereiche anhand der resolvten IP zu definieren wäre super. Würde ein Stückchen mehr Sicherheit bedeuten. Die IP-Adressen meines Providers haben z.B. immer das Format ***.dynamic.mnet-online.de.
Ich bin gerade dabei den Kern neu zu designen. Auch damit z.B. InternetX oder Schlundtech DNS Server angesteuert werden können. Bitte etwas Geduld.

Gruß
Haggy
 

d0nk

New Member
Guten Tag,

habe das Problem das auf mein Hosteurope VServer mit der Plesk version 11.0.9 Update #58, das script den DNS Server an sich nicht neustartet bzw. die config Lädt. Es ist zwar überall die IP in Plesk geändert aber per DIG oder ping ist immer noch die alte IP eingetragen.

Hat jemand ne Ahnung woran das liegen kann?
 

Leon201006

New Member
@Haggy

ich habe dein DNS Addon installiert wie auf der beiliegenden Installationshilfe.
so weit so gut. Wenn ich jetzt im Kunden CP auf DynDNS klicke dauert es einen kleinen Moment und ich bekomme die Meldung " Sie haben keine Berechtigung diesen Service zu nutzen " leider finde ich keine Einstellmöglichkeit um dem Nutzer diese Rechte einzuräumen.

Hab ich was über sehen ??

Mein System:
BS openSUSE 12.1
Panel-Version 11.0.9 Update #60, zuletzt aktualisiert am Okt 31, 2013 03:17 AM


Gruß Michael
 

scholle

New Member
Ja, nur ein Nameserver läuft auf Deiner Maschine. Die anderen bei Schlund. Und je nachdem welcher NS gerade beim nslookup Antwortet glaubt das Addon das der Nameserver woanders läuft.

Gruß
Haggy

Hallo,

ich habe ein ähnliches Problem wie HMnet, ich bekomme die Meldung "Host x.y.z kann nicht aktiviert werden, da der Nameserver nicht auf dieser Maschine läuft!"
Ich habe einen VServer bei Strato. Es ist kein NS von Strato im DNS eingetragen. Selbst wenn ich nur den lokalen NS einstelle, also ohne forwarder, bekomme ich o.g. Meldung. DNS-Template habe ich auch entsprechend angepasst. Ich bin im Moment ziemlich ratlos :confused:.
Scheinbar findet ja eine Überprüfung innerhalb deiner Scripte statt? Kann man diese Überprüfung testweise abstellen? :rolleyes:
 

Shamane

New Member
<MOD>Fullquote entfernt!</MOD>

So geht es mir auch.
Hab es so eingestellt wie hier bereits beschrieben.
Bei meinem Provider alle einträge gemacht und in Plesk die DNS einstellungen vor genommen.
Im großen und ganzen funktioniert es.

Nur leider ist folgendes...

- Der Button für DynDNS fehlt vollkommen
--+ Nur sichtbar wenn man ihn manuell einfügt
- Die liste der Subdomains ist eingegraut
--+ aktivierung nicht möglich da anscheinend der DNS Server nicht auf dieser Maschine läuft. (Was allerdings quatsch ist).

Hoffe da findet sich noch rat und tat bei der behebung :)
Ansonsten ein netter ansatz.
 
Last edited by a moderator:

hugo72

New Member
dyndns Vserver plesk 11.5.30 / Ubuntu 12.04.4 LTS

Hallo ,

habe das Tool wie in der Anleitung installiert.
im DNS habe ich 2 Einträge mit
ns2.hans.hosteurope.de.
und
lvpsxx-xxx-xx-xx.dedicated.hosteurope.de.
eingetragen.

Den Button angelegt und ist auch bei den Domains sichtbar.

Die Seite geht auf, SubDomains werden in der Liste angezeigt.

Wenn ich versuche ein Eintrag zu aktivieren kommt Fehler ( siehe Anhang).

Was mache ich falsch oder geht das mit einem Vserver gar nicht?

Hoffe es kann mir hier jemand helfen.

:confused:Hugo
 

Attachments

  • fehler.PNG
    fehler.PNG
    8.6 KB · Views: 252

gordin

New Member
Geht hier ebenfalls nicht

Hi,
ich habe ebenfalls das Problem, dass das Control Panel der Meinung ist der DNS-Server würde nicht auf der selben Maschine laufen. Das stimmt aber nicht. Der DNS-Server läuft definitiv auf der selben Maschine.
Ich habe für die Subdomain den DNS-Server auf "Master" stehen und der Alias-Eintrag wird auch abgeändert. Nur leider nicht automatisch sondern nur nach aus/einschalten (bzw. auf Slave und dann wieder zurück auf Master).

Das ganze hat auch schon mal geklappt... sonst hätte ich das ja gar nicht erst aktivieren können.
Dummerweise habe ich jetzt auf "DynDNS deaktivieren" geklickt. Die dynupd Subdomain weg geräumt und den Alias-Eintrag auf die "echte" IP des Servers zurück gesetzt. Aktivieren geht nun leider nicht mehr. Ich habe das Gefühl, das einfach der Check, ob der DNS-Server auf der selben Maschine läuft fehl schlägt.

Ich verwende Plesk 11.0.9 Update #60 auf einem VServer mit Ubuntu 10.04.4 LTS, DynDNS Control Panel 1.2.1
 

gordin

New Member
Workaround

Für die Mutigen hier ein Workaround.

Disclaimer: ich habe null Ahnung vom DCP und übernehme keine Verantwortung für evtl. auftretende Nebeneffekte. Ich selbst weiß 100% dass mein DNS-Server auf der selben Maschine läuft und habe daher die Holzhammermethode genommen:

in /opt/psa/admin/htdocs/dcp/dcp.class.php folgende Änderung vornehmen:
Zeile 263, function getDnsEntries()
$view = (@in_array($data->host,$this->noDyns))?false:true;
ändern in:
$view = (@in_array($data->host,$this->noDyns))?true:true;

So schaltet man jede Subdomain aktiv. Ich persönlich gehe davon aus, dass in einer der SQL-Abfragen was schief geht und daher die Domain in "noDyns" landet obwohl sie halt eigentlich unter der Kontrolle des Servers steht.

Getestet mit Fritz!Box 7272. Info: wenn ihr in der Fritz!Box "Neu verbinden" klickt müsst ihr euch danach bei Plesk erneut anmelden um die neue IP zu sehen. Es gibt keine Fehlermeldung von DCP wenn man einfach auf "Aktualisieren" klickt ohne sich neu anzumelden. Aber die Anzeige kann dann nicht aktualisiert werden.
 

hugo72

New Member
Super, hat geklappt

Danke.
Ist zwar nicht optimial aber da ich den Server alleine nutze spielt da keine Rolle.

Grüße
Hugo
 

beckersstef

New Member
Moin erst mal,

ich bin der neue :rolleyes:

ich glaube ich bin etwas blöd geworden :eek:
ich habe das Modul schon mal installiert, alles ohne Probleme.

Nach einem HD Crash musste es nun neu auf den Server, es scheint eigentlich zu laufen, legt aber komischerweise die Sub Domain dynup.xx.xx.de nicht an.

Hatte schon mal jemand von euch das gleiche Problem, und weis wo ich suchen muss.

--
03.03.14 8:32 Edit: gestern vergessen Plesk 11.5.3 auf Ubuntu 12.04.4
--


LG Stefan
 
Last edited by a moderator:

JoergG

New Member
Hallo,

ich hoffe mir kann jemand weiterhelfen.
Nach dem Einrichten vom DCP (1.2.1), meldet meine FritzBox immer:
"Die Dynamic DNS-Aktualisierung war erfolgreich, anschließend trat jedoch ein Fehler bei der DNS-Auflösung auf"
Die Kompilierung des wrapper brachte keinen Erfolg.

Auch bekomme ich beim Aufruf der Update-URL folgende Meldung:
Notice: Constant DB_PWD already defined in /opt/psa/admin/htdocs/dcp/config.inc.php on line 8 Notice: Constant PSA_PATH already defined in /opt/psa/admin/htdocs/dcp/config.inc.php on line 20 Notice: Constant VHOSTS_PATH already defined in /opt/psa/admin/htdocs/dcp/config.inc.php on line 21

Das manuelle Eintragen der IP über den Button "IP updaten" funktioniert einwandfrei, Subdomain und IP werden richtig aufgelöst.

Vielen Dank schon mal im voraus

Gruß
Jörg

Plesk 11 Update 35
Ubuntu 12.04
 

millenium1980

New Member
Hallo,
ich habe folgendes Problem:

Einrichten hat super geklappt. Update der IP über Plesk klappt auch.
Was nicht funktioniert ist das Update über die Update URL.
Wenn ich die im Browser aufrufe, kann die Seite nicht geladen werden. Auch ein ping auf dynupd.test.xxxdomain.de kann nicht ausgeführt werden.
Ansonsten ist die Domain aber problemlos erreichbar.

Hat jemand eine Idee, wo der Fehler sein könnte?

Vielen Dank

millenium
 

haggybear

Registered User
Ja, ist er
Hast Du lt. INSTALL.txt dieses hier mal gemacht:

Code:
The wrapper is compliled on a 64 bit system with Plesk 11. If you want (or have) to compile your own wrapper just do this:
cd sh
rm wrapper
gcc wrapper.c -o wrapper
strip wrapper
chown root:root wrapper
chmod 4755 wrapper

Gruß
Haggy

PS: Hast Du ein Ubuntu System?
 
Top