DNS Abrage feste IP der Telekom, IPv6 einrichten Gateway

Haxley

Member
Hallo,

ich hab eine feste IPv4 87.xxx.xxx.147 und einen festen Präfix IPv6 2003:xxxx:xxxx:xx30:: der Telekom und da einen kleinen Webserver dran.

Der Aufbau zum Webserver IPv4 ist folgender:

- externer DNS Server domain.de verweist auf 87.xxx.xxx.147
- Router (hat selber 192.168.0) Portfreigabe (Port 25, 80, 3306 usw.) auf 192.168.0.54
- Webserver (Proxmox) eine VE hat 192.168.0.54, Gateway 192.168.0.1
Das geht soweit, aber wenn ich eine externe DNS Abfrage mache hört diese vor der 87.xxx.xxx.147 auf. Warum ist das so? Was muss ich da ändern?

Noch eine Frage zu IPv6:

Ich möchte IPv6 für diesen Webserver auch mit einrichten, also Dualstack.
Aufbau:
- externer DNS Server AAAA Eintrag domain.de verweist auf 2003:xxxx:xxxx:xx30::54
- Router Portfreigabe (Port 25, 80, 3306 usw.) auf 2003:xxxx:xxxx:xx30::54
- Webserver (Proxmox) eine VE hat zusätzlich zu IPv4 (siehe oben) noch die 2003:xxxx:xxxx:xx30::54 (feste IP)
Ist der Aufbau so korrekt? Also eine öffentliche IP für den Webserver zu verwenden?

Nun muss ich für IPv6 noch etwas als Gateway eintragen. Dem Router selbst kann ich aber keine feste IPv6 geben. Was genau trage ich da ein? Soweit ich das verstanden hab benötigt IPv6 doch keine Gateway oder?



Danke Gruß Haxley
 

mr_brain

Registered User
Das geht soweit, aber wenn ich eine externe DNS Abfrage mache hört diese vor der 87.xxx.xxx.147 auf. Warum ist das so? Was muss ich da ändern?
Was meinst du mit "DNS hört vor auf"? Meinst du vielleicht ein Traceroute?

Wieso bei IPv6 eine Portfreigabe bei festen IP´s? Hast du von der Telekom kein festes IPv6-Netz bekommen? Wenn du ein ganzes IPv6-Netz von der Telekom hast, dann brauchst du kein Gateway, aber auch kein Portforward.
 

Haxley

Member
Ja ich meine einen Traceroute bei IPv4.
Bei IPv4 blockt der Router ja erstmal alle Ports bei Zugriff von außen. Die muss ich da schon erstmal freigeben und zum richtigen Server leiten.

Ich hab feste IPs (IPv6 den Prefix) von der Telekom. Heißt ich muss am Router nichts feigeben bei IPv6?
Wenn meine VE in Proxmox ein IPv6 Gatway erwartet, lasse ich das sozusagen dnan einfach frei?
 

mr_brain

Registered User
Ein Traceroute wird immer beim Portforward aufhören, da ja kein Routing stattfindet, sondern ein Portforward.

Wenn der Router korrekt mit IPv6 umgehen kann, dann musst du auf den VMs das GW des IPv6-Netzes angeben, welches dir zugewiesen wurde.
 

Haxley

Member
OK danke!
Aber wo bekomme ich die GW Adresse des IPv6 Netzes raus? Ich hab ja nur den Prefix zugeteilt bekommen.
 

mr_brain

Registered User
Müsste eigentlich im Telekomrouter angezeigt werden. "Zugewies. Adressbereich / Präfix", "Nutzbarer Adressbereich für LAN" und "IPv6-Adresse (GUA)"
 

danton

Debian User
Bei IPv6 machst du kein Portforwarding, sondern verwendest die IPv6 der Servers. Im Router musst du nur für diese IPv6 die Ports öffnen. Bei IPv6 wird normalerweise geroutet und kein Portforwarding betrieben.
 

Haxley

Member
Portforwarding hatte ich eigenlich auch nicht gemacht, sondern nur die Ports frei gegeben zu der IPv6 Adresse. Aber es gibt noch die Option des statischen Routings. Denk das ist der richtigere Weg.
 

danton

Debian User
Brauchst du eigentlich nicht. Du vergibst dem Server sinnvollerweise statisch eine IPv6-Adresse mit dem korrekten Prefix. Das Gateway kommt dann normalerweise per Router-Announcement und muss nicht statisch eingestellt werden. Unter Windows ist dies standardmäßig aktiv, unter Linux muss das ganze ggfl. per Systemd oder sysctl.conf konfiguriert werden, abhängig von Distribution und Netzwerk-Konfigurationsmethode.
 
Top