devMX TS³-Viewer Problem

Nox

New Member
Hallo Forum,

ich hab ein kleines Problem und stehe denke ich mal einfach auf dem Schlauch. Es geht speziell um den TS³-Viewer:

"devMX TeamSpeak3 Webviewer"

Die Installation befinden sich auf dem gleichen Server, wie die Homepage wo der TS³ angezeigt werden soll und der TS³-Server installiert ist.

Nach dem ich alles konfiguriert habe, kann ich mit die Einstellungen anzeigen lassen und alles wird richtig dargestellt - jedoch ein zweiter Aufruf funktioniert nicht. Erst Minuten später -> Also dacht ich klarer Fall -> Whitelist-Eintrag machen... aber da alles auf dem selber Server ist, ist auch alles Localhost... trozdem hab ich die Whitlist erweitert um localhost/ 127 / static ip -> Neustart -> Keine Veränderung.

*Die ServerRecht sind für den user gesetzt
*fsockopen aktiviert
*Whitelist eintrag stimmt
*Server neugestartet
*Allgemeine Rechte für das Webinterface sind konfiguriert

Hier mal meine config der Viewers:

Code:
<?xml version="1.0"?>
<!--
 * Author    : Maximilian Narr
 * Homepage  : http://maxesstuff.de
 * Email     : maxe@maxesstuff.de
 * License   : See license-folder
 * Version   : See changelog.txt
-->
<!DOCTYPE root PUBLIC "-//W3C//DTD HTML 3.2 Final//EN" "null">
<config>
  <!-- Main configuration -->
  <!-- IP Adress or DNS Name to your server -->
  <host>84.201.33.231</host>
  <!-- Queryport of your server (Default: 10011) -->
  <queryport>10011</queryport>
  <!-- Port of the server over which you are connecting to it via client (Default: 9987) -->
  <vserverport>9987</vserverport>
  <!-- Credentials -->
  <!-- 
    If credentials are required to log into the server via query
    if a username is needet set it to true
    a login is just needed if the standard user hasn't the following permissions:
      b_virtualserver_select (use)
      b_virtualserver_info_view (serverinfo)
      b_virtualserver_channel_list (channellist)
      b_virtualserver_client_list (clientlist)
      b_serverinstance_modify_querygroup
      b_serverinstance_modify_templates
      b_virtualserver_servergroup_list (servergrouplist)
      b_virtualserver_channelgroup_list (channelgrouplist)
    -->
  <login_needed>true</login_needed>
  <!-- Username of the Query-User -->
  <username>serveradmin</username>
  <!-- Password of the Query-User -->
  <password>iLoveSSF.de</password>
  <!-- Language -->
  <!-- Language of the Viewer (de or en) -->
  <language>de</language>
  <!-- DONT CHANGE ANYTHING HERE -->
  <prefix>none</prefix>
  <!-- Usage statistics -->
  <usage_stats>false</usage_stats>
  <!-- Images -->
  <!--
    if this option is settted to true, the Channel and Servergroup Icons are downloaded and stored localy on the webspace
    if it's setted to false the images of the imagepack are used
    -->
  <use_serverimages>true</use_serverimages>
  <!--
    if you use the script in a iframe and you want that the script works for user who aren't accepting third party cookies
    -->
  <use_sid_in_url>false</use_sid_in_url>
  <!--
    if use_serverimages is setted to false fill in the name of the server and channelgroupicons
    (The number in brackets is the group-id)
    Letting this on default is recommended
    -->
  <!-- Serveradmin -->
  <servergrp_images_6>group_300</servergrp_images_6>
  <!-- Channeladmin -->
  <channelgrp_images_5>group_100</channelgrp_images_5>
  <!-- Operator -->
  <channelgrp_images_6>group_200</channelgrp_images_6>
  <!-- Voice -->
  <channelgrp_images_7>group_600</channelgrp_images_7>
  <!-- Styling Options -->
  <!-- Stylepack (DONT CHANGE ANYTHING HERE) -->
  <style>modern-dark</style>
  <!-- Imagepack -->
  <imagepack>standard</imagepack>
  <!-- Image-Type of the images (DONT CHANGE ANYTHING HERE) -->
  <image_type>png</image_type>
  <!-- Wheter arrows should shown like in the TS-Client (true or false) -->
  <show_arrows>true</show_arrows>
  <!-- Whether icons should be shown or not -->
  <show_icons>true</show_icons>
  <!-- Whether country icons should be shown or not -->
  <show_country_icons>false</show_country_icons>
  <!-- Client ordering .
        Supported Orderings are:
        clid -> client with lowest clid first (as provided by clientlist) no extra queries are made (default)
        name -> alphabetical sorting, no extra queries are made
        tsclient -> sorting like in ts3-client (talkpower, is_talker, alphabetical) one query per user is made, may slow down the viewer!
     -->
  <sort_method>clid</sort_method>
  <!-- Filters -->
  <!-- Available Filters:
        standard           -> Standard display
        clientsonly        -> Shows only clients
        channelclientsonly -> Shows only channels in which are clients online
    -->
  <filter>standard</filter>
  <!-- Caching -->
  <!-- Whether caching should be enabled (true or false) -->
  <enable_caching>false</enable_caching>
  <!-- Enable flushing caches by appending fc as a get parameter -->
  <enable_cache_flushing>true</enable_cache_flushing>
  <!-- Minimal time in seconds between two connections to the server -->
  <standard_cachetime>180</standard_cachetime>
  <!-- The method which should be uses for caching -->
  <cache_method>file</cache_method>
  <!-- Format of the date() function -->
  <!-- See http://php.net/manual/de/function.date.php -->
  <date_format>d.m.Y - H:i</date_format>
  <!-- Enabled Modules (seperate with comma) -->
  <modules>htmlframe,style,about,channelHiding,infoDialog,js_login,loginButton,stats,serverInfo,userBar</modules>
  <!-- Module configuration -->
  <module name="template"/>
  <module name="autoRefresh">
    <refresh_time>none</refresh_time>
  </module>
  <module name="channelHiding">
    <fadeIn_time>none</fadeIn_time>
    <fadeOut_time>none</fadeOut_time>
    <remember_hidden_chans>none</remember_hidden_chans>
    <hide_empty_chans>none</hide_empty_chans>
  </module>
  <module name="infoDialog">
    <show_html_for_client>none</show_html_for_client>
    <close_by_mouseout>none</close_by_mouseout>
    <hover_delay>none</hover_delay>
    <width>none</width>
    <height>none</height>
  </module>
  <module name="stats">
    <use_tab>none</use_tab>
    <height>none</height>
    <width>none</width>
    <x_formatString>none</x_formatString>
    <y_formatString>none</y_formatString>
    <l_style>none</l_style>
    <locale>none</locale>
  </module>
  <module name="loginButton">
    <prompt_username>none</prompt_username>
    <prompt_pass>none</prompt_pass>
    <server_password>none</server_password>
    <connect_host>none</connect_host>
    <button_text>none</button_text>
  </module>
  <module name="legend">
    <use_tab>none</use_tab>
  </module>
  <module name="serverInfo">
    <use_tab>none</use_tab>
    <value_format>none</value_format>
  </module>
  <module name="js_login">
    <prompt_username>none</prompt_username>
    <prompt_pass>none</prompt_pass>
    <server_password>none</server_password>
    <connect_host>none</connect_host>
  </module>
  <module name="about"/>
  <module name="userBar"/>
</config>

Hier der Fehler der mir in der Konsole angezeigt wird:

Verbindungsaufbau(Aufruf im Webbrowser):
2014 Apr 10 11:40:12 vps48277 PAM service(sshd) ignoring max retries; 6 > 3

Verbindungsabbruch(Schliesen des Browser):
2014 Apr 10 11:42:43 vps48277 fatal: Write failed: Connection reset by peer [preauth]
2014 Apr 10 11:42:43 vps48277 PAM service(sshd) ignoring max retries; 4 > 3


Liegt bestimmt auf der Hand - sehs aber irgend wie nicht ^^

Grüße

(edit: Kann es sein, das es ein Problem mit meinem Hoster gibt?^^)
 
Last edited by a moderator:
Top