• This forum has a zero tolerance policy regarding spam. If you register here to publish advertising, your user account will be deleted without further questions.

Detaillierte Web-Statistiken (Server/vServer)

Thorsten

SSF Facilitymanagement
Staff member
Zur Auswertung von Websitebesuchern hat sich AWStats als extrem hilfreiches Tools erwiesen.
Man kann für jeden virtuellen Webserver bzw. für jede Website auf dem Server eine eigene Konfigurationsdatei anlegen (awstats.conf bzw. awstats.www.website.com.conf).
Die Auswertung erfolgt dann entweder von der Kommandozeile oder – wesentlich komfortabler – mittels Cronjob.

AWStats ist unter http://awstats.sourceforge.net zu finden. Eine Beispielstatistik unter http://www.neckel.com/cgi-bin/awstats.pl .
 
awstats funktioniert bei bir nur

wenn ich per cronjob buildstaticpages ausführe.

Ich habe schon versucht es direkt über das cgi-bin Verzeichnis ausführe aber das funktioniert nicht. :(

awstats.pl liegt in /var/www/cgi-bin/awstats/awstats.pl
hat 755 als Recht und mein Aufruf über den Browser lautet

http://168079.vserver.de/cgi-bin/awstats/awstats.pl?config=www.maydomain.de&configdir=/etc/awstats

Ich habe die Vermutung, dass das cgi-bin Verzeichnis gar nicht per Browser angesprichen wird.

Kann mir jemand helfen?

Grüsse

Dr.Evil
 
In der Datei /etc/httpd/conf/httpd.conf steht unten ein Eintrag zum VirtualHost der auf die Domain XXXYYY.vserver.de steht.
Ist dort evtl. Confixx drin und setzt einen eigenen cgi-bin-Alias?

huschi the husch
 
Jetzt klappt es

Hallo,
in der httpd.conf steht ziemlich am Schluss folgendes

## CONFIXX
<Directory "/var/www/confixx/html">
AllowOverride all
</Directory>
NameVirtualHost xxxxxxx:80
<VirtualHost xxxxxxxxxx:80>
ServerName xxxxxx.vserver.de
#User confixx
#Group users
DocumentRoot /var/www/confixx/html
php_admin_value safe_mode_exec_dir /var/www/confixx/bin
php_admin_value upload_tmp_dir /var/www/confixx/tmp
ScriptAlias /cgi-bin/ /var/www/cgi-bin/
CustomLog /var/log/httpd/151090.vserver.de_access.log "%h %l %u %t \"%r\" %s %b \"%{Referer}i\" \"%{User-agent}i\""
ErrorLog /var/log/httpd/151090.vserver.de_error.log
</VirtualHost>
Include /etc/httpd/conf/confixx_vhost.conf
# ^- It is imperative that this entry remain at the end of the file
## /CONFIXX

Dort habe ich den ScriptAlias in /var/www/cgi-bin/
geändert und noch folgende Sachen geändert.
Alles in der httpd.conf suchen und evtl. einkommentieren (die # vor dem Eintrag entfernen).

LoadModule cgi_module modules/mod_cgi.so
AddModule mod_cgi.c

<Directory "/var/www/cgi-bin">
AllowOverride None
Options None
Order allow,deny
Allow from all
</Directory>

AddHandler cgi-script .cgi

und das hier unterhalb ergänzen falls man auch Perl-Scripts ausführen möchte.
AddHandler cgi-script .pl

Jetzt klappt´s auch mit dem Nachbarn :D
 
Re: Jetzt klappt es

Dr.Evil said:
Dort habe ich den ScriptAlias in /var/www/cgi-bin/
geändert
Funktioniert Dein Confixx noch? Oder hast Du das sicherheitshalber auf eine andere Subdomain gesetzt?

LoadModule cgi_module modules/mod_cgi.so
AddModule mod_cgi.c
Die Zeilen sind nur für mod-perl-Programmierer interessant. (Grob gesagt: mod-perl != perl)
Im Regelfall fressen alle Module, die man nicht benötigt nur unötig Speicher. (Und der ist auf vServer bekanntlich rar.)

huschi the husch
 
Conifxx klappt einwandfrei

Hallo Huschihusch,

also mein Confixx funktioniert noch einwandfrei. Ich habe sonst auch nichts weiter verändert.

Du hast recht, die beiden Zeilen braucht man nicht dringend. Könnte man wieder auskommentieren.

Jetzt klappt auch der Zugriff der einzelnen Virtual Hosts auf das cgi-bin Verzeichnis.

Viele Grüsse

Dr.Evil
 
Back
Top