Debian Sarge SA24 PHP Safe Mode Ausschalten

Helli

New Member
Hallo!

Ich hab einen PowerServer S mit Debian Sarge und ServerAdmin24. Ich versuche seit Wochen immer wieder den PHP Safe Mode abzuschalten, ohne Erfolg. In jeder php.ini die man finden kann, ist Safe Mode = Off eingestellt, in den anderen, eventuell? interessanten Dateien, wie /etc/apache2/sites_available (welches wohl die Konfigdatei für die in SA24 angelegten Domains ist) sehe ich aber auch keine Safe Mode = xy Option. Ich habe auch von der Möglichkeit gelesen, HTTP Special Einträge irgendwo zu hinterlegen, finde aber auch dazu keine Möglichkeit im ServerAdmin. Die Template-Datei für VirtualHosts Einträge wäre vielleicht noch eine Möglichkeit:
Code:
<VirtualHost *:80>
php_admin_value open_basedir %%homedir%%:/usr/local/lib/php:/tmp
<%%no_php%%>
  php_admin_flag engine off
</%%no_php%%>
DocumentRoot %%homedir%%public_html/
ServerName [url]www.%%domain%%[/url]
Options -Indexes
<%%no_frontpage%%>
  <%%cgi%%>
<IfModule mod_suexec.c>
  ScriptAlias /cgi-bin/ %%homedir%%public_html/cgi-bin/
  SuexecUserGroup %%ftpusername%% %%hauptbenutzergruppe%%
</IfModule>
  </%%cgi%%>
</%%no_frontpage%%>
DirectoryIndex index.htm index.html index.shtml start.htm start.html start.shtml index.php index.php3 index.php4
ServerAlias %%aliases%%
CustomLog "|/usr/local/sa24/cronolog/cronolog --symlink=/usr/local/sa24/logfiles/%%domain%%/access_log --prev-symlink=/usr/local/sa24/logfiles/%%domain%%/current_access_log /usr/local/sa24/logfiles/%%domain%%/%Y/%m/%d/access_log" combined
<%%redirects%%>
  Redirect %%redirect_from%% [url]http://%%redirect_to%%[/url]
</%%redirects%%>
</VirtualHost>

MOD: Bitte [noparse]
Code:
...
[/noparse]-Tags bzw. # im Editor-Menü verwenden!

Aber kann man diese so anpassen daß der Safe Mode Off ist?
 
Last edited by a moderator:
Top