datenbank spielt verrückt

IMMERDRAUF

Registered User
hi,

ich bin s mal wieder :)

unzwar geht es mir um einen seltsamen datenbank fehler...meine datenbank von vserver spielt manchmal verückt, habe jetzt ca. 2 wochen den server...und schon mehrmals kam diese fehler meldung...hier mal ein auszug:


Code:
error in sql-statement: mysql_connect, err-no: 2005
description: Unknown MySQL Server Host '137242.vserver.de' (11)

error in sql-statement: mysql_select_db, err-no: 1044
description: Access denied for user: '@localhost' to database 'usr_web1_1'

error in sql-statement: mysql_query, err-no: 1044
qry: select * from nuke_authors
description: Access denied for user: '@localhost' to database 'usr_web1_1'

Warning: Supplied argument is not a valid MySQL result resource in /var/www/web1/html/portal/includes/sql_layer.php on line 249

error in sql-statement: mysql_num_rows, err-no: 1044
description: Access denied for user: '@localhost' to database 'usr_web1_1'

error in sql-statement: mysql_query, err-no: 1044
qry: select pass from nuke_users where uid=''
description: Access denied for user: '@localhost' to database 'usr_web1_1'

Warning: Supplied argument is not a valid MySQL result resource in /var/www/web1/html/portal/includes/sql_layer.php on line 298

error in sql-statement: mysql_fetch_row, err-no: 1044
description: Access denied for user: '@localhost' to database 'usr_web1_1'

error in sql-statement: mysql_query, err-no: 1044
qry: select pass from nuke_users where uname=''
description: Access denied for user: '@localhost' to database 'usr_web1_1'

Warning: Supplied argument is not a valid MySQL result resource in /var/www/web1/html/portal/includes/sql_layer.php on line 298

error in sql-statement: mysql_fetch_row, err-no: 1044
description: Access denied for user: '@localhost' to database 'usr_web1_1'

error in sql-statement: mysql_query, err-no: 1044
qry: DELETE FROM nuke_whoiswhere WHERE time < 1066254437
description: Access denied for user: '@localhost' to database 'usr_web1_1'

error in sql-statement: mysql_query, err-no: 1044
qry: SELECT time FROM nuke_whoiswhere WHERE username='217.228.79.45'
description: Access denied for user: '@localhost' to database 'usr_web1_1'

Warning: Supplied argument is not a valid MySQL result resource in /var/www/web1/html/portal/includes/sql_layer.php on line 355

error in sql-statement: mysql_fetch_array, err-no: 1044
description: Access denied for user: '@localhost' to database 'usr_web1_1'

error in sql-statement: mysql_query, err-no: 1044
qry: INSERT INTO nuke_whoiswhere (username, time, host_addr, guest, module, url) VALUES ('217.228.79.45', '1066255337', '217.228.79.45', '1', '', '/admin.php?op=SiteStat')
description: Access denied for user: '@localhost' to database 'usr_web1_1'


error in sql-statement: mysql_query, err-no: 1044
qry: select * from nuke_banner
description: Access denied for user: '@localhost' to database 'usr_web1_1'

Warning: Supplied argument is not a valid MySQL result resource in /var/www/web1/html/portal/includes/sql_layer.php on line 249

error in sql-statement: mysql_num_rows, err-no: 1044
description: Access denied for user: '@localhost' to database 'usr_web1_1'

error in sql-statement: mysql_query, err-no: 1044
qry: select bid, imageurl from nuke_banner limit 0, 1
description: Access denied for user: '@localhost' to database 'usr_web1_1'

Warning: Supplied argument is not a valid MySQL result resource in /var/www/web1/html/portal/includes/sql_layer.php on line 298

error in sql-statement: mysql_fetch_row, err-no: 1044
description: Access denied for user: '@localhost' to database 'usr_web1_1'

error in sql-statement: mysql_query, err-no: 1044
qry: select pwd from nuke_authors where aid='immerdrauf'
description: Access denied for user: '@localhost' to database 'usr_web1_1'

Warning: Supplied argument is not a valid MySQL result resource in /var/www/web1/html/portal/includes/sql_layer.php on line 298

nun frag ich mich, ist die einfach nur manchmal nicht erreichtbar...oder ist da was faul...???? seh da selber nicht so durch :shock:
nun steht da viel über sql_layer.php die hat die rechte 666, ist da vieleicht was falsch?
danke euch jetzt schon fuer die hilfe...ach und eurer link bei mir ist euch jetzt schon sicher ;)

IMMERDR@UF
 
Last edited by a moderator:

Thorsten

SSF Facilitymanagement
Staff member
Hallo!
Das kann jetzt ein Schnellschuss sein aber mir ist folgendes aufgefallen:
Ich habe auf meinem vServer öfter Probleme mit der DNS Auflösung. Host not found.
Wenn es bei dir möglich ist,versuch doch den Servernamen durch localhost zu ersetzten.Eventuell sind die Probleme dann weg.

mfG
Thorsten
 

Huschi

Moderator
Staff member
Thorsten said:
Wenn es bei dir möglich ist,versuch doch den Servernamen durch localhost zu ersetzten.Eventuell sind die Probleme dann weg.
Das sollte man eh tun.
Denn eine SQL-Connection an localhost findet über Sockets statt, wärend eine Verbindung an eine Domäne über TCP/IP läuft. D.h. man hat zusätzlich einen Geschwindigkeitsgewinn.
Zusätzlich kann man dann in /etc/my.cnf in der Sektion [mysqld] die Zeile
skip-networking
einfügen. Dann verweigert die Datenbank alle Verbindungen von Außen. Dies bringt nochmal ein Stück Sicherheit auf Deinen vServer.

huschi the husch
 

Huschi

Moderator
Staff member
error in sql-statement: mysql_query, err-no: 1044
qry: INSERT INTO nuke_whoiswhere (username, time, host_addr, guest, module, url) VALUES ('217.228.79.45', '1066255337', '217.228.79.45', '1', '', '/admin.php?op=SiteStat')
description: Access denied for user: '@localhost' to database 'usr_web1_1'
Die meisten Fehler klingen mir aber nach fehlerhafter Konfiguration von phpNuke: statt '@localhost' sollte eigendlich 'web1@localhost' übergeben werden. D.h. Du hast keinen Datenbank-User konfiguriert.

Hast Du denn das Alter der Fehler überprüft? Sind die wirklich aktuell, oder läuft Dein phpNuke eigendlich ohne Fehler?

Test-Möglichkeit:
laß im ssh einfach mit tail -f /var/log/mysql.log laufen (ctrl-C zum beenden benutzen) und surf dann ein bischen auf Deinen Seiten. Sobald sich im ssh was tut sag mal bescheid.

huschi the husch
 

IMMERDRAUF

Registered User
wenn ich tail -f /var/log/mysql.log eingebe passiert
[root@host root]# tail -f /var/log/mysql.log
tail: /var/log/mysql.log: No such file or directory
tail: no files remaining

...muesst entschuldigen, aber kenn mich auch noch nicht so aus mit shell
geb ich nur tail -f ein, passiert nix
[root@host root]# tail -f
 

IMMERDRAUF

Registered User
allso jetzt surf ich ....ging alles..stelle aber fest, das der server gerade abgeht wie sau..kann das sein????
geht alles, als wenn ich dsl 1500 haett :D
 

Thorsten

SSF Facilitymanagement
Staff member
Irgendetwas treibt/trieb Server4you am Hostsystem.
Schaut doch mal in eure Sys-Logs. Meine waren heute morgen alle leer!

mfG
Thorsten
 

Huschi

Moderator
Staff member
Thorsten said:
Irgendetwas treibt/trieb Server4you am Hostsystem.
Schaut doch mal in eure Sys-Logs. Meine waren heute morgen alle leer!
(Logrotate?)
Bei mir (Server 20) ist alles Normal.

huschi the husch
 

IMMERDRAUF

Registered User
ne ist alles da...werd jetzt mal propieren mit dem web1@localhost....das seltsame ist aber das der fehler nicht imme kommt, und wenn er da ist und ich aktualisiere haut wieder alles hin...
 

Thorsten

SSF Facilitymanagement
Staff member
Na ja,was passiert ist kann ich leider nicht so genau sagen. :?
Ich habe jedenfalls keinerlei außergewöhnliche Aktionen gestartet und trotztdem sind die Logs weg.Nach einem restart des syslog ging es dann auch wieder.

Life is hard...
Thorsten
 

IMMERDRAUF

Registered User
Sobald sich im ssh was tut sag mal bescheid.
allso tut sich nix...glaub ist alles wie beim start:

[root@host root]# tail -f /var/log/mysqld.log
Cannot initialize InnoDB as 'innodb_data_file_path' is not set.
If you do not want to use transactional InnoDB tables, add a line
skip-innodb
to the [mysqld] section of init parameters in your my.cnf
or my.ini. If you want to use InnoDB tables, add for example,
innodb_data_file_path = ibdata1:30M
But to get good performance you should adjust for your hardware
the InnoDB startup options listed in section 2 at
http://www.innodb.com/ibman.html
/usr/libexec/mysqld: ready for connections

allso deute ich das alles ok ist oder was denkt ihr?[/quote]
 

IMMERDRAUF

Registered User
allso nochmal...hab wieder ne fehler meldung..sieht genau so aus.
nun hab ich mal in der config.php meines portales in der zeile $dbhost = "xxx"; web1@localhost und nur localhost propiert...ohne erfolg den da geht gleich garnix :(
allso hab ich wieder xxxxxx.vserver.de reingesetzt, da geht es, aber leider kommt da ab und zu dieser bloede fehler wie oben "kann datenbank nicht ereischen"

nu? noch einer ne idee?

IMMERDR@UF


jetzt schau ich gerad mal auf meine daten bank, und muss mit verwundern feststellen das da sehr eigenartige dinge stehen..


Link zum Bild

seht ihr da das % zeichen, da haut doch was net hine oder wie seh ich das? wie kommt das aber dort hin?
 

Thorsten

SSF Facilitymanagement
Staff member
Hallo Immerdrauf!
Habe mir gerade mal deine Seite angesehen.Funktioniert bei mir problemlos.Die 'Fehlermeldung' von mysql (INNODB) ist normal.
Interessant wäre deine Konfiguration von mysql.Nomalerweise mache ich das folgendermaßen:
Benutzer root hat vom host localhost alle Berechtigungen (mit Kennwort).
In die config.php von phpNuke trägst du als host localhost ein.Als user root mit entsprechendem Kennwort.Ich habe in keiner einzigen config.php so etwas wie user@...

mfG
Thorsten
 

IMMERDRAUF

Registered User
Die meisten Fehler klingen mir aber nach fehlerhafter Konfiguration von phpNuke: statt '@localhost' sollte eigendlich 'web1@localhost' übergeben werden
deswegen hatte ich es so propiert baer wie gesagt da ging gleich garnix, muss auch dabei bleiben den user web1 zu nennen, da ich ja mehrere datenbanken anlegen will...aber das mit dem % sagst ist i.o.? dacht da kommt auch localhost rein :rolleyes:
nur wenn du sagst es haut alles hin warum bekomm ich dann ab und zu diese fehlermeldungen??? irgendwie ist die datenbank halt nicht immer erreichbar...und das muss ja an was liegen.nur mein latein ist am ende
 

Thorsten

SSF Facilitymanagement
Staff member
IMMERDRAUF said:
jetzt schau ich gerad mal auf meine daten bank, und muss mit verwundern feststellen das da sehr eigenartige dinge stehen..
Link zum Bild
Ich habe das mal aus 'Design Gründen' geändert.

mfG
Thorsten
 

Thorsten

SSF Facilitymanagement
Staff member
IMMERDRAUF said:
nur wenn du sagst es haut alles hin warum bekomm ich dann ab und zu diese fehlermeldungen??? irgendwie ist die datenbank halt nicht immer erreichbar...und das muss ja an was liegen.nur mein latein ist am ende
Wie gesagt,funktioniert bei mir problemlos.
Die Konfiguration muss also richtig sein. Eventuell hat das Server4you Hostsystem zur Zeit einige Aussetzer - keine Ahnung. :rolleyes:
 

IMMERDRAUF

Registered User
ok, glaub jetzt hab ich auch....hab das % mit localhost gewechselt, und die config.php auch auf localhost...jetzt funzt es hofentlich, denk mal schon

na dann bis zum nächsten male.echt klasse hier
 

Huschi

Moderator
Staff member
IMMERDRAUF said:
ok, glaub jetzt hab ich auch....hab das % mit localhost gewechselt, und die config.php auch auf localhost...jetzt funzt es hofentlich, denk mal schon
Nachbemerkung:
Die config.php kann/sollte so aussehen:
---
$dbhost = "localhost";
$dbuname = "web1";
$dbpass = "...";
---

Und das % bei Hosts der MySql-Rechten ist ein Jokerzeichen und heißt: "Eschal wo der herkömmt. Isch nemmm aaallesch."
Dü kannst auch bei User ein % einsetzen und das Passwort leer lassen.
Das kommt besonders gut. :D

huschi the husch
 
Top