Curl unter Debian Etch führt zu Abhängigkeitsproblemen 4

Riddler

New Member
Hallo zusammen,

ich versuchte gerade Curl zu installieren, was sich nicht besonders schwierig rausstellte. Installiere ich jedoch die Brücke zu php5, gibt es Abhängigkeitsprobleme:

Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut... Fertig
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder dass, wenn Sie die
Unstable-Distribution verwenden, einige erforderliche Pakete noch nicht
kreiert oder aus Incoming herausbewegt wurden.

Da Sie nur eine einzige Operation angefordert haben, ist es sehr wahrscheinlich,
dass das Paket einfach nicht installierbar ist und eine Fehlermeldung über
dieses Paket erfolgen sollte.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben nichterfüllte Abhängigkeiten:
php5-curl: Hängt ab: php5-common (= 5.2.0+dfsg-8+etch15) aber 5.2.8-0.dotdeb.1 soll installiert werden

Meine Sources.list sieht aus wie folgt:

deb http://ftp.tu-chemnitz.de/pub/linux/debian/debian/ etch main non-free contrib
deb-src http://ftp.tu-chemnitz.de/pub/linux/debian/debian/ etch main non-free contrib

deb http://security.debian.org/ etch/updates main contrib non-free
deb-src http://security.debian.org/ etch/updates main contrib non-free

Wo ist der Fehler?
 

djrick

Registered User
Hattest du mal ne andere sources.list?
Da steht nämlich was von dot-deb. Die Dot-Dep Repo taucht aber nicht in deiner sources.list auf.
Hast du nach dem Ändern ein "apt-get update" gemacht?

Wenn du dir sicher bist, dass alles in Ordnung ist:
Code:
apt-get install -f
apt-get update
apt-get install <was du installieren willst>
 

Riddler

New Member
Hi,

nein hatte ich nicht. Wenn ich es so mache, wie Du beschrieben hast (siehe meinen ersten Post) bekomme ich ja diese Meldung:

Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut... Fertig
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder dass, wenn Sie die
Unstable-Distribution verwenden, einige erforderliche Pakete noch nicht
kreiert oder aus Incoming herausbewegt wurden.

Da Sie nur eine einzige Operation angefordert haben, ist es sehr wahrscheinlich,
dass das Paket einfach nicht installierbar ist und eine Fehlermeldung über
dieses Paket erfolgen sollte.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben nichterfüllte Abhängigkeiten:
php5-curl: Hängt ab: php5-common (= 5.2.0+dfsg-8+etch15) aber 5.2.8-0.dotdeb.1 soll installiert werden
E: Kaputte Pakete

Ich hoffe jemand kann mir helfen?
 

djrick

Registered User
Hier mal eine Orginal-Debian Sources.list:
Code:
deb http://ftp.de.debian.org/debian/ etch main non-free contrib
deb-src http://ftp.de.debian.org/debian/ etch main non-free contrib

deb http://security.debian.org/ etch/updates main contrib non-free
deb-src http://security.debian.org/ etch/updates main contrib non-free
damit:
Code:
apt-get install -f
apt-get update
apt-get install <dein packet>
 

Riddler

New Member
Hallo,

Danke Dir. Jedoch wie erwartet folgende Meldung:

ks201694:~# apt-get install php5-curl
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut... Fertig
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder dass, wenn Sie die
Unstable-Distribution verwenden, einige erforderliche Pakete noch nicht
kreiert oder aus Incoming herausbewegt wurden.

Da Sie nur eine einzige Operation angefordert haben, ist es sehr wahrscheinlich,
dass das Paket einfach nicht installierbar ist und eine Fehlermeldung über
dieses Paket erfolgen sollte.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben nichterfüllte Abhängigkeiten:
php5-curl: Hängt ab: php5-common (= 5.2.0+dfsg-8+etch15) aber 5.2.8-0.dotdeb.1 soll installiert werden
E: Kaputte Pakete

Gruß
 

Riddler

New Member
Hallöchen,

das ist soweit richtig. Leider bekomme ich nun die Meldung, dass das Paket nicht heruntergeladen werden kann. Liegt wahrschenlich an der Quelle, oder?

Re-Installation von php5-common ist nicht möglich,
es kann nicht heruntergeladen werden.
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.

Gruß
 
Top