Connection refused ... Habe mein LAMP kastriert :-(

Wurzer

Registered User
Hallo Ihr Wissenden, ich hätt da gern mal ein Problem ... :oops:

Ich habe einen alten 586er auserkoren Tsetserver zu werden. Nachdem ich ihm RedHat 9.0 mit Indianer SQL&PHP spendiert habe war er (kurze Zeit) auch herrlich kommunikativ.
Die Installation von Mambo, OSCommerce funzte auch, immer noch war der Kollege bemüht allen Anforderungen gerecht zu werden (intern sowie extern). Um dann die diversen Fehlermeldungen und Warnungen vom Tisch zu kriegen musste ich an diversen Konfigurationsdateien basteln. Der "Erfolg": der Zugriff ist nur noch über das lokale Netz (IP 192.168.x.x) erreichbar. Extern geht gar nix mehr. Auch der Versuch mit Mozilla einen externen Server zu erreichen scheitert. Der Router routet und der Rest des Netzes hat auch externen Zugriff.
Wenn ich versuche extern auf meinen Server zuzugreifen kommt "Seite nicht gefunden" wenn ich versuche mit Mozilla vom Server aus externe Seiten aufzurufen kommt "The Connection was refused when attempting to contact www......"
Hat irgendjemand eine Idee mit welcher Konfigurationseinstellung ich das verwurschtelt habe?

Solltet ihr es noch nicht gemerkt haben ... bin Linuxnewbie :oops:
 

Huschi

Moderator
Staff member
Wurzer said:
Um dann die diversen Fehlermeldungen und Warnungen vom Tisch zu kriegen musste ich an diversen Konfigurationsdateien basteln.
Erste Unbekannte für uns:
Welche Konfigurationen hast Du verändert?
Welche Fehlermeldungen & Warnungen waren es?

Der "Erfolg": der Zugriff ist nur noch über das lokale Netz (IP 192.168.x.x) erreichbar. Extern geht gar nix mehr. Auch der Versuch mit Mozilla einen externen Server zu erreichen scheitert. Der Router routet und der Rest des Netzes hat auch externen Zugriff.
Zweite Unbekannte: Dein Netzwerk.
Wenn ich es richtig verstehe hast Du mindestens das:
S: Server (586er mit RH9)
W: Workstation (wo Du arbeitest)
R: (Hardware-)Router (mit Verbindung ins Internet)
I: irgendein Internet-Server, oder andere Maschine von der man auf S kommen soll.

Welche Verbindungen funzen nun?
W -> S : ping? ssh? http?
S -> W : ping?
S -> R : ping?
W -> R -> I : ping:ja http:ja
S -> R -> I : ping? http?

Wenn ich versuche extern auf meinen Server zuzugreifen kommt "Seite nicht gefunden" wenn ich versuche mit Mozilla vom Server aus externe Seiten aufzurufen kommt "The Connection was refused when attempting to contact www......"
Mozilla auf dem Server (siehe oben)?
Das klingt aber, als ob er zumindest den Namen auflösen kann.
Von extern auf Deinen Server per IP oder dyndns.org o.Ä.?

Solltet ihr es noch nicht gemerkt haben ... bin Linuxnewbie :oops:
Hättest Du es nicht gesagt, wäre es noch niemanden aufgefallen.

Bin mal gespannt ob wir das wieder hinbiegen können. :)

huschi the husch
 

Wurzer

Registered User
Problem gelöst ... der Kastrat funzt wieder :)

Irgendwie habe ich oder der "Rothut" die Einstellung des Routers vergniesgnaddelt. Das fiel mir nach eingabe von "Route" auf. Die Reinstallation der Netzwerkkarte brachte dann den gewünschten Erfolg.
Ist doch unglaublich was so eine 0 statt einer 1 alles bewirken kann :D

Auf jeden Fall vielen Dank für die "angedrohte" Hilfe :D :D :D
 

Top