Confixx weiße Seite

smithy

New Member
Hallo
Habe gerade versucht Confixx auf meinem Rootserver zu installieren und es lief auch alles sauber ab also die Installation keine Fehler oder ähnliches doch die confixx Panel Seite lässt sich nicht öffnen es kommt nur eine weiße Seite mit Datei speichern.

Jemand eine Idee was ich falsch gemacht habe?

Link: http://confixx.fastnetworks.de


Vielen Dank!

MFG
Amir
 

svenr

Registered User
Was sagt denn das entsprechende Log?
Ist php entsprechend geladen?
Was sagt phpinfo?:
PHP:
<?php phpinfo(); ?>
Welcher Anleitung bist Du gefolgt... usw usw... Fragen über Fragen

Gruß Sven
 

smithy

New Member
Nach der Anleitung:
http://blog.murawski.ch/2011/04/confixx-server-aufsetzen-debian-squeeze-howto/

Diesen Punkt versteh ich irgendwie nicht vielleicht liegts daran?

Und nun spätestens kann man http://SERVERNAME aufrufen und die Confixx Lizenz einspielen.
Bei Include Fehlern bei der Confixx Webseite / Confixx zeigt nur weisse Seite / Kein Login Button auf der Confixx Seite

Um diese zu beseitigen muss man gegebenenfalls den include_path anpassen von Confixx. Da Confixx nur mit mod_php läuft und nicht per suphp muss man dies in der /etc/apach2/confixx_mhost.conf anpassen.

Dort sucht man sich ServerName dein.confixx.host und im gleichen VirtualHost ändert man die include_path Variable ab wie folgt:

php_admin_value include_path “.:/var/www/confixx/html/include:/var/www/confixx/html:/var/www/confixx/html/PEAR”

Danach startet ihr den Apache2 Dienst erneut mit:

/etc/init.d/apache restart
Wo sehe ich ob PHP geladen ist?
 

svenr

Registered User
Code:
apache2ctl -M
sollte Dir die geladenen Module ausgeben. Da siehste dann auch ob php dabei ist.

Gruß Sven
 

smithy

New Member
Loaded Modules:
core_module (static)
log_config_module (static)
logio_module (static)
mpm_prefork_module (static)
http_module (static)
so_module (static)
alias_module (shared)
auth_basic_module (shared)
authn_file_module (shared)
authz_default_module (shared)
authz_groupfile_module (shared)
authz_host_module (shared)
authz_user_module (shared)
autoindex_module (shared)
cgi_module (shared)
deflate_module (shared)
dir_module (shared)
env_module (shared)
expires_module (shared)
include_module (shared)
mime_module (shared)
negotiation_module (shared)
python_module (shared)
reqtimeout_module (shared)
rewrite_module (shared)
setenvif_module (shared)
ssl_module (shared)
status_module (shared)
suexec_module (shared)
suphp_module (shared)
Syntax OK
 

svenr

Registered User
Ich kenne die genauen Anforderungen an Confixx nicht.
Aber im Prinzip .... schauen ob die entsprechenden PHP Module installiert sind..... dpkg -l und nach php greppen .... wenn nicht nachinstallieren und laden. a2enmod modulname

Gruß Sven
 

s24!

Registered User
suPHP ist eine Art Wrapper für PHP, kein PHP. Als Administrator eines Rootservers weißt du das aber, nicht wahr?
 

smithy

New Member
Also php läuft nun und jetzt kommt kein datei speichern mehr sondern nur eine klare weiße seite


Loaded Modules:
core_module (static)
log_config_module (static)
logio_module (static)
mpm_prefork_module (static)
http_module (static)
so_module (static)
alias_module (shared)
auth_basic_module (shared)
authn_file_module (shared)
authz_default_module (shared)
authz_groupfile_module (shared)
authz_host_module (shared)
authz_user_module (shared)
autoindex_module (shared)
cgi_module (shared)
deflate_module (shared)
dir_module (shared)
env_module (shared)
expires_module (shared)
include_module (shared)
mime_module (shared)
negotiation_module (shared)
php5_module (shared)
python_module (shared)
reqtimeout_module (shared)
rewrite_module (shared)
setenvif_module (shared)
ssl_module (shared)
status_module (shared)
suexec_module (shared)
suphp_module (shared)
Syntax OK




was könnte denn jetzt noch falsch sein?
 

smithy

New Member
http://confixx.fastnetworks.de/phpinfo.php

Ich glaube dieser Schritt ist noch notwenig aber ich weis nicht wie ich das jetzt genau einfügen soll ohne syntax error oder ähnlich so sieht meine confixx_mhost.conf aus:

############### PARALLELS CONFIXX APACHE MAIN CONFIG FILE #################
# created at Wed May 22 00:24:53 2013
#
# !!! Do not make any changes in this file !!!
#
# 1. We cannot guarantee that the software will work properly, if
# the contents of this file are modified.
# 2. This file would be rewritten after each Parallels Confixx software update and
# in some other cases. Thus all your changes would be lost unless you made
# a backup of the file.
#
# If you need to modify this file, you can insert some custom "Include"
# directives. E.g.
# Include /path/to/your/file
# Includes inserted directly after <VirtualHost> tag would keep their
# location inchanged after the file is updated. Other includes would
# be moved to be inserted before the </VirtualHost> tag.
##########################################################################


<Directory "/var/www/confixx/html">

AllowOverride all

<IfModule mod_access.c>
Allow from all
</IfModule>
<IfModule mod_authz_host.c>
Allow from all
</IfModule>

<IfModule mod_rewrite.c>

RewriteEngine On
Options +FollowSymlinks

RewriteRule ^reseller/res[0-9]+/(.*)$ reseller/$1 [L]

RewriteRule ^user/[a-zA-Z][-a-zA-Z0-9_]{0,4}[0-9]+/(.*)$ user/$1 [L]

RewriteRule ^ftplogin/[a-zA-Z][-a-zA-Z0-9_]{0,4}[0-9]+/(.*)$ ftplogin/$1 [L]
RewriteRule ^ftplogin/[a-zA-Z][-a-zA-Z0-9_]{0,4}[0-9]+f[0-9]+/(.*)$ ftplogin/$1 [L]

RewriteRule ^poplogin/[a-zA-Z][-a-zA-Z0-9_]{0,4}[0-9]+p[0-9]+/(.*)$ poplogin/$1 [L]

</IfModule>

AddDefaultCharset off

suPHP_engine on

</Directory>


NameVirtualHost 85.25.243.177:80

<VirtualHost 85.25.243.177:80>

ServerName 85.25.243.177

DocumentRoot /var/www/confixx/html/gesperrt

Options FollowSymLinks
suPHP_ConfigPath /etc/apache2/confixx_phpini
<IfModule mod_dir.c>
DirectoryIndex index.php index.html index.htm index.shtml index.cgi
</IfModule>


</VirtualHost>

<VirtualHost 85.25.243.177:80>

ServerName confixx.fastnetworks.de

#User confixx
#Group confixx
DocumentRoot /var/www/confixx/html
Options FollowSymLinks

suPHP_ConfigPath /etc/apache2/confixx_phpini

ScriptAlias /cgi-bin/ /var/www/confixx/html/cgi-bin/

<IfModule mod_dir.c>
DirectoryIndex index.html index.htm index.shtml index.cgi index.php
</IfModule>


CustomLog /var/log/apache2/confixx.fastnetworks.de_access.log "%h %l %u %t \"%r\" %s %b \"%{Referer}i\" \"%{User-agent}i\""
ErrorLog /var/log/apache2/confixx.fastnetworks.de_error.log


</VirtualHost>

NameVirtualHost 85.25.243.177:443

<VirtualHost 85.25.243.177:443>

ServerName 85.25.243.177

DocumentRoot /var/www/confixx/html/gesperrt

Options FollowSymLinks
suPHP_ConfigPath /etc/apache2/confixx_phpini
<IfModule mod_dir.c>
DirectoryIndex index.php index.html index.htm index.shtml index.cgi
</IfModule>


<IfModule mod_ssl.c>

SSLEngine on
SSLCertificateKeyFile /etc/ssl.key/confixx.fastnetworks.de.key
SSLCertificateFile /etc/ssl.crt/confixx.fastnetworks.de.crt



SetEnvIf User-Agent ".*MSIE.*" \
nokeepalive ssl-unclean-shutdown downgrade-1.0 force-response-1.0

<Files ~ "\.(cgi|shtml|phtml|php3?)$">
SSLOptions +StdEnvVars
</Files>

<Directory "/var/www/confixx/html/cgi-bin">
SSLOptions +StdEnvVars
</Directory>

</IfModule>


</VirtualHost>

<VirtualHost 85.25.243.177:443>

ServerName confixx.fastnetworks.de

#User confixx
#Group confixx
DocumentRoot /var/www/confixx/html
Options FollowSymLinks

suPHP_ConfigPath /etc/apache2/confixx_phpini

ScriptAlias /cgi-bin/ /var/www/confixx/html/cgi-bin/

<IfModule mod_dir.c>
DirectoryIndex index.html index.htm index.shtml index.cgi index.php
</IfModule>


<IfModule mod_ssl.c>

SSLEngine on
SSLCertificateKeyFile /etc/ssl.key/confixx.fastnetworks.de.key
SSLCertificateFile /etc/ssl.crt/confixx.fastnetworks.de.crt



SetEnvIf User-Agent ".*MSIE.*" \
nokeepalive ssl-unclean-shutdown downgrade-1.0 force-response-1.0

<Files ~ "\.(cgi|shtml|phtml|php3?)$">
SSLOptions +StdEnvVars
</Files>

<Directory "/var/www/confixx/html/cgi-bin">
SSLOptions +StdEnvVars
</Directory>

</IfModule>


CustomLog /var/log/apache2/confixx.fastnetworks.de_access.ssl.log "%h %l %u %t \"%r\" %s %b \"%{Referer}i\" \"%{User-agent}i\""
ErrorLog /var/log/apache2/confixx.fastnetworks.de_error.ssl.log


</VirtualHost>

Include /etc/apache2/confixx_vhost.conf
# ^- Dieser Eintrag sollte unbedingt am Ende der Datei bleiben
## /PARALLELS CONFIXX
 
Last edited by a moderator:
Top