CloneZila Alternative?

jmar83

Member
Kennt jemand was?

Muss-Kriterien:

- Kostenlos, jedoch nicht unbedingt Opensource
- Möglichkeit zum Booten
- Möglichkeit ganze Datenträger zu sichern und wiederherzustellen

Danke für die Feedbacks..
 

chris4000

Member
Warum überhaupt eine Alternative? Clonezilla erfüllt alle Anforderungen. Acronis hat eine bessere Benutzeroberfläche und kann inkrementelle Images, aber ist halt auch nicht kostenlos.
 
Last edited by a moderator:

jmar83

Member
Habe ein ganz gewaltiges Problem mit meinem HW-RAID10 auf einem LSI-9212-4i4e:

https://serversupportforum.de/threads/lsi-megaraid-fehlermeldung.59114/

Nachdem ich die Quellplatte erneut gebootet hatte und unter Win7 chkdsk /F /V ausgeführt habe liefe CloneZilla zwar durch (mit der rescue-Option) jedoch auch mit Fehlermeldungen - welche nach chkdsk aber nicht mehr zum Abbruch führten.

Das Image der ges. HD habe ich per SSH auf nen Linux-Server gesichert. Beim restore kam eine Meldung mit "deflate" error oder sowas.

Nun versuche ich mal direkt vom RAID10-Array auf eine 1TB HD am Mainboard-Cotroller zu sichern - auch mit CloneZilla... habe mir heute extra ne 1TB-HD gekauft, weil die im Laden (kein Computershop) nur externe Platten mit 1TB hatten musste ich das Teil halt auseinandernehmen. (=Garantieverlust)

Vom einem Problem zum Anderen - ein ganzer Rattenschwanz, was das Zeugs verursacht...

(Wie ich inzwischen vermute, hat das RAID-Array die defekte Platte auf die anderen synchronisiert. ("punctation" oder so?))

Wenn es nun direkt (vom RAID zur einzelnen Platte am Mainboard) klappt mit CloneZilla werde ich später jeder der 4-RAID-Platten mit dem "HDD Low Level-Format" Tool bearbeiten und 2x RAID0 am Controlller machen welches ich dann unter dem OS als RAID1 zusammenfasse... so sollte ich dann das OS melden, wenn eine der 4 Platten Stress macht.

Und das OS werd ich dann auf die heute gekaufte PLatte tun - ohne RAID.

Zum ko**en, das Ganze!!

Eine alternative wäre evtl. der Amazon Storage mit ISCSI..(?)
 

jmar83

Member
RAID scheint irgendwie für nix zu sein, zumindest mit LSI:

- Arrays geht kaputt und man merkt NULL und NIX davon
-> deswegen fühlt man sich in trügerischer Sicherheit

- Festplatte kann nciht während laufenden Beitrieb getauscht werden. (Dafür müsste ich wohl LSI-Schrott für nen 4-stelligen Betrag kaufen?)

- Verursacht noch mehr Aufwand und Kosten als kein RAID

- etc pp.!!


...schuld ist wahrscheinlich der Herr Kollege, bei dem der Server zurvor war. Dieser Vollpfosten hat wohl einfach mal den Stecker gezogen beim PLatzwechsel des Servers. (besser gesagt ex-Kollege, falls sich meine Vermutung bewahrheitet!! ;-))
 
Last edited by a moderator:

jmar83

Member
Ja, die Fehlermeldung tritt auch beim Vorgang lokales RAID auf lokale HD auf:

"Can't read sector at xxx, lost data"

Ich geh allerdings davon aus, dass in diesen Bereichen keine Dateien sind. Und zum Abbruch führ die MEldung auch nicht. Immerhin.

Nachtrag: Es könnte auch dran liegen, dass die 4 von mir verwendeten Seagate-Video-Platten inkompatibel zum HW-RAID von LSI sind, und ich deswegen nciht automatisch (SMART?) benachtrichtigt werde, sondern erst beim Konsistenzcheck?

Nachtrag 2: Nun erstelle ich mir man eine "Paragon Rescur Boot Disk", geht allerdings in der gratis-Version nur mit WinPE... keine Ahnung ob man dann dort nen SSH-Server als Ziel für das HD-Image verwenden kann. Keine Ahnung. Aber wenn es nun mit CloneZilla von lokalem RAID zu lokaler HD klappt..? Hmmm.? Mal schauen,,

Nachtrag 3: Dass der Controlller defekt ist, halte ich für ausgeschlossen - nur ziemlich schrottig!

Nachtrag 4: Klonvorgang lief bis zu 100%, allerdings Neustart beim booten von der geklonten PLatte. Nun ist Win7-Systemreparatur angesagt. Mal schauen..

Nachtrag 5: Nun passiert das hier: https://www.drwindows.de/windows-7-allgemein/32687-geloest-abbild-windows-7-echtheit-windows-kopie.html

Nachtrag 6: Ein anschliessend der einzelnen PLatte an den LSI-Controller (andere sind weg) ohne RAID hilfe aux nix - weiterhin das Lizensierungsproblem.

Nächsten gehe ich mit der Kiste und einem Kanister Benzin in den Wald!!!!!!!!!
 
Last edited by a moderator:

marce

Well-Known Member
Hardware-Raid auch. Ich sehe beim TE eher ein ISO-Layer-8-Problem vorliegen...

"Als wir noch eigene Hardware hatten" waren da "einige" LSI-HW-Raid-Controller verbaut. Keinerlei Probleme, über Jahre hinweg. Auch sonst erfreuen sich die Dinger AFAIK begründeter Beliebtheit und sind zuverlässig und machen genau das, was sie sollen.
 

mr_brain

Registered User
RAID scheint irgendwie für nix zu sein, zumindest mit LSI:

- Arrays geht kaputt und man merkt NULL und NIX davon
-> deswegen fühlt man sich in trügerischer Sicherheit

- Festplatte kann nciht während laufenden Beitrieb getauscht werden. (Dafür müsste ich wohl LSI-Schrott für nen 4-stelligen Betrag kaufen?)

- Verursacht noch mehr Aufwand und Kosten als kein RAID

- etc pp.!!


...schuld ist wahrscheinlich der Herr Kollege, bei dem der Server zurvor war. Dieser Vollpfosten hat wohl einfach mal den Stecker gezogen beim PLatzwechsel des Servers. (besser gesagt ex-Kollege, falls sich meine Vermutung bewahrheitet!! ;-))
- Wieso sollte man nichts von dem Kaputtgehen des RAID merken? Beim LSI gibt es die Optionen "Consistency Check Reoccurrence".

- Hotswap kann eigentlich jeder LSI (mindestens seit der 8000er-Serie). Vielleicht wird eine Backplane verwendet, die dazwischen funkt?

- Für die Fälle mit dem Stecker ziehen gibt es die zusätzlichen BBU btw. Cache Vault.
 
Last edited by a moderator:

mr_brain

Registered User
Ja, die Fehlermeldung tritt auch beim Vorgang lokales RAID auf lokale HD auf:

"Can't read sector at xxx, lost data"

Ich geh allerdings davon aus, dass in diesen Bereichen keine Dateien sind. Und zum Abbruch führ die MEldung auch nicht. Immerhin.
Welche Platten (Hersteller und Model) verwendest du? Eventuell hat das OS Probleme mit 4k-Platten an dem Controller. Ist mir beispielsweise von 4k-Platten unter VMware 6.0 bekannt. Ggf. dann das ganze mal mit 512e- oder 512n-Platten testen.
 

jmar83

Member
Danke fürs Feedback.

Ich verwende aktuell 4x st500vt000-1dk14 als HW-RAID10. Die sind jedenfalls nicht in der Kompatibilitätsliste für die "Entry Level Controller" vom Broadcom...

Habe mich für die Videoplatten entschieden weil diese nicht allzu hochgezüchtet (keine 7200U/Min.) sowie für den Dauerbetrieb ausgelegt sind.

"Eventuell hat das OS Probleme mit 4k-Platten an dem Controller. Ist mir beispielsweise von 4k-Platten unter VMware 6.0 bekannt. Ggf. dann das ganze mal mit 512e- oder 512n-Platten testen."
Verstehe Dich leider nicht ganz, kannst Du das mehr präzisieren?


"Ankündigung einer Straftat?"
Nicht wirklich! ;-)


Wieso sollte man nichts von dem Kaputtgehen des RAID merken? Beim LSI gibt es die Optionen "Consistency Check Reoccurrence".
SMART (oder die Controllersoftware) sollte sich eigentlich da melden, es sollte eigentlich nicht notwendig sein irgendwelche Tests zu machen. Am besten BEVOR ein richtiges Problem vorhanden ist.
Oder habe ich da was falsch verstanden?

"Ich sehe beim TE eher ein ISO-Layer-8-Problem vorliegen..."
Das Problem sitzt vor dem Rechner meinst Du? Wenn ich mir die ISO-OSI-Layers anschaue, dann sehe ich nur 7: https://de.wikipedia.org/wiki/OSI-Modell

...ist schon lange her, als ich das zum letzten Mal angeschaut habe. ;-)

Evtl. habe ich beim Thema RAID was grundlegend falsch verstanden? Dass es kein Backup ersetzt ist mir jedenfalls klar!!
 
Last edited by a moderator:

mr_brain

Registered User
Bei 4k, 512n und 512e handelt es sich um die Sektorgröße. Angaben dazu findest du i.d.R. im Datenblatt der HDD.

Der "Consistency Check" hat nichts mit dem SMART der HDD zu tun. Es betrifft das RAID. Zwei verschiedene paar Schuhe. Der "Consistency Check" fähr ein Abgleich der Daten bei RAID1 bzw. überprüft das Parity.
 

danton

Debian User
Habe mich für die Videoplatten entschieden weil diese nicht allzu hochgezüchtet (keine 7200U/Min.) sowie für den Dauerbetrieb ausgelegt sind.
Naja, eigentlich sind für den normalen RAID-Betrieb NAS-Platten besser geeignet (Bei WD die Red-Serie hat z.B. auch nur 5400 U/Min), Videoplatten sind zwar auch für den Dauerbetrieb vorgesehen, haben aber aber andere Anforderungen (z.B. das sie konstant eine bestimmte Datenmenge wegschreiben können) und ein entsprechendes Verhalten der Firmware.

SMART (oder die Controllersoftware) sollte sich eigentlich da melden, es sollte eigentlich nicht notwendig sein irgendwelche Tests zu machen. Am besten BEVOR ein richtiges Problem vorhanden ist.
SMART ist ein Verfahren, bei dem Festplatten bestimmte Zustände erfassen und anhand derer eine Vorhersage abgeben, wie gut der Zustand der Platte ist. Aber es ist nur einer Interpretation von Daten und auch abhängig von der HDD-Firmware, was da überhaupt für Daten mitgeloggt werden. Daher kommt es auch immer wieder vor, dass Platten ausfallen, obwohl sie laut SMART in Ordnung sein müssten. Um mal eine Analogie zu verwenden: SMART liefert oft Indizien, aber nur selten Beweise.
 

jmar83

Member
Nochmal besten Dank für die Tipps!! Das Thema hat sich vorerst gelöst: https://serversupportforum.de/threads/lsi-megaraid-fehlermeldung.59114/

(Allerdings sind wieder weitere Frage aufgetreten)

Eine brauchbare Alternative zu CloneZilla wüsste niemand?

Habe mir noch die gratis-Version vom Paragon Partition Manager heruntergeladen, und damit ne Boot-CD ("WinPE") erstellt. Allerdings kam die nicht zu Einsatz.

Kennt jemand diese Software, wäre die brauchbar und ein HD-Image (komplett, alle Partitionen) auf über SSH (SFTP/SCP) oder ISCSI zu sichern?
 
Top