CentOS 5: Problem mit Plesk 9.3.0 und openssl 0.9.8e-12.el5_4.6

siradlib

Blog Benutzer
Hallo,

vielleicht als Warnung/Hinweis an andere: Bei meinen zwei CentOS-Servern wurde heute über "yum upgrade" u.a. dieses Paket angeboten:
openssl.i686 0:0.9.8e-12.el5_4.6
Sobald ich dieses Paket installiere, versagt nach dem nächsten
Code:
/etc/init.d/psa restart
Plesk den Dienst, es erscheint nur "starting Plesk... failed"

Eine kleine Recherche im Netz half nicht wirklich weiter, und aus "Instinkt" ;) tippte ich auf ein Problem mit dem OpenSSL-Paket. Und siehe da, nach einer (Re-) Installation des OpenSSL-Paketes von Parallels läuft Plesk wieder:
Code:
wget http://autoinstall.plesk.com/PSA_9.3.0/update-rpm-CentOS-5-i386/openssl-0.9.8e-12.el5.i386.rpm
rpm -U --force openssl-0.9.8e-12.el5.i386.rpm
Beide OpenSSL-Pakete haben übrigens dieselbe Version.

Kann sich darauf jemand einen Reim machen? Wie sollte ich weiter vorgehen?
Ich schau gleich mal in den CentOS-Bugtracker.

LG siradlib
 
Last edited by a moderator:

siradlib

Blog Benutzer
Gab es denn von PLESK in den einschlägigen Logfiles keine weiteren Details ?

EDIT: Lies mal hier !

YUM update of mod_ssl, openssl, httpd on RHEL 5.4 hosts breaks psa

http://forum.parallels.com/showthread.php?t=100247

Danke für den Tipp, das wars/ist es! :)
In Deinem Link ist auch ein Auszug aus der /var/log/sw-cp-server/error_log. Dieselben Fehlermeldungen habe ich auch hier:
Code:
2010-03-29 11:49:28: (log.c.75) server started
2010-03-29 11:49:28: (network.c.336) SSL: error:00000000:lib(0):func(0):reason(0)
Da die Meldungen so schön nichtssagend sind, konnte ich mir darauf bloß keinen Reim machen... :mad:

Ich habe vorübergehend in der /etc/yum.conf einen Eintrag vorgenommen, damit OpenSSL nicht aktualisiert wird:
Code:
# exclude openssl, because openssl-0.9.8e-12.el5_4.6 breaks Plesk 9.3.0
# see http://forum.parallels.com/showthread.php?t=100247
exclude = openssl*
Aber das ist ja auch wieder extrem eklig... :eek:
 
Last edited by a moderator:

Dado

New Member
Habe das selbe Problem. Aber unter openSUSE 11.1. Dafür gibts aber, soweit ich sehe, noch keinen patch, oder? Weiß vielleicht jemand Rat? :(
 

Dado

New Member
Ja, in der log steht:
Code:
2010-04-07 19:00:57: (log.c.75) server started
2010-04-07 19:00:57: (network.c.336) SSL: error:00000000:lib(0):func(0):reason(0)
daher ging ich davon aus...
 

wiggerl3000

New Member
openssl Problem

Hallo,
hab das gleiche Problem mit openSuSE 11.1 und Plesk 9.3
sw-cp-server startet nicht mehr

openssl Paket von Plesk schon neu installiert geht aber auch nicht!!!
Brauch dringend hilfe
 
Top