AXFR-Probleme bei inwx

F

federschuh

Guest
Hallo,

ich betreibe meinen eigenen Master-DNS server um meine Domains zu verwalten,
und repliziere via AXFR-Transfer zum DNS-Slave-Server des Providers inwx.
Das ging viele Jahre gut, aber seit einigen Monaten klappt der AXFR-Transfer nicht mehr.
Hat sonst jemand AXFR-Probleme beim Domain-Provider inwx?

Der Support sagt, mein DNS-Server würde nicht erreichbar sein, was aber nicht stimmt,
was man via diese Adresse leicht überprüfen kann:
https://ednscomp.isc.org/ednscomp

Ich bin mittlerweile soweit, dass ich ernsthaft über einen Umzug zu einem anderen Provider nachdenke. Könnt ihr mir einen empfehlen?

Thx
 
F

federschuh

Guest
Logfiles? Config? Etwas mehr Infos.

Hast du die Änderung mitbekommen? ("aber seit einigen Monaten klappt der AXFR-Transfer nicht mehr."
https://www.inwx.de/de/news/408/neue-ip-adresse-für-axfr-zonentransfers
Ja, ja, IP-Änderung von derem AXFR-Server weiss ich, ist in meiner named-cfg schon aktualisiert.
Notifys gehen raus, aber deren AXFR-Server meldet sich nicht.
Zu 2 anderen secondary DNS-Servers klappt der AXFR-Transfer ohne Probleme.

Ja, was soll ich da als Kunde noch sagen, wenn der Support lapidar behauptet dass mein DNS-Server nicht erreichbar sei, obwohl es vom Rest der Welt erreichbar ist!
Ich habe dem Support den o.g. Link zum Selber-Testen gegeben, bis jetzt noch keine Antwort.

Btw. hier ist noch ein gutes onlines DNS Test-Tool (gibt's noch mehr gute Tools dort):
https://www.ultratools.com/tools/dnsTraversal
 
Last edited by a moderator:
F

federschuh

Guest
Hab das Problem jetzt so gelöst, dass ich auch einen eigenen Secondary-DNS (Slave) installiert habe.
Diese Lösung kann ich jedem empfehlen.
Natürlich dürfen die beiden DNS-Server nicht im selben Class-C-Network sein (Vorgabe von denic etc.):
x.x.1.1 und x.x.2.1 OK
x.x.1.1 und x.x.1.254 NICHTOK
 
Last edited by a moderator:
Top