Avago MegaRAID Mailbenachrichtigung

#1
Last edited by a moderator:
#3
...das war defintiv mein letzter Controller von AVAGO... auch Hersteller welche deren Chips verbauen werden zukünftig von mir boykottiert. (HP, IBM, Dell, Fujitsu etc.)
 
#5
Danke für Deinen Beitrag!

Werde dem bei Gelegenheit nachgehen, aber jetzt läuft's vorerst mal.

FAKT IST: Dran schuld ist definitiv Avago, die Schreiben ja selbst dass nicht mal mit GMail geht!!

Ferner geht GMX nicht unter der lokale hmailserver ebenfalls nicht.

(Während alle Sache mit den "SMTP Diag Tool gehen" - Mails werde damit abgesendet!!)

Die Entwickler von Avago sind wohl schlicht zu hohl, um sich an die SMTP-Konventionen zu halten, das ist der Punkt...!!!

(Und eine solche Firma verkauft Controller, welche vierstellige Beträge kosten!!! :mad::mad::mad:)
 
#7
"Die Entwickler von Avago sind wohl schlicht zu hohl, um sich an die SMTP-Konventionen zu halten, das ist der Punkt...!!!"
Dann würde einem wohl nix anderes übrig bleiben, als einen SMTP-Proxy selbst zu programmieren, welcher mit dem offenbar nicht-RFC-konformen Handshake vom der Avago-Software klarkommt...

Sowas ist schlicht zu kotzen, anders kann ich das leider nicht ausdrücken!!!
 

mr_brain

Registered User
#9
Das sagt hier absolut gar nichts zur Sache, um es auf den Punkt zu bringen!
Dann wende dich doch an Avago und nicht hier ans Forum! Wenn du meinst, dass es sowieso verbockte Software im Bereich SMTP ist, dann können wir dir eh nicht weiter helfen.
 
#10
Habe erst nach dem 1. Beitrag herausgefunden, dass es mit sendgrid.com offenbar geht.

(Ferner hoffe ich noch, dass mein Beitrag mindestens von ein paar huntert Leuten gelesen wird, um vor diesem Schrott zu warnen!!)

An Avago habe ich bereits geschrieben. Bin aber ausserhalb der Garantie... die werde sich wohl kaum die Mühe machen, mir zurückzuschreiben... (Die beschäftigen sich wohl lieber mit der Entwicklung von schrottiger Software und bestenfalls mittelmässiger Hardware (inkl. Buggy-Firmware 20.0.x beim 9212-4i4e im Auslieferungszustand, welche zu Datenverlusten auf der einen oder Anderen Platte führt und den RAID-Verbund-Wiederaufbau sich im Kreis drehen lässt) zu horrenden Preisen!!)
 
Last edited by a moderator:

Joe User

Blog Benutzer
#12
Und man kann nicht mal einen SSL- oder TLS-SMTP-Server angeben, so wie's aussieht!! :eek:

*kotz* !!!
Das ist Bullshit, siehe Deinen Broadcom Link.

Auch Dein rumgejammer hier ist gelinde gesagt Bullshit, denn nur weil Du SMTP und die best-practice für Mailserver nicht verstanden hast, heisst das noch lange nicht, dass der beklagte Hersteller etwas falsch gemacht hat. Im Gegenteil, der besagte Hersteller hat alles richtig gemacht...


Erst Basiswissen aneignen, dann Fachwissen aneignen und erst dann rumjammern.
Dir fehlt offenbar bereits das Basiswissen, ebenso wie dem von Dir verlinkten Blogger...
 
#13
"Auch Dein rumgejammer hier ist gelinde gesagt Bullshit, denn nur weil Du SMTP und die best-practice für Mailserver nicht verstanden hast..."
Gut, dann erklär mir doch das bitte mal wie das ist mit der "best-practise" bei SMTP bezügl. Verschlüsselung oder nicht... als SW-Entwickler bin ich halt unter eurem intellektuellen Niveau, schon klar, das impliziert sich! :cool:

Auf dem Broadcom-Link steht was von Port 587. Das kann verschlüsselt oder auch nicht sein. Das einzige Kriterium ist bei Port 587, dass es doch immer ein Kennwort braucht. (?) Gerne kannst Du mich korrigieren...

Und Fakt ist un bleibt immer noch:

"...da geht einfach gar nichts:

- Mit Authentifizierung auf ext. Server
- Ohne Authentifizierung mit lok. Mailproxy auf ext. Server
- Ohne Authentifizierung auf lok. Server"


Was sollte daran falsch sein? Ich denke eher weniger, dass ich halluziniere oder so...
 
#14
"Im Gegenteil, der besagte Hersteller hat alles richtig gemacht..."

OK, dann widerlege mir dass ich dort JEDEN SMTP-Server angeben kann...

P.S.: Mitarbeiter oder Händer von Avago, richtig..? ;)
 

Thunderbyte

Moderator
Staff member
#15
@jmar83:
Als Mod möchte ich Dich auf folgendes hinweisen:

- Beschränke Dich bitte auf einen SACHLICHEN Ton hier im Forum! Das Forum ist nicht dazu da, dass Du Deinen persönlichen Frust hier abladen kannst. Du kannst gerne auf ggfalls existierende Probleme mit einem Raid Controller hinweisen, aber bitte sachlich, mit Belegen und in diesem einen Thread.

- Unterlasse es daher sofort, andere Threads mit Deinen "Warnungen" zu versehen. Diese Crossposts wurden als unnötige Kommentare verwarnt und gelöscht.

- Mehrere eigene Posts hintereinander entsprechen auch nicht gerade der Netiquette.

TLDR: Komm mal wieder runter! :confused:
 

Joe User

Blog Benutzer
#16
P.S.: Mitarbeiter oder Händer von Avago, richtig..? ;)
Weder das Eine, noch das Andere, nichtmal Nutzer eines deren Produkte.
Leidiglich seit 20 Jahren Postmaster.


Punkt 1) GMail und nahezu alle anderen Mailprovider und vernünftigen Postmaster lehnen SMTP-Verbindungen von Dialup-Adressen grundsätzlich ab.
Punkt 2) Port 587 (submission) hat immer TLS und SMTP-AUTH gesichert zu sein.
Punkt 3) Die Doku und die Software legen nicht ganz grundlos die Nutzung des eigenen lokalen Mailservers nahe, welcher üblicherweise Mails aus dem eigenen Netz (mit oder ohne TLS oder SMTP-AUTH) entgegen nimmt.
 
#17
OK, danke für Dein Feedback

Was sind "Dialup-Adressen"? Ich habe jedenfalls die Originale, zum Account gehörende E-Mail-Adresse als Absenderadresse bei der Avaga-Software hinterlegt...

Also:

E-Mail-Absenderadresse: xxx@gmail.com
Benutzername: xxx@gmail.com
Kennwort: GMail-Kennwort

Gleiches mit GMX. Beides jeweils mit Port 25 und 587 wie auch mit 465 getestet - nix geht! :mad:

Und warum wird dann sendgrid.com akzeptiert, und die anderen Accounts nicht?

Ich glaube, ich werde die Sache mal mit Wireshark analysieren!!

Nachtrag: Und hier habe ich noch einen Opensource-SMTP-Proxy, geschreiben in Java (meiner bevorzugten Programmiersprache) gefunden: https://github.com/hontvari/mireka... jedenfalls wird mir heute Nacht sicher nicht langweilig! ;-)
 
Last edited by a moderator:

Joe User

Blog Benutzer
#18
https://en.wikipedia.org/wiki/Dialup_Users_List

Hast Du Deinen GMail-Account so konfiguriert, dass Du von extern senden und empfangen darfst?
Welchen GMail-Servernamen und Port hast Du genau in der Software angegeben?
Hast Du STARTTLS oder nur SSL/TLS in der Software aktiviert?
Hast Du SMTP in allen beteiligten "Firewalls" freigegeben?
Alle dummen Anti-Malware/Viren/Spam/whatever Lösungen deaktiviert/deinstalliert?
Keine Providerseitigen Port- oder Protokollsperren?
 
#19
Hallo zusammen

"Hast Du Deinen GMail-Account so konfiguriert, dass Du von extern senden und empfangen darfst?"
Ja, den gleichen Account verwendet ich auch in M$ Outlook. Allerdings mit "TLS" ("StartTLS" gibt bei meinem alten Outlook 2010 nicht) unter Port 587.


"Welchen GMail-Servernamen und Port hast Du genau in der Software angegeben?"
smtp.gmail.com:25


"Hast Du STARTTLS oder nur SSL/TLS in der Software aktiviert?"
Weder noch - der "MegaRAID Storage Manager - 17.05.00.02" unterstützt nur unverschlüsselte Verbindungen!


"Hast Du SMTP in allen beteiligten "Firewalls" freigegeben?"
Nicht nötig... ausgehende Verbindungen sind bei meiner aktuellen Konfiguration grundsätzlich erlaubt!

"Alle dummen Anti-Malware/Viren/Spam/whatever Lösungen deaktiviert/deinstalliert?"
Ich verwende den M$ Defender, teilweise "Clamwin AntiVirus" für gewissen Serversoftware und evtl. noch Spybot. Und die haben alle keine Firewall-Funktionen. "Clamwin AntiVirus" macht keine Probleme mit dem MS Defender, da erster über keine Echtzeit-Überwachungsfunktion verfügt. (Gibt also keine Konflikte) und Spybot in der gratis-Version hat das ebenfalls nicht. Firewall-Funktionen hat keines der 3 genannten Programme. Ist also nicht das Problem.


"Keine Providerseitigen Port- oder Protokollsperren?"
Nein.


Die Probleme waren folgende:

- Zwar läuft bei GMail sowie bei GMX auf Port 25 noch ein Dienst (zwecks SMTP-Empfang evtl.?), allerdings ist dieser keinesfalls unverschlüsselt, sondern "StartTLS". Das hat das Protokoll-Log des "Mireka mail server and SMTP proxy" (kann nur mit unverschlüsselten Diensten umgehen!) ergeben.
Auch "telnet" zeigt bei "StartTLS" zuerst was unverschlüsseltes an (wohl normal bei "StartTLS"), ganz im Ggs. zum SSL-SMTP-Port 465, dort gibt's nur Zeichenwirrwarr...
Bei sendgrid.com ist es ohne jegliche Verschlüsselung! Darum geht das auch problemlos mit dem "MegaRAID Storage Manager - 17.05.00.02"...

- Der "MegaRAID Storage Manager - 17.05.00.02" scheint ein Problem mit dem "hmailserver" (ebenfalls als SMTP-Proxy getestet) zu haben. Und zwar folgendes: Ich muss ZWANGSLÄUFIG die IP-Adresse 192.168.1.21 des Rechners angeben, und nicht 127.0.0.1. oder "localhost". hmailserver läuft allerdings auf dem gleichen Rechner wie der "MegaRAID Storage Manager - 17.05.00.02"... interessant ist, dass das "SMTP Diag Tool" dort aber keine Probleme hat mit 127.0.0.1 oder "localhost"

--> Die Lösungs des Problems war demzufolge nun, den GMX-Account (smtp.gmx.net mit Port 465 sowie der Option "Use SSL") im hmailserver für den SMTP-Versand anzugeben. (Fungiert dann als SMTP-Proxy) und anschliessend beim "MegaRAID Storage Manager - 17.05.00.02" die IP 192.168.1.21 inkl. dem im hmailserver konfigurierten authentifizierungs-Login anzugeben...
 

mr_brain

Registered User
#20
Bei dem hmailserver kann man doch die SMTP-Einstellungen pro IP machen, oder? Falls ja, kannst du dem doch die IP 127.0.0.2 zuweisen und dann dort "Require SMTP Authentication" deaktiviert lassen.
 
Top