• This forum has a zero tolerance policy regarding spam. If you register here to publish advertising, your user account will be deleted without further questions.

apache2 webserver: htaccess

dieex

New Member
Hallo, Ich bin dabei Wordpress unter dem Betriebsystem ubuntu-xenial-16.04 zu installieren dazu bin ich einer Anleitung gefolgt. Nun bin ich an einem Problem angekommen wo ich nicht richtig weiter weiß. Das Problem ist folgendes wenn ich den apache2 server anfrage über "http" oder "MeinerIP" bekomme ich "Forbidden :You don't have permission to access / on this server.
Server unable to read htaccess file, denying access to be safe"
Als Meldung angezeigt! Ich möchte Wordpress ganz normal über einen Browser aufrufen können!
Leider komme ich nicht weiter ich bitte daher um Hilfe.
Ein kleiner Ausschnitt meiner apache2.conf:
Code:
# Sets the default security model of the Apache2 HTTPD server. It does
# not allow access to the root filesystem outside of /usr/share and /var/www.
# The former is used by web applications packaged in Debian,
# the latter may be used for local directories served by the web server. If
# your system is serving content from a sub-directory in /srv you must allow
# access here, or in any related virtual host.
<Directory />
        Options FollowSymLinks
        AllowOverride None
        Require all denied
</Directory>

<Directory /usr/share>
        AllowOverride None
        Require all granted
</Directory>

<Directory /var/www/>
AllowOverride None
Order allow,deny
allow from all
</Directory>
#Options Indexes FollowSymLinks
#AllowOverride None
#Require all granted
#</Directory>

<Directory /var/www/html/>
    AllowOverride All
    Require all granted
</Directory>

#<Directory /srv/>
#       Options Indexes FollowSymLinks
#       AllowOverride None
#       Require all granted
#</Directory>




# AccessFileName: The name of the file to look for in each directory
# for additional configuration directives.  See also the AllowOverride
# directive.
#
AccessFileName .htaccess

#
# The following lines prevent .htaccess and .htpasswd files from being
# viewed by Web clients.

Vielen Dank!
Grüße DIEEX
 
@ marce: wordpress liegt unter "/var/www/html/wordpress"
@ danton: wenn ich in einem Browser http://MeineIP/wordpress/index.php aufrufe erhalte ich: The requested URL /wordpress/index.php was not found on this server.

Wie muss ich vor gehen sodass ich die index.php von wordpress aufrufen kann ?
Grüße dieex
 
Anscheinend zeigt der Default-vHost bzw. (sofern vorhanden) der vHost deiner IP nicht auf /var/www/html als Dok-Root. Groß- und Kleinschreibung beim Verzeichnis- und Dateinamen beachtet? Linux achtet da im Gegensatz zu Windows ja drauf...
 
Back
Top