• This forum has a zero tolerance policy regarding spam. If you register here to publish advertising, your user account will be deleted without further questions.

Apache - Vserver - Debian falsche Rechte :(

djrick

Registered User
Moin,

Ich hab auf meinem Vserver Debian neu installiert und habe jetzt Apache2 laufen.
Das Problem ist: Wenn ich einen Benutzer erstelle (zB web1) dann wird der auch korrekt angelegt mit Verzeichnissen etc

/var/www/web1 (und unterverzeichisse files, html, etc)
Die Rechte für diesen Ordner sind natürlich:
User: web1
Group: ftponly

Wenn ich nun mit dem Browser die Seite von web1 aufrufe bekomme ich ein:
Forbidden

You don't have permission to access / on this server.

Wenn ich die Rechte vergebe: www-data/www-data dann funktionierts (weil der Indianer mit diesen Rechten läuft). Aber das kanns ja nicht sein weil dann können die User per FTP ja keine Daten mehr ändern ;)

Der Errorlog vom Apache gibt das aus:
[Sat Feb 12 17:11:43 2005] [crit] [client 217.255.163.27] (13)Permission denied: /var/www/web1/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable

Ich habe keine Ahnung was der Log mir damit sagen will :confused: Es befindet sich auch keine .htaccess Datei in dem Verzeichniss und ehrlich gesagt will ich da auch keine haben ...
Das komische ist: Wenn ich Confixx aufrufe - Das funktioniert...

Hilfe :(
 
Schau mal nach, ob der VirtualHost-Eintrag in der confixx_vhost.conf für web1 die Zeilen 'User web1' und 'Group ftponly' stehend.
Wenn ja, gibt es evtl. ein Problem mit dem Wrapper suexec.
Dazu sollte in /var/log/apache2/suexec.log eine Fehlermeldung stehen.
Wenn nicht finde herraus ob suexec überhaupt installiert ist.

huschi.
 
Alsoooooooooo

Suexec läuft
User web1
Group ftponly
steht natürlich in der Confixx_vhost.

Suexec wird gestartet als Modul (man kopiert die Mods die man braucht einfach in /etc/apache2/mods-enabled).
Einen Log des Wrappers gibts leider nicht :-(

Ich denke aber nicht dass es an der Suexec liegt weil ich habe das Modul deaktiviert und die Direktive aus der Confixx_vhost.conf genommen und neu gestartet und bekomme noch die selbe Meldung im Error log. Ich weiss auch nicht was es mit dieser ominösen .htaccess Datei auf sich hat, am besten wäre es: Diese "Prüfung" einfach ausstellen dass er nicht nach der .htaccess sucht.
 
Last edited by a moderator:
djrick said:
(man kopiert die Mods die man braucht einfach in /etc/apache2/mods-enabled)
Nicht kopieren! Linken!

Und:
Sorry, unter Apache2 heißt es ja jetzt:
SuexecUserGroup web1 ftponly

huschi.
 
Das sind alles Links da steht bloss in der jeweiligen Datei:
LoadModule suexec_module /usr/lib/apache2/modules/mod_suexec.so
 
Guckst du:

in der apache2.conf wird für die module auf /etc/apache2/mods-enabled verwiesen. Wenn ich jetzt das Modul "suexec" haben will kopiere ich "suexec.load" von /mods-avialible nach /mods-enabled
in der Datei "suexec.load" steht:
LoadModule suexec_module /usr/lib/apache2/modules/mod_suexec.so

Verstanden? Sprich: Suexec wird geladen. Aber ich glaube nicht dass es an suexec liegt, weil selbst wenn ichs deaktiver (das Modul) kommt immer noch der gleiche Fehler in dem error.log
 
-----------------------------------

So den dicken Strich hab ich mir hier drunter verdient. (Eigentlich auch eine Ohrfeige oder sowas...)

DENN: Das Problem ist gelößt.
Nachdem ich das System geupgraded habe, Apache 1.x ausprobiert habe und mit dem Modulen rumgespielt habe und das ALLES nix gebracht hat, habe ich in Kleinstarbeit alle User, Gruppen und Rechte jeder Verzeichnisse durchgegangen und die Lösung war mal wieder simpel:

chown web1:ftponly /var/www/web1/ -R
chmod 755 /var/www/web1/html

Und fertig (den chmod Befehl hatte ich übersehen).

:rolleyes:
 
Back
Top