• This forum has a zero tolerance policy regarding spam. If you register here to publish advertising, your user account will be deleted without further questions.

apache problem

kuchen35

Registered User
Seit einem Server Neustart versuchte ich in Plesk Apache zu starten aber es kommt ein Fehler:
ERROR

Unable to make action: Unable to manage service by websrvmng: websrvmng: Service apache2 failed to start
0: /usr/local/psa/admin/htdocs/server/restart_services.php:28 psaerror(string "Unable to make action: Unable to manage service by websrvmng: websrvmng: Service apache2 failed to start")

und wenn ich versuche ihn über Putty zu starten komm:

Starting httpd2 (prefork) Syntax error on line 6 of /etc/apache2/httpd.include:
DocumentRoot must be a directory

The command line was:
/usr/sbin/httpd2-prefork -f /etc/apache2/httpd.conf

aber alle Dateien sind vorhanden und am richtigen Platz
was kann ich da machen ?

danke
 
Hallo und Herzlich Willkommen im Forum,

Was steht in Zeile 6 in dieser Datei:
/etc/apache2/httpd.include
Da liegt der Fehler. Bitte einmal posten dann können wir dir besser helfen :)
Da sollte etwas mit DocumentRoot stehen
 
Also das steht alles in der Datei:
Code:
NameVirtualHost xx.xxx.x.xxx:xx
NameVirtualHost xx.xxx.x.xxx:xxx
ServerName xxxxxxx.xxxxxxxx.xxxx
ServerAdmin [email]xxxxxx@xxxxxx.xx[/email]

DocumentRoot /home/httpd/vhosts/default/htdocs

<IfModule mod_logio.c>
LogFormat "%h %l %u %t \"%r\" %>s %O \"%{Referer}i\" \"%{User-Agent}i\"" plesklog
</IfModule>
<IfModule !mod_logio.c>
LogFormat "%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" plesklog
</IfModule>
<Directory "/home/httpd/vhosts">
	AllowOverride All
	Options SymLinksIfOwnerMatch
	Order allow,deny
	Allow from all
	php_admin_flag engine off
</Directory>

<Directory "/usr/lib/mailman">
	AllowOverride All
	Options SymLinksIfOwnerMatch
	Order allow,deny
	Allow from all
	php_admin_flag engine off
</Directory>

<IfModule mod_userdir.c>
	UserDir disabled
</IfModule>
<VirtualHost \
			xx.xxx.x.xxx:xx \
			>
	ServerName default
	UseCanonicalName Off
	DocumentRoot /home/httpd/vhosts/default/htdocs
	ScriptAlias /cgi-bin/ "/home/httpd/vhosts/default/cgi-bin/"
	<IfModule mod_ssl.c>
		SSLEngine off
	</IfModule>
	<Directory "/home/httpd/vhosts/default/cgi-bin/">
		AllowOverride None
		Options None
		Order allow,deny
		Allow from all
	</Directory>
	<Directory /home/httpd/vhosts/default/htdocs>
	<IfModule sapi_apache2.c>
		php_admin_flag engine on
		php_admin_value open_basedir "/home/httpd/vhosts/default/htdocs:/tmp"
	</IfModule>
	<IfModule mod_php5.c>
		php_admin_flag engine on
		php_admin_value open_basedir "/home/httpd/vhosts/default/htdocs:/tmp"
	</IfModule>
	</Directory>
</VirtualHost>


<IfModule mod_ssl.c>

<VirtualHost xx.xxx.x.xxx:xxx >
	ServerName default-xx-xxx-x-xxx
	UseCanonicalName Off
	DocumentRoot /home/httpd/vhosts/default/httpsdocs
	ScriptAlias /cgi-bin/ "/home/httpd/vhosts/default/cgi-bin/"
	SSLEngine on
	SSLVerifyClient none
	SSLCertificateFile /usr/local/psa/var/certificates/certsvH7794
	<Directory "/home/httpd/vhosts/default/cgi-bin/">
		AllowOverride None
		Options None
		Order allow,deny
		Allow from all
	</Directory>
	<Directory /home/httpd/vhosts/default/httpsdocs>
		SSLRequireSSL
	</Directory>
</VirtualHost>

</IfModule>

<VirtualHost \
			xx.xxx.x.xxx:xx \
			>
	DocumentRoot /usr/share/psa-horde/
	Alias /horde/ /usr/share/psa-horde/
	Alias /imp/ /usr/share/psa-horde/imp/
	ServerName webmail
	ServerAlias webmail.*
	UseCanonicalName Off
	<Directory /usr/share/psa-horde>
		<IfModule sapi_apache2.c>
			php_admin_flag engine on
			php_admin_flag magic_quotes_gpc off
			php_admin_flag safe_mode off
			php_admin_value open_basedir "/usr/share/psa-horde:/etc/psa-horde:/etc/psa:/tmp:/var/log:/usr/share/doc"
			php_admin_value include_path "/usr/share/psa-horde:/usr/share/psa-horde/pear:."
		</IfModule>
		<IfModule mod_php5.c>
			php_admin_flag engine on
			php_admin_flag magic_quotes_gpc off
			php_admin_flag safe_mode off
			php_admin_value open_basedir "/usr/share/psa-horde:/etc/psa-horde:/etc/psa:/tmp:/var/log:/usr/share/doc"
			php_admin_value include_path "/usr/share/psa-horde:/usr/share/psa-horde/pear:."
		</IfModule>
		Order allow,deny
		Allow from all
	</Directory>
</VirtualHost>


<IfModule mod_ssl.c>

<VirtualHost \
			xx.xxx.x.xxx:xx \
			>
	DocumentRoot /usr/share/psa-horde/
	Alias /horde/ /usr/share/psa-horde/
	Alias /imp/ /usr/share/psa-horde/imp/
	ServerName webmail
	ServerAlias webmail.*
	UseCanonicalName Off
	SSLEngine on
	SSLVerifyClient none
	SSLCertificateFile /etc/apache2/httpd.pem
	<Directory /usr/share/psa-horde>
		<IfModule sapi_apache2.c>
			php_admin_flag engine on
			php_admin_flag magic_quotes_gpc off
			php_admin_flag safe_mode off
			php_admin_value open_basedir "/usr/share/psa-horde:/etc/psa-horde:/etc/psa:/tmp:/var/log:/usr/share/doc"
			php_admin_value include_path "/usr/share/psa-horde:/usr/share/psa-horde/pear:."
		</IfModule>
		<IfModule mod_php5.c>
			php_admin_flag engine on
			php_admin_flag magic_quotes_gpc off
			php_admin_flag safe_mode off
			php_admin_value open_basedir "/usr/share/psa-horde:/etc/psa-horde:/etc/psa:/tmp:/var/log:/usr/share/doc"
			php_admin_value include_path "/usr/share/psa-horde:/usr/share/psa-horde/pear:."
		</IfModule>
		SSLRequireSSL
		Order allow,deny
		Allow from all
	</Directory>
</VirtualHost>


</IfModule>

<VirtualHost \
			xx.xxx.x.xxx:xx \
			>
	DocumentRoot /home/httpd/vhosts/default/htdocs
	ServerName lists
	ServerAlias lists.*
	UseCanonicalName Off
	ScriptAlias /mailman/ /usr/lib/mailman/cgi-bin/
	Alias /icons/ /usr/lib/mailman/icons/
	Alias /pipermail/ /usr/lib/mailman/archives/public/
	<Directory /usr/lib/mailman/archives/>
		Options FollowSymLinks
	</Directory>
</VirtualHost>


<IfModule mod_ssl.c>

<VirtualHost \
			xx.xxx.x.xxx:xx\
			>
	DocumentRoot /home/httpd/vhosts/default/httpsdocs
	ServerName lists
	ServerAlias lists.*
	UseCanonicalName Off
	ScriptAlias /mailman/ /usr/lib/mailman/cgi-bin/
	Alias /icons/ /usr/lib/mailman/icons/
	Alias /pipermail/ /usr/lib/mailman/archives/public/
	<Directory /usr/lib/mailman/archives/>
		Options FollowSymLinks
	</Directory>
</VirtualHost>


</IfModule>

Include /home/httpd/vhosts/project-chaos-ro.de/conf/httpd.include

Include /home/httpd/vhosts/pjcro-online.de/conf/httpd.include
Hoffe ihr könnt mir helfen.
 
Last edited by a moderator:
Also das steht alles in der Datei:
DocumentRoot /home/httpd/vhosts/default/htdocs
Guten Tag,

ich stand soeben vor exakt derselben Fehlermeldung.
E stellte sich heraus, dass hier lediglich 2 Buchstaben fehlten:
Es muss (sofern es auch dasselbe Problem ist) httpdocs und nicht htdocs heissen.
Hoffe, das hilft Dir weiter :)

Gruß
Jens
 
Back
Top