Server Support Forum
mod_rewrite funktioniert nicht

Zurück   Server Support Forum > >


Antwort
 
Themen-Optionen Thema bewerten
  #1  
Alt 24.06.2011, 05:50
philmue95 philmue95 ist offline
Registered User
 
Registriert seit: 08.2010
Beiträge: 7
Ausrufezeichen mod_rewrite funktioniert nicht

Guten Tag,

Seit Stunden versuche ich mod_rewrite zu aktivieren.
Das geht soweit auch. Ich starte den Apache Server neu, will die CMS installation beginnen und bekomme wieder die Meldung das mod_rewrite nicht aktiviert ist.
Ich habe auch keine Dateiberechtigung, selbst wenn alles auf 777 steht.


An was kann das liegen?

Danke schonmal.
LG. Phil
Miniaturansicht angehängter Grafiken
mod_rewrite funktioniert nicht-fail.png  

Geändert von philmue95 (24.06.2011 um 05:52 Uhr)
Mit Zitat antworten

  #2  
Alt 24.06.2011, 08:13
Whistler Whistler ist offline
Support Guru
 
Registriert seit: 10.2008
Beiträge: 2.661
Was steht in der phpinfo()? Ist die RewriteEngine für den betreffenden vHost on? Werden Dateien außerhalb des DocRoot verwendet?
Mit Zitat antworten
  #3  
Alt 24.06.2011, 08:52
philmue95 philmue95 ist offline
Registered User
 
Registriert seit: 08.2010
Beiträge: 7
Danke für deine Antwort

Also hier ist die phpinfo http://46.251.225.117/php.php.
Ich weis nich ob die RewriteEngine an ist. Wo kann ich das schaun? Und daten auserhalb des DocRoot?? Kein plan was das ist ich denks nicht^^
Mit Zitat antworten
  #4  
Alt 24.06.2011, 09:47
Benutzerbild von d4f
d4f d4f ist offline
Support Guru
 
Registriert seit: 04.2007
Ort: /dev/urandom
Beiträge: 4.353
d4f eine Nachricht über ICQ schicken d4f eine Nachricht über MSN schicken
Zitat:
Wo kann ich das schaun?
apache2handler -> Loaded modules
Und ja, es ist geladen

Hast du die entsprechende .htaccess hochgeladen?
Die Erkennung der Module durch PHP-Skripte ist nicht immer 100% korrekt sofern er keine .htaccess zum Test benutzt.
__________________
Einige Beiträge sind auf meinem Smartphone verfasst. Bitte Tippfehler und Abkürzungen entschuldigen!
Bitte keine ICQ/MSN/Skype Kontaktaufnahmen ohne vorherige persoenliche Absprache.
Mit Zitat antworten
  #5  
Alt 24.06.2011, 11:13
philmue95 philmue95 ist offline
Registered User
 
Registriert seit: 08.2010
Beiträge: 7
Die .htaccess ist beim cms dabei und die Funktioniert normalerweise auch.
Mit Zitat antworten
  #6  
Alt 24.06.2011, 12:24
converge converge ist offline
Registered User
 
Registriert seit: 04.2011
Beiträge: 148
Erlaubst Du das Überschreiben der VirtualHost-Direktiven? Falls nein werden htaccess-Dateien garnicht erst ausgewertet.

Schau mal im entsprechenden VirtualHost nach dem Eintrag:
Code:
AllowOverride Wert
Sollte dies z.B. auf None gestellt sein, muss die Rewrite-Regel direkt in der VirtualHost-Definition festgelegt werden.
Mit Zitat antworten
  #7  
Alt 24.06.2011, 13:16
philmue95 philmue95 ist offline
Registered User
 
Registriert seit: 08.2010
Beiträge: 7
Wo kann ich das einstellen?
Mit Zitat antworten
  #8  
Alt 24.06.2011, 13:43
converge converge ist offline
Registered User
 
Registriert seit: 04.2011
Beiträge: 148
Gute Frage. Ist nicht mein Server, von daher kenne ich die Konfiguration leider nicht. Eventuell wäre jedoch der Ort /etc/apache2/sites-enabled ein guter Ort, um mit der KONSOLE mal nachzusehen.
Mit Zitat antworten
  #9  
Alt 28.06.2011, 15:36
dante dante ist offline
Registered User
 
Registriert seit: 08.2010
Beiträge: 156
Moin,

AllowOverride setzt du im Directory-Container, siehe auch hier.

Gruß
dante
Mit Zitat antworten
Antwort

Stichworte
apache, mod, rewrite



Themen-Optionen
Thema bewerten
Thema bewerten:

Forumregeln
Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist aus.
HTML-Code ist aus.

Gehe zu

Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
Speicherplatzverbrauch funktioniert nicht Anagramm ispCP 4 14.12.2009 22:10
E-Mailweiterleitung bei mehreren Empfängern funktioniert nicht Maggus Mail 5 10.03.2008 09:52
Exim4 smarthost mit LDAP-Anbindung funktioniert nicht GreatCornholio Mail 2 05.12.2007 11:53
Confixx Zugriffstatistik (traffic funktioniert) paranoid64 Confixx 0 03.06.2007 16:13
mod_rewrite funktioniert nur für einen Kunden liltoe Confixx 6 16.01.2006 22:46


mod_rewrite funktioniert nicht
mod_rewrite funktioniert nicht
mod_rewrite funktioniert nicht mod_rewrite funktioniert nicht
Powered by vBulletin® Version 3.8.11 (Deutsch)
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.