Server Support Forum
XenServer 6.0.2 Hetzner Routed Netzwerk Probleme

Zurück   Server Support Forum > >


Antwort
 
Themen-Optionen Thema bewerten
  #1  
Alt 28.09.2012, 14:54
tony_s tony_s ist offline
Registered User
 
Registriert seit: 09.2012
Beiträge: 1
XenServer 6.0.2 Hetzner Routed Netzwerk Probleme

Hallo Leute,

nach zahllosen Stunden des ausprobierens von diversen Tutorials wende ich mich an euch, weil ich schlichtweg nicht mehr weiterkomme ..

Also zur Ausgangssituation ... ich habe bei Hetzner einen RootServer auf welchem ich XenServer 6.0.2 von Citrix in der Free Version installiert habe. Da man seit der IP Knappheit nur noch eine Ip Adresse von Hetzner zusätzlich bekommt, habe ich weitere Ip beantragt. Da fängt das erste Problem an. Die UrsprungsIp liegt in subnetz A und besitzt netzmaske A. Die weiteren Ips befinden sich alle in anderen subnetzen mit unterschiedlichen netzmasken.
Ich wollte also den XenServer in den "routed network mode" versetzen, damit jedes Paket zunächst über den Host und dann erst an die VM's weitergeleitet wird.
Da ich keine Möglichkeit habe, eine IP für ein Gateway pro Subnetz zu opfern wollte ich die pointopoint lösung anwenden. Beim normalen XEN scheint dies ja kein großartiges Problem zu sein ... nur beim Xenserver will es partout nicht klappen.

Was ich getan habe war somit folgendes:
Code:
Änderung in der /etc/xen/xend-config.sxp
(network-script network-route)
(vif-script     vif-route)

* Wo sind eigentlich beim Xenserver die zugehörigen Scripte?
Zusätzlich passte ich die /etc/sysctl.conf an:
Code:
# Controls IP packet forwarding
net.ipv4.ip_forward = 1

# Controls proxy arp
net.ipv4.conf.default.proxy_arp = 1

# Turn off redirects
net.ipv4.conf.all.send_redirects = 0
net.ipv4.conf.default.send_redirects = 0
net.ipv4.conf.lo.send_redirects = 0
net.ipv4.conf.xenbr0.send_redirects = 0
und einen weiteren Eintrag im iptables:
Code:
-A RH-Firewall-1-INPUT -i xenbrX -o xenbrX -j ACCEPT
Der Server erhielt eine Route zu der jeweiligen VM mit der netzmaske 255.255.255.255 ...
Entsprechend verlief die Einrichtung auf der VM .. zuätzlich hab ich die MAC vom Hetzner Robot auf die Netzwerkkarte gebunden..
Code:
IP: <von Hetzner zugeteilte IP>
Netzmaske:255.255.255.255
Gateway: <IP HOST>
der Server ist auch erreichbar und pingt auch sauber nach draussen .. über den HOST .. sobald ich aber nen trace von Zuhause aus mache, stellt man fest das der HOST überhaupt nicht involviert ist, sondern die Anfrage direkt an die VM durchgestellt wird.

Hat irgend jemand ne Ahnung wie man das beheben kann bzw. wie man generell zusätzliche IPS bei Hetzner einbinden kann auf nem Xenserver die in unterschiedlichen Subnetzen liegen? Das ganze sollte halt entsprechend über den Host geroutet werden, damit ich zusätzlich noch eine Paketfilterung über iptables betreiben kann. Über Hilfe jeder Art würde ich mich sehr freuen, da ich schlichtweg nicht mehr weiß, was ich noch ändern könnte /müsste.
Mit Zitat antworten

  #2  
Alt 17.10.2012, 23:57
geeosor geeosor ist offline
Registered User
 
Registriert seit: 10.2012
Beiträge: 1
Hallo,

ein sehr ähnliches Problem hatten wir auch zu lösen, damals noch mit XenServer 4x. Es hat damit geendet, dass wir eine router VM mit Vyatta gemacht haben. Dahinter dann private Netze. Dies klappt prima...

gruss

GeE
Mit Zitat antworten
Antwort

Lesezeichen

Stichworte
hetzner, netzwerk, route, xenserver



Themen-Optionen
Thema bewerten
Thema bewerten:

Forumregeln
Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist aus.
HTML-Code ist aus.

Gehe zu

Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
Xenserver auf den neuen Hetzner Servern DennisD Dedizierte Server 0 01.11.2011 09:09
Xenserver 5.6 FP1 - Netzwerk Timeouts auf VM und Mgmt Interface repa Virtualisierung 0 18.04.2011 13:51
XENServer 5.6 Netzwerk einstellung Kuki Virtualisierung 4 28.03.2011 22:51
XenServer 5.5 bei Hetzner christianwehner Virtualisierung 0 21.07.2009 21:15
XENServer bei Hetzner DrRamazzotti Virtualisierung 4 15.03.2009 10:29


XenServer 6.0.2 Hetzner Routed Netzwerk Probleme
XenServer 6.0.2 Hetzner Routed Netzwerk Probleme
XenServer 6.0.2 Hetzner Routed Netzwerk Probleme XenServer 6.0.2 Hetzner Routed Netzwerk Probleme
Powered by vBulletin® Version 3.8.11 (Deutsch)
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.