Server Support Forum


Zurück   Server Support Forum > >


Antwort
 
Themen-Optionen Thema bewerten
  #1  
Alt 13.07.2007, 21:43
blob
Gast
 
Beiträge: n/a
Große Probleme in den letzten 2 Tagen

Ich muß einfach mal erzählen, was mir seit 2 Tagen Probleme bereitet hat; mein Server lief kaum. Vielleicht auch lehrreich zur Fehlersuche.

Seit rd. 2 Tagen, wenn ich ins Internet gegangen bin als Klient, ist beim Aufruf verschiedener web-Seiten der Rechner abgestürzt / eingefroren. Aber auch unabhängig davon, spontan während ich nichts tat.

Nach und nach ist mir aufgefallen, daß dies nicht ausschließlich aber hauptsächlich passiert, wenn ich die Server-Programme laufen habe. Insbesondere sofort Absturz wenn ich in eins meiner eigenen sites ging. Am stabilsten waren der Reihe nach Opera, Mozilla, Ff, Konqueror. Kein Absturz, wenn ich im Text-Modus mit lynx in meine Seiten ging, diese funktionierten aber nur teilweise. Nach dem Austausch der start-webpage in den browsern (zBsp yahoo statt mein-site) nicht sofort Absturz beim Öffnen des browsers, aber Absturz sobald ich einige meiner sites öffnen wollte. Komisch aber, daß das nur bei einigen sites passierte, bei anderen nicht beim Öffnen, aber beim Aufruf bestimmter Dienste darin. Bei einigen sites ließ sich das php-Forum öffnen, bei anderen Meldung phpBB database connection error.

Ich habe zunächst an ein hacking gedacht, und alle Server-Protokolle, die web-Seiten meiner sites usw. abgesucht, aber nichts gefunden, auch nichts mit rootkit-Programmen. Ebensowenig instabile plugins der web-browser.

In den letzten Tagen hatte ich u.a. den Kernel erneuert, was ich aber dauernd tue und nie Probleme gab; ferner php, apache u.a. neu übersetzt, dabei teilweise headers eigener Kernels benutzt die neuer waren als bei der Übersetzung der gclib, auch dies bisher bei fast allen Progs problemlos. Jetzt also mal die 'offiziellen', auch für gclib verwendete header zurückkopiert und damit php, apache kompiliert. Erfolglos, die Probleme blieben. mysql lief übrigens normal; die Tafeln aller Foren usw sind in der selben Datenbank, keine Probleme mit der Verbindung o.ä. beim Öffnen derselben mit #mysql --user=root mysql

Ich habe schon befürchtet und fast begonnen, mein gesamtes System von einem backup zurückzuholen !!

Oder hier im Forum um Hilfe zu bitten.

Nun, ratet mal, was das sein könnte !! Und was ihr mir als Lösung empfohlen hättet .


Die Sucherei ging dann letztlich in die richtige Richtung, da einige sites funktionierten, oder aber die phpBB2 -Foren einiger sites, andere nicht.

Bei der Einrichtung von sites und insbesondere der phpBB2 -Foren sowie anderer Anwendungen in den sites, habe ich als host-Name meistens werner, manchmal localhost, manchmal 127.0.0.1 angegeben. Und etztere waren die, welche jetzt noch funktionierten !

Normalerweise ist in /etc/resolv.conf 127.0.0.1 u.a. als werner und localhost angegeben. Irgendeins der zahlreichen Programme, die ich täglich downloade und installiere, hat das aber umkonfiguriert, und werner auf eth0 geschoben, also auf 192.168.1.5 . Nur die sites oder Teile davon wie Foren die mit host-name 127.0.0.1 oder localhost eingerichtet wurden, haben funktioniert; bei den anderen hing es wohl von der Intelligenz des browsers ab, für hostname=werner etwas über eth0 statt lo zu finden. Daß der Rechner auch spontan abstürzte, offenbar dann wenn andere Klienten eins meiner sites aufgerufen haben.

Seitdem ich das korrigiert habe wie es war, keine Probleme mehr; fehlt nur noch, wieder die neuen headers nach /usr/include zu kopieren und nochmal php, apache dagegen zu übersetzen

Geändert von blob (13.07.2007 um 22:00 Uhr)
Mit Zitat antworten

Antwort

Lesezeichen


Themen-Optionen
Thema bewerten
Thema bewerten:

Forumregeln
Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist aus.
HTML-Code ist aus.

Gehe zu

Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
Meine letzten Worte an Server4You ! oemi2006 Vertragsfragen 12 23.11.2006 23:11
MC bleibt nicht im letzten Verzeichnis stehen iconsulting Sonstige Admin-Software 0 10.11.2006 16:17
S4Y Probleme seit 2 tagen Boergi Virtuelle Server 1 29.12.2005 11:16
letzten ./configure compile string rauskriegen? eXce Webserver 1 02.07.2005 12:38
letzten 3/4 hops zum Vserver ElNino Virtuelle Server 1 14.04.2004 22:50





Powered by vBulletin® Version 3.8.11 (Deutsch)
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.