Server Support Forum
Plesk PHP5.6 und PHP-CURL
  #1  
Alt 24.03.2018, 16:24
top-germany top-germany ist offline
Registered User
 
Registriert seit: 02.2018
Beiträge: 9
Plesk PHP5.6 und PHP-CURL

Hallo zusammen,

ich versuche auf einer Plesk VM (Plesk Onyx 17) das PHP Module Curl zu installieren.
Installiert habe ich es bereits mit
apt-get install php5.6-curl
und auch
apt-get install curl
läuft.

Allerdings erkennt Plesk nur CURL direkt, aber PHP-Curl läuft einfach nicht.

Woran könnte das liegen?

Vielen Dank für eure/Ihre Hilfe!
Mit Zitat antworten

  #2  
Alt 24.03.2018, 17:24
Werner S Werner S ist offline
Registered User
 
Registriert seit: 04.2017
Beiträge: 144
Wieso installierst du es nicht über Plesk selber?

Tools und Einstellungen -> PHP-Einstellungen -> PHP Version 5.6 anklicken und Curl installieren?
Mit Zitat antworten
  #3  
Alt 24.03.2018, 19:00
top-germany top-germany ist offline
Registered User
 
Registriert seit: 02.2018
Beiträge: 9
Zitat:
Zitat von Werner S Beitrag anzeigen
Wieso installierst du es nicht über Plesk selber?

Tools und Einstellungen -> PHP-Einstellungen -> PHP Version 5.6 anklicken und Curl installieren?
Das ist bereits dort installiert. Aber CURL oder eben PHP-Curl wird nicht erkannt.
In der PHP Info Datei steht z.b.:
"'--without-curl'" bei Commands
Wie ändere ich das?

& der Unterpunkt Curl ist aufgelistet. Also Curl scheint zu funktionieren, aber PHP-Curl geht nicht.

Weshalb auch immer.... Bin fast am zweifeln und Plesk am runterschmeißen.

Geändert von top-germany (24.03.2018 um 19:08 Uhr)
Mit Zitat antworten
  #4  
Alt 24.03.2018, 19:10
Benutzerbild von nexus
nexus nexus ist offline
Registered User
 
Registriert seit: 06.2011
Beiträge: 1.480
Zitat:
Zitat von top-germany Beitrag anzeigen
Bin fast am zweifeln und Plesk am runterschmeißen
Wäre ein sinnvoller Ansatz.

Ich bin sowieso kein Freund von Plesk und wenn du nicht gerade hunderte Domains, Webseiten oder Mailadressen verwalten mußt, ist Plesk sowieso völlig überdimensioniert.
Richte dir deinen Server vernünftig manuell ein, dann weißt du wenigstens genau, was auf der Kiste läuft. So du hast auch volle Kontrolle über die Konfigurationen der einzelnen Dienste und Plesk funkt dir da nicht dazwischen.
__________________
Ist ein Server das Richtige für mich? -> Entscheidungshilfe und Erste Schritte
Lesenswert für alle Mailserver-Admins -> Best Practice für stressfreie Mailserver
Server- und Hostinganbieter, die ich empfehlen kann -> PHP-Friends, IP-Projects, Keyweb, Netcup
Hier gibt es alle Infos zu Schulferien (Insider wissen, was ich meine ) -> schulferien.org
Mit Zitat antworten
  #5  
Alt 25.03.2018, 09:44
GwenDragon GwenDragon ist offline
Registered User
 
Registriert seit: 12.2008
Ort: Franken
Alter: 57
Beiträge: 3.052
https://support.plesk.com/hc/en-us/a...Out-of-the-Box hilft nicht?

Früher habe ich fehlende PHP-Module mit PECL erzeugt und installiert.
__________________
die Gwen, also die Drachin... nix anderscht!
Mit Zitat antworten
  #6  
Alt 25.03.2018, 20:02
Benutzerbild von Joe User
Joe User Joe User ist offline
Registered User
 
Registriert seit: 11.2008
Ort: Hamburg
Alter: 39
Beiträge: 3.970
Zitat:
Zitat von top-germany Beitrag anzeigen
& der Unterpunkt Curl ist aufgelistet. Also Curl scheint zu funktionieren, aber PHP-Curl geht nicht.
Die Fehlermeldung lautet ernsthaft "geht nicht"?
__________________
PayPal.Me/JoeUserWings for LifeWings for Life World Run
RootForum CommunityFreeBSD Remote InstallationFreeBSD WebHosting System

„If there’s more than one possible outcome of a job or task, and one of those outcomes will result in disaster or an undesirable consequence, then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.
Mit Zitat antworten
  #7  
Alt 26.03.2018, 11:55
GwenDragon GwenDragon ist offline
Registered User
 
Registriert seit: 12.2008
Ort: Franken
Alter: 57
Beiträge: 3.052
Auch interessant für den Nutzer: https://www.plesk.com/blog/product-t...ules-in-plesk/

Stellt sich mir immer die Frage wie der Nutzer die PHP.ini für die 5.6-Module angelegt hat.
__________________
die Gwen, also die Drachin... nix anderscht!
Mit Zitat antworten
  #8  
Alt 28.03.2018, 15:48
Bierteufel Bierteufel ist offline
Registered User
 
Registriert seit: 04.2006
Beiträge: 715
Einfach unter:

/opt/plesk/php/5.6/etc/php.ini

liegt die ini.

Und unter:

/opt/plesk/php/5.6/etc/php.d

kannst Du dein Modul reinhängen.
Mit Zitat antworten
Antwort

Lesezeichen


Themen-Optionen
Thema bewerten
Thema bewerten:

Forumregeln
Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist aus.
HTML-Code ist aus.

Gehe zu

Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
Plesk 12.0.18 - Ubuntu 14.04.3 - Plesk Update Fehler catwiesel Plesk 9 13.09.2015 16:18
php5-fcgi 500-Problem (premature end of header) als mod-php5 läuft alles! rico3000 Webserver 29 20.05.2012 10:47
PHP 5.3 CGI mit Plesk 10 Bornagain1983 Plesk 15 20.01.2012 20:21
Apache 2.2.x und PHP 5 - Seite bleibt leer ? xCycle Webserver 2 01.04.2009 14:40
RH7.3 -> PHP updaten madmat Virtuelle Server 21 11.01.2004 17:19


Plesk PHP5.6 und PHP-CURL
Plesk PHP5.6 und PHP-CURL
Plesk PHP5.6 und PHP-CURL Plesk PHP5.6 und PHP-CURL
Powered by vBulletin® Version 3.8.11 (Deutsch)
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.