Server Support Forum
Mails versenden geht nur teilweise / DNS Problem?

Zurück   Server Support Forum > >


Antwort
 
Themen-Optionen Thema bewerten
  #1  
Alt 08.01.2018, 18:37
xse xse ist offline
Registered User
 
Registriert seit: 07.2013
Beiträge: 19
Mails versenden geht nur teilweise / DNS Problem?

Guten Tag,

ich schlage mich jetzt schon einen halben Tag mit dem Problem rum und könnte etwas Hilfe gebrauchen.

Ich hab einen Root-Server bei Hetzner mit Plesk eingerichtet. Für die Verwaltung der Domains nutze ich den Robot von Hetzner, in dem man DNS-Zonefiles anlegt.

Ich kann Mail auf dem Rootserver empfangen, aber das senden geht nur teilweise. Bei manchen Empfänger-Adressen geht die E-Mail so durch, bei anderen wird sie einfach "verschluckt", es kommt aber auch keine Fehler-Mail zurück.

Ich vermute, dass könnte damit zu tun haben, dass die DNS Einstellungen falsch sind. Brauche ich ein Reverse DNS für diese Konstellation (wenn ja, wie sollte das aussehen)?

Ich komme darauf, weil in den Log-Dateien u.a folgendes steht, wenn ich zu einer GMX Adresse senden möchte:

Code:
host mx01.emig.gmx.net[212.227.17.5] refused to talk to me: 554-gmx.net (mxgmx115) Nemesis ESMTP Service not available 554-No SMTP service 554-Bad DNS PTR resource record.
An eine gmail.com-Adresse landet die mal dagegen zumindest im Spam.

Mein Zonefile zu der Domain sieht so aus:

Code:
$TTL 86400
@   IN SOA ns1.first-ns.de. postmaster.robot.first-ns.de. (
    2017122100   ; serial
    86400        ; refresh
    10800        ; retry
    3600000      ; expire
    86400 )      ; minimum
 
@                        IN NS      robotns3.second-ns.com.
@                        IN NS      robotns2.second-ns.de.
@                        IN NS      ns1.first-ns.de.
 
@                        IN A       176.9.38.136
mail                     IN A       176.9.38.136
www                      IN A       176.9.38.136
@                        IN MX 10   mail
In Plesk habe ich die DNS Verwaltung für diese Domain auf "Slave" gestellt, dort stehen auch die Nameserver, die im Zonefile stehen.

Ich bin mir sicher, dass ist nur eine Kleinigkeit, aber ich komme einfach nicht drauf...

viele Grüße,
Alex
Mit Zitat antworten

  #2  
Alt 08.01.2018, 19:59
reccon reccon ist offline
Registered User
 
Registriert seit: 12.2015
Alter: 39
Beiträge: 147
Mails versenden geht nur teilweise / DNS Problem?
Hallo Alex


GMX gibt dir doch den Hinweis dass der Reverse DNS Eintrag falsch ist (554-Bad DNS PTR resource record).
Laut deinem MX DNS Eintrag soll dein (Mail-)Server mail.deine-domäne.tld heißen. So sollte dann auch der Reverse DNS Eintrag und der Wert im Plesk unter Servereinstellungen/Vollständiger Hostname lauten.
Mit Zitat antworten
  #3  
Alt 08.01.2018, 21:44
xse xse ist offline
Registered User
 
Registriert seit: 07.2013
Beiträge: 19
Hi reccon,

danke für deine Antwort!

Ich finde allerdings nicht raus, wie ich den Reverse DNS Eintrag korrekt erstelle. Erstelle ich den im Zonefile bei Hetzner, oder direkt auf dem Server in Plesk?
Ich gehe davon aus, bei Hetzner. Aber wie? Ich habe es einfach probiert, indem ich folgendes an das oben gepostet Zonefile angehängt habe:

Code:
176.9.38.136	IN	A	netz-und-werke.de
funktioniert aber leider nicht :-/

viele Grüße,
Alex
Mit Zitat antworten
  #4  
Alt 08.01.2018, 21:53
Benutzerbild von Thunderbyte
Thunderbyte Thunderbyte ist offline
Moderator
 
Registriert seit: 01.2006
Alter: 41
Beiträge: 6.454
https://wiki.hetzner.de/index.php/DNS-Reverse-DNS

Zitat:
Reverse-DNS-Einträge können ausschliesslich über die entsprechende Robot-Funktion erzeugt werden (Menüpunkt "Server" -> Klick auf den Server -> "IPs" -> Klick auf das Textfeld rechts neben der gewünschten IP-Adresse).
Robot: https://robot.your-server.de/
__________________

...Der Werdegang eines Rootserveradmins...

Geändert von Thunderbyte (08.01.2018 um 21:55 Uhr)
Mit Zitat antworten
  #5  
Alt 08.01.2018, 22:25
xse xse ist offline
Registered User
 
Registriert seit: 07.2013
Beiträge: 19
Hi Thunderbyte,

besten Dank! Damit geht es jetzt. Ich hab die ganze Zeit an der falschen Stelle gesucht...

Eine Sache interessiert mich aber. Ich habe jetzt als reverse-DNS für den Server die Domain netz-und-werke.de eingestellt. Der Server soll ja aber in Zukunft deutlich mehr Domains bekommen, die auch alle Mail-Adressen haben. Macht das nichts?

viele Grüße,
Alex
Mit Zitat antworten
  #6  
Alt 08.01.2018, 22:36
reccon reccon ist offline
Registered User
 
Registriert seit: 12.2015
Alter: 39
Beiträge: 147
Mails versenden geht nur teilweise / DNS Problem?
Dein Reverse DNS Eintrag sollte ein FQDN sein, also z.B. mail.netz-und-werke.de
Genau wie die Servernamen Einstellung in Plesk.
Mit Zitat antworten
  #7  
Alt 09.01.2018, 08:20
greystone greystone ist offline
Registered User
 
Registriert seit: 05.2016
Beiträge: 266
Zitat:
Der Server soll ja aber in Zukunft deutlich mehr Domains bekommen, die auch alle Mail-Adressen haben. Macht das nichts?
Das ist unerheblich. Wichtig für den rDNS ist, dass er korrekt ist - sprich, dass er vorwärts(DNS-Hostname -> IP) und rückwärts(IP -> DNS-Hostname) jeweils zu den gleichen Werten auflöst. Welcher DNS-Hostname das ist, ist so erstmal nicht an die E-Mail Domain(s) gebunden.
Mit Zitat antworten
  #8  
Alt 09.01.2018, 18:20
Benutzerbild von Thunderbyte
Thunderbyte Thunderbyte ist offline
Moderator
 
Registriert seit: 01.2006
Alter: 41
Beiträge: 6.454
Ich denke er will auf folgendes hinaus:

Wenn PTR Record und A Record für mail.netz-und-werke.de und IP Adresse in beide Richtungen geht, dann ist das die einzig korrekte Einstellung für den Mailserver auf diesem Server.

Natürlich kannst Du dieses Setting auch für andere Domains verwenden.

Für diesen Fall machst Du folgendes:

MX Record für netz-und-werke.de auf mail.netz-und-werke.de (MX Records dürfen keine IP Adressen sein!)
A Record für netz-und-werke.de auf 176.XX.XX.XX (Du solltest Deine IP unkenntlich machen!)

MX Record für domain2.de gleichfalls auf mail.netz-und-werke.de
MX Record für domain3.de gleichfalls auf mail.netz-und-werke.de
...und so weiter.

So passts immer und für alle Domains.

Als "kosmetischen" Mailserver zum Eintrag in den Client kannst Du ja immer noch:
CNAME Record für mail.domain2.de auf mail.netz-und-werke.de
CNAME Record für mail.domain3.de auf mail.netz-und-werke.de
legen. Das hat aber mit dem Versand oder MX Record erstmal nix zu tun.

Nebenbei solltest Du wohl noch am Besten einen SPF Record anlegen ( z.B. https://www.spfwizard.net oder andere).
__________________

...Der Werdegang eines Rootserveradmins...
Mit Zitat antworten
  #9  
Alt 10.01.2018, 19:45
Benutzerbild von danton
danton danton ist offline
Registered User
 
Registriert seit: 04.2009
Ort: Ennigerloh
Alter: 44
Beiträge: 2.442
Mails versenden geht nur teilweise / DNS Problem?
Zitat:
Zitat von Thunderbyte Beitrag anzeigen
Als "kosmetischen" Mailserver zum Eintrag in den Client kannst Du ja immer noch:
CNAME Record für mail.domain2.de auf mail.netz-und-werke.de
CNAME Record für mail.domain3.de auf mail.netz-und-werke.de
legen. Das hat aber mit dem Versand oder MX Record erstmal nix zu tun.
Das hat aber eine anderen unschönen Nebeneffekt und der betrifft die Mail-Clients. Sofern man nicht gerade ein Multi-Domain-Zertifikat hat, in dem alle Domains drin stehen, gibt es im Client eine schöne Zertifikatswarnung. Daher einfach nur mail.netz-und-werke.de verwenden, wenn man dein IMAP-Postfach im Client abrufen will, egal welche Domain vom Server es gerade betrifft. Ein Multi-Domain-Zertifikat würde das Problem zwar lösen, aber will man darüber auf einfachem Weg verraten, welche Domains noch auf diesem Server liegen?
__________________
Event-List - PHP/MySQL-Veranstaltungskalender für die eigene Homepage
Mit Zitat antworten
  #10  
Alt 11.01.2018, 22:58
Benutzerbild von Thunderbyte
Thunderbyte Thunderbyte ist offline
Moderator
 
Registriert seit: 01.2006
Alter: 41
Beiträge: 6.454
Da ist natürlich was dran. Ja. Dann doch lieber nur mail.netz-und-werke.de.

Ein Zertifikat dafür brauchst Du natürlich auch noch, falls das noch nicht gemacht ist. Denn verschlüsseln solltest Du den Mailverkehr natürlich schon.
__________________

...Der Werdegang eines Rootserveradmins...
Mit Zitat antworten
Antwort

Lesezeichen



Themen-Optionen
Thema bewerten
Thema bewerten:

Forumregeln
Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist aus.
HTML-Code ist aus.

Gehe zu

Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
DNS Problem - 1&1 und Powerdns loewexy DNS 4 25.02.2014 16:31
Mit Postfix versendete mails kommen nur teilweise an. tavid Mail 2 26.09.2008 14:34
Problem mit senden und abschicken von Mails niCeguY Confixx 8 04.05.2008 02:25
DNS Problem - Windows Server @ S4Y djtonjah Dedizierte Server 1 24.09.2005 19:29
Sendmail: Mails ohne Berechtigung versenden Senekha Mail 5 14.03.2004 13:10


Mails versenden geht nur teilweise / DNS Problem?
Mails versenden geht nur teilweise / DNS Problem?
Mails versenden geht nur teilweise / DNS Problem? Mails versenden geht nur teilweise / DNS Problem?
Powered by vBulletin® Version 3.8.11 (Deutsch)
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.