Server Support Forum
504 Gateway Time-out

Zurück   Server Support Forum > >


Antwort
 
Themen-Optionen Thema bewerten
  #1  
Alt 28.12.2017, 23:09
aerotech aerotech ist offline
Registered User
 
Registriert seit: 12.2017
Beiträge: 9
504 Gateway Time-out

Moin,

bei der Installation der Forensoftware WoltLab Suite Core erhalte ich ständig unmittelbar nach Beginn der Installation die Fehlermeldung 504 Gateway Time-out / nginx, obwohl alle benötigten Systemvoraussetzungen erfüllt werden.
Liegt das wohlmöglich an der Ausführungszeit für den Webserver Timeout?

Webservertyp und Version:
Root Server Linux Level 2 (v1209.1.38)

Serverbetriebssystem und Version:
Ubuntu 12.04 LTS Server 32bit + Plesk 11.0 (unsupported)

Gerne höre ich von einem Profi mit möglichen Lösungen.

VG
Mit Zitat antworten

  #2  
Alt 28.12.2017, 23:21
Benutzerbild von Cyperghost
Cyperghost Cyperghost ist offline
Registered User
 
Registriert seit: 10.2017
Beiträge: 14
504 Gateway Time-out
Guten Abend,

Dies Problem haben viele mit Plesk, und zwar muss die Antwortzeit vom Webserver(Apache und Nginx) sowie von PHP auf etwa 120 Sekunden gestellt werden.
Leider hat Plesk dies nur für PHP gemacht jedoch wartet der Webserver solange nicht.
Mit Zitat antworten
  #3  
Alt 28.12.2017, 23:28
aerotech aerotech ist offline
Registered User
 
Registriert seit: 12.2017
Beiträge: 9
Zitat:
Zitat von Cyperghost Beitrag anzeigen
Guten Abend,

Dies Problem haben viele mit Plesk, und zwar muss die Antwortzeit vom Webserver(Apache und Nginx) sowie von PHP auf etwa 120 Sekunden gestellt werden.
Leider hat Plesk dies nur für PHP gemacht jedoch wartet der Webserver solange nicht.

Ok, dass sind doch schon mal wichtige Informationen. DANKE für Deinen Support.
Weißt Du auch, wo genau ich da suchen muss? Diese Einstellung als solches kann ich in den allgemeinen Servereinstellungen als auch in den Apache Webserver und PHP-Einstellungen bei STRATO nirgends finden.

Geändert von aerotech (28.12.2017 um 23:30 Uhr)
Mit Zitat antworten
  #4  
Alt 28.12.2017, 23:34
Benutzerbild von Cyperghost
Cyperghost Cyperghost ist offline
Registered User
 
Registriert seit: 10.2017
Beiträge: 14
504 Gateway Time-out
Diese wie oben geschrieben müssten in der Config Files geändert werden.
Bei PHP, kannst du die max_execution Time erhöhen etwa auf 300.
Ich bin mir nicht sicher, aber ich glaube mit dem neuen Plesk haben die das behoben, bei den älteren Versionen ist das Problem noch drinnen.
Läuft der Nginx als Proxy oder mit FPM?
Mit Zitat antworten
  #5  
Alt 28.12.2017, 23:43
aerotech aerotech ist offline
Registered User
 
Registriert seit: 12.2017
Beiträge: 9
Zitat:
Zitat von Cyperghost Beitrag anzeigen
Diese wie oben geschrieben müssten in der Config Files geändert werden.
Bei PHP, kannst du die max_execution Time erhöhen etwa auf 300.
Ich bin mir nicht sicher, aber ich glaube mit dem neuen Plesk haben die das behoben, bei den älteren Versionen ist das Problem noch drinnen.
Läuft der Nginx als Proxy oder mit FPM?

Habe mal in den vier PHP.ini's den max_execution_time Wert auf 300 erhöht.
5.3.10 by OS vendor Apache-Modul
on 5.3.10 by OS vendor CGI-Anwendung
on 5.3.10 by OS vendor FastCGI-Anwendung
on 5.5.9 by OS vendor FPM-Anwendung

Mal schauen, ob das was bringt.
Mit Zitat antworten
  #6  
Alt 28.12.2017, 23:46
d3p d3p ist offline
Registered User
 
Registriert seit: 03.2010
Beiträge: 502
Cross-Posting.
https://community.woltlab.com/thread...-installation/
Mit Zitat antworten
  #7  
Alt 28.12.2017, 23:46
Benutzerbild von Cyperghost
Cyperghost Cyperghost ist offline
Registered User
 
Registriert seit: 10.2017
Beiträge: 14
504 Gateway Time-out
Teste mal vielleicht funktioniert es
Welches der oberen ist den ausgewählt für die Webseite?


Ach und eine Frage aus reiner Neugier
Warum verwendet man eigentlich nich 32 Bit?
Und so eine alte Plesk und Ubuntu(ist zwar LTS, aber schon bald 6 Jahre alt) Version?
Mit Zitat antworten
  #8  
Alt 28.12.2017, 23:49
aerotech aerotech ist offline
Registered User
 
Registriert seit: 12.2017
Beiträge: 9
Zitat:
Zitat von Cyperghost Beitrag anzeigen
Teste mal vielleicht funktioniert es
Welches der oberen ist den ausgewählt für die Webseite?


Ach und eine Frage aus reiner Neugier
Warum verwendet man eigentlich nich 32 Bit?
Und so eine alte Plesk und Ubuntu(ist zwar LTS, aber schon bald 6 Jahre alt) Version?
auf 5.3.10 by OS vendor FastCGI-Anwendung liegen 8 Domains

Es liegt an der Unwissenheit, dass noch keine Updates auf dem Server erfolgt sind.
Dank Deines Hinweises habe ich das Plesk auf 12.5.30 umgestellt.

Allerdings hat sich an meinem urspünglichem Problem nichts geändert.
Die Installation schlägt immer noch fehl.

Geändert von aerotech (29.12.2017 um 00:10 Uhr)
Mit Zitat antworten
Antwort

Lesezeichen



Themen-Optionen
Thema bewerten
Thema bewerten:

Forumregeln
Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist aus.
HTML-Code ist aus.

Gehe zu

Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
Webspace-Provider hostingraja - aus DE keine Verbindung nach Indien tobi4 Smalltalk 16 12.12.2017 16:34
Mail Log Einträge Flashrider Mail 20 06.09.2012 16:57
Client bekommt keinen Internetzugriff sitecom Dedizierte Windows Server 7 08.08.2012 19:37
Postfix SMTP server: errors from unknown[xxx.xxx.xxx.xxx]‏ Fusl Virtuelle Server 9 13.07.2010 01:16
Squid und fehler in der cache.log Snakekick Sonstige Serverdienste 1 21.06.2007 21:08


504 Gateway Time-out
504 Gateway Time-out
504 Gateway Time-out 504 Gateway Time-out
Powered by vBulletin® Version 3.8.11 (Deutsch)
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.