Server Support Forum
Upgrade Plesk Onyx 17.0.17 --> 17.5.3 fehlerhaft

Zurück   Server Support Forum > >


Antwort
 
Themen-Optionen Thema bewerten
  #1  
Alt 05.12.2017, 11:09
Mmax Mmax ist offline
Registered User
 
Registriert seit: 12.2017
Beiträge: 8
Upgrade Plesk Onyx 17.0.17 --> 17.5.3 fehlerhaft

Hallo Forum,
habe folgendes Problem, das ich nicht gelöst bekomme:
Beim Upgrade auf Plesk Onyx 17.0.17 --> 17.5.3 kommt es zu einer Fehlermeldung:
- dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem

Die Ausführung von 'dpkg --configure -a' brachte auch keinen Erfolg, Meldung: - dpkg: Fehler beim Bearbeiten des Paketes apparmor (--configure)

'plesk repair all' liefert mir die Fehlermeldung:
- The NS configuration file '/var/named/run-root/etc/named.conf' is
absent .................................................. .......... [ERROR]
Restoring the DNS configuration file
'/var/named/run-root/etc/named.conf' ............................ [2017-12-05 10:30:58] ERR [util_exec] proc_close() failed ['/opt/psa/admin/bin/filemng' 'root' 'cp' '-r' '/va r/named/run-root/etc/named.conf.default' '/var/named/run-root/etc/named.conf' '--allow-root'] with exit code [1]

Was kann ich machen? Letzter Ausweg ist eine komplette Neuinstallation des Servers.
Schonmal vielen Dank Max
Mit Zitat antworten

  #2  
Alt 06.12.2017, 09:15
Mmax Mmax ist offline
Registered User
 
Registriert seit: 12.2017
Beiträge: 8
kleine Ergänzung

Schade, dass es noch keine Hilfe gab.
Hier noch ein paar Info's:
Es handelt sich um einen Root Server Linux D500-69 (1609.12de-s) von Strato.
Nochmals Danke Max
Mit Zitat antworten
  #3  
Alt 06.12.2017, 12:36
Benutzerbild von catwiesel
catwiesel catwiesel ist offline
Registered User
 
Registriert seit: 12.2006
Ort: Zum Glück in Bayern
Beiträge: 873
Pauschal kann ich jetzt nur sagen das sich Plesk mit dem Paket Apparmor stört.

Dies schon gemacht:

https://support.plesk.com/hc/de/arti...r-deaktivieren
__________________
Programming today is a race between software engineers striving to build bigger and better idiot-proof programs, and the Universe trying to produce bigger and better idiots.
So far, ....the universe is winning!
Mit Zitat antworten
  #4  
Alt 06.12.2017, 13:48
Mmax Mmax ist offline
Registered User
 
Registriert seit: 12.2017
Beiträge: 8
keine Veränderung

Danke catwiesel für den Tip,
brachte aber leider keine Verbesserung.
Mit Zitat antworten
  #5  
Alt 06.12.2017, 14:24
Benutzerbild von reccon
reccon reccon ist offline
Registered User
 
Registriert seit: 12.2015
Alter: 39
Beiträge: 143
Upgrade Plesk Onyx 17.0.17 --> 17.5.3 fehlerhaft
Zitat:
Zitat von Mmax Beitrag anzeigen
ERR [util_exec] proc_close() failed ['/opt/psa/admin/bin/filemng' 'root' 'cp' '-r' '/var/named/run-root/etc/named.conf.default' '/var/named/run-root/etc/named.conf' '--allow-root'] with exit code [1]
Hast du mal geschaut, ob
/var/named/run-root/etc/named.conf.default
vorhanden ist und wenn ja, was passiert wenn man es nach
/var/named/run-root/etc/named.conf
kopiert?
Mit Zitat antworten
  #6  
Alt 06.12.2017, 16:12
Mmax Mmax ist offline
Registered User
 
Registriert seit: 12.2017
Beiträge: 8
Nein, ist nicht vorhanden.
Auf dem Server gibt es kein (oder ich sehe kein) Verzeichnis /var/named/... und foglich auch nicht die Dateien.
Mit Zitat antworten
  #7  
Alt 06.12.2017, 16:37
Benutzerbild von reccon
reccon reccon ist offline
Registered User
 
Registriert seit: 12.2015
Alter: 39
Beiträge: 143
Upgrade Plesk Onyx 17.0.17 --> 17.5.3 fehlerhaft
Dann scheint bind gar nicht installiert zu sein:

Reinstall BIND server support component via Plesk autoinstaller:

/usr/local/psa/admin/bin/autoinstaller

Or via Plesk GUI: Plesk > Tools&settings > Updates and Upgrades
Mit Zitat antworten
  #8  
Alt 06.12.2017, 20:39
Mmax Mmax ist offline
Registered User
 
Registriert seit: 12.2017
Beiträge: 8
Hat leider auch nicht geholfen.
Ergab die bekannte Fehlermeldung:

Installing packages
E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.

ERROR: An error occurred on attempt to install packages.
Attention! Your software might be inoperable.
Please contact product technical support.
Mit Zitat antworten
  #9  
Alt 07.12.2017, 09:44
jlsoft jlsoft ist offline
Registered User
 
Registriert seit: 10.2017
Beiträge: 1
Zitat:
Zitat von Mmax Beitrag anzeigen
Hat leider auch nicht geholfen.
Ergab die bekannte Fehlermeldung:

Installing packages
E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.

ERROR: An error occurred on attempt to install packages.
Attention! Your software might be inoperable.
Please contact product technical support.
Hast du schon folgendes versucht:

# apt-get autoremove
# apt-get clean
# aptitude update
# aptitude upgrade

und danach

# plesk installer --select-release-current --reinstall-patch --upgrade-installed-components

Das repariert fehlende oder korrupte Pakete.
Mit Zitat antworten
  #10  
Alt 07.12.2017, 12:09
Mmax Mmax ist offline
Registered User
 
Registriert seit: 12.2017
Beiträge: 8
Danke für die Mühe. Nein, hatte ich noch nicht versucht.
Führt aber leider auch nur zur bekannten Meldung:

E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.

Und das funktioniert ja auch nicht.
Werde am Montag den Server komplett neu installieren müssen.
Mit Zitat antworten
  #11  
Alt 07.12.2017, 12:30
greystone greystone ist offline
Registered User
 
Registriert seit: 05.2016
Beiträge: 257
Zitat:
- dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem

Die Ausführung von 'dpkg --configure -a' brachte auch keinen Erfolg, Meldung: - dpkg: Fehler beim Bearbeiten des Paketes apparmor (--configure)
Da muss bei dpkg --configure -a noch mehr gekommen sein als: dpkg: Fehler beim Bearbeiten des Paketes apparmor (--configure)

Wahrscheinlich ist das postinstall Script fehlgeschlagen.
Mit Zitat antworten
  #12  
Alt 12.12.2017, 09:46
Mmax Mmax ist offline
Registered User
 
Registriert seit: 12.2017
Beiträge: 8
Danke

für eure Hilfe,
habe gestern den Server neu aufgesetzt, scheint bis jetzt alles zu laufen.
Danke noch mals Max
Mit Zitat antworten
Antwort

Lesezeichen


Themen-Optionen
Thema bewerten
Thema bewerten:

Forumregeln
Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist aus.
HTML-Code ist aus.

Gehe zu

Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
Plesk Onyx 17.5.3 für Debian? Shorty Plesk 4 06.08.2017 17:57
Erfahrungsbericht: Warden Antispam & Antivirus für Plesk 12 & Plesk Onyx transp0rter Plesk 9 28.04.2017 10:30
Neue Plesk Hosting Suite Lizenzen 10.x / Sitebuilder 5.x / Billing Tune up IT Biete 0 11.09.2011 18:19
Upgrade Plesk 8.0 auf 8.0.1 bei 1BLU -> Absturtz msX Virtuelle Server 9 05.07.2008 23:27


Upgrade Plesk Onyx 17.0.17 --> 17.5.3 fehlerhaft
Upgrade Plesk Onyx 17.0.17 --> 17.5.3 fehlerhaft
Upgrade Plesk Onyx 17.0.17 --> 17.5.3 fehlerhaft Upgrade Plesk Onyx 17.0.17 --> 17.5.3 fehlerhaft
Powered by vBulletin® Version 3.8.11 (Deutsch)
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.