Server Support Forum
Massive Spam Probleme - Spamassasin funktioniert nicht

Zurück   Server Support Forum > >


Antwort
 
Themen-Optionen Thema bewerten
  #1  
Alt 08.04.2017, 16:58
hanssonny hanssonny ist offline
Registered User
 
Registriert seit: 06.2012
Beiträge: 20
Massive Spam Probleme - Spamassasin funktioniert nicht

Hi Zusammen,

im Moment bekomm ich mega viel Spam. Die Mails haben einen Spamscore von 5.5 - 6 ...

Bei mir läuft Plesk 17 auf ubuntu

Ich dachte dann ich stell den Spamassasin einfach auf 5 und gut ist ...

leider kommen trotzdem mails durch alle 3minuten 2-4 mails ...

Ich hab die EInstellung sowohl systemweit gesetzt, als auch für die betroffene Mail-Adresse ....

Ich geh aber davon aus dass der spamassasin nicht läuft oder nichts tut. Was kann ich tun um das Problem zu beseitigen?

Danke
Mit Zitat antworten

  #2  
Alt 08.04.2017, 17:15
rolapp rolapp ist offline
Fan vom SSF
 
Registriert seit: 07.2011
Ort: Erlensee, Hessen
Beiträge: 665
bei mir funktioniert die Glaskugel nicht.

Code:
PS -A | grep spam
__________________
Gruß
Steffen
Mit Zitat antworten
  #3  
Alt 08.04.2017, 17:18
hanssonny hanssonny ist offline
Registered User
 
Registriert seit: 06.2012
Beiträge: 20
liefert nichts zurück... d.h. wohl spamassasin läuft nicht oder?

wenn ich den dienst aber starten will sagt er läuft bereits ....

wenn ich mit htop schau dann ist spamd auch da

Geändert von hanssonny (08.04.2017 um 17:26 Uhr)
Mit Zitat antworten
  #4  
Alt 08.04.2017, 17:52
GwenDragon GwenDragon ist offline
Registered User
 
Registriert seit: 12.2008
Ort: Franken
Alter: 57
Beiträge: 2.965
Läuft dein Spamassassin wirklich nicht? Dann sollte auch in einer empfangenen Mail kein Header drin sein. Schau dir bitte mal den Quelltext an.

Sieht am Anfang der Mail beispielsweise so aus:
HTML-Code:
X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on .......de
X-Spam-Level: 
X-Spam-Status: No, score=0.3 required=6.0 tests=DKIM_ADSP_CUSTOM_MED,
        DKIM_SIGNED,FREEMAIL_FORGED_FROMDOMAIN,FREEMAIL_FROM,
        HEADER_FROM_DIFFERENT_DOMAINS,RP_MATCHES_RCVD,T_DKIM_INVALID autolearn=no
        autolearn_force=no version=3.4.0
__________________
die Gwen, also die Drachin... nix anderscht!

Geändert von GwenDragon (08.04.2017 um 17:55 Uhr)
Mit Zitat antworten
  #5  
Alt 08.04.2017, 17:57
hanssonny hanssonny ist offline
Registered User
 
Registriert seit: 06.2012
Beiträge: 20
also eine Mail die hier vom Forum kommt hat das im Header:

Code:
Return-Path: <www-data@serversupportforum.de>
X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on
    Mein VServer
X-Spam-Level: 
X-Spam-Status: No, score=-1.9 required=4.0 tests=BAYES_00,RP_MATCHES_RCVD,
    URIBL_BLOCKED autolearn=ham autolearn_force=no version=3.4.0

Wenn ich eine von den Spam Mails nehme ... steht genau das gleiche drin ....

Wenn ich eine von den Spam Mails nehme und hier prüfe: http://spamcheck.postmarkapp.com/ bekomm ich 5.7 raus ...
Mit Zitat antworten
  #6  
Alt 08.04.2017, 18:41
Powie Powie ist offline
Registered User
 
Registriert seit: 03.2004
Beiträge: 117
Powie eine Nachricht über MSN schicken Massive Spam Probleme - Spamassasin funktioniert nicht
Also ich persönlich halte von spamassassin genau deswegen nichts. Zu viel rutscht durch, knapp am score wert vorbei. Und deun serve muss den kram veabreiten.

Seitdem es die extension magicspam für plesk gibt hat man damit viel mehr erfolg, und der serve muss den müll garnicht erst fressen. Probier das mal. Danach wird SA arbeitslos...
Mit Zitat antworten
  #7  
Alt 08.04.2017, 18:46
hanssonny hanssonny ist offline
Registered User
 
Registriert seit: 06.2012
Beiträge: 20
magicspam kostet doch aber 10€ im Monat

Woran kann es denn liegen dass spamassasin so überhaupt nicht funzt
Mit Zitat antworten
  #8  
Alt 09.04.2017, 11:01
GwenDragon GwenDragon ist offline
Registered User
 
Registriert seit: 12.2008
Ort: Franken
Alter: 57
Beiträge: 2.965
Bei Sppamassassin kommt es darauf an, welche Regeln er aktiv hat und welche Mittel er zur Prüfung nimmt.
Mit sa-update -D in der shell lässt sich sehen welche Perl-Module er lädt und welche du mit cpan noch nach installieren kannst.

Ansonsten sollte mit Plesk der Spamassassin laufen.
__________________
die Gwen, also die Drachin... nix anderscht!
Mit Zitat antworten
  #9  
Alt 09.04.2017, 11:04
hanssonny hanssonny ist offline
Registered User
 
Registriert seit: 06.2012
Beiträge: 20
hab ich ausgeführt, screenshot ist angehängt. danke.
Miniaturansicht angehängter Grafiken
Massive Spam Probleme - Spamassasin funktioniert nicht-screenshot_2017.04.09_11h03m51s_001_.png  
Mit Zitat antworten
  #10  
Alt 09.04.2017, 11:56
GwenDragon GwenDragon ist offline
Registered User
 
Registriert seit: 12.2008
Ort: Franken
Alter: 57
Beiträge: 2.965
Screenshot kann ich nicht lesen. Bitte, man kann auch Textinhalte kopieren

Dann installiere noch die fehlenden Perl-Module in der Shell mit dem Pakatemanager deines Systems oder mit cpan.
__________________
die Gwen, also die Drachin... nix anderscht!
Mit Zitat antworten
  #11  
Alt 09.04.2017, 12:47
hanssonny hanssonny ist offline
Registered User
 
Registriert seit: 06.2012
Beiträge: 20
Code:
Apr  9 12:47:06.494 [15610] dbg: logger: adding facilities: all
Apr  9 12:47:06.494 [15610] dbg: logger: logging level is DBG
Apr  9 12:47:06.494 [15610] dbg: generic: SpamAssassin version 3.4.0
Apr  9 12:47:06.494 [15610] dbg: generic: Perl 5.018002, PREFIX=/usr, DEF_RULES_DIR=/usr/share/spamassassin, LOCAL_RULES_DIR=/etc/spamassassin, LOCAL_STATE_DIR=/var/lib/spamassassin
Apr  9 12:47:06.494 [15610] dbg: config: timing enabled
Apr  9 12:47:06.494 [15610] dbg: config: score set 0 chosen.
Apr  9 12:47:06.497 [15610] dbg: generic: sa-update version svn1475932
Apr  9 12:47:06.497 [15610] dbg: generic: using update directory: /var/lib/spamassassin/3.004000
Apr  9 12:47:06.550 [15610] dbg: diag: perl platform: 5.018002 linux
Apr  9 12:47:06.550 [15610] dbg: diag: [...] module installed: Digest::SHA, version 5.84_01
Apr  9 12:47:06.550 [15610] dbg: diag: [...] module installed: HTML::Parser, version 3.71
Apr  9 12:47:06.550 [15610] dbg: diag: [...] module installed: Net::DNS, version 0.68
Apr  9 12:47:06.550 [15610] dbg: diag: [...] module installed: NetAddr::IP, version 4.071
Apr  9 12:47:06.550 [15610] dbg: diag: [...] module installed: Time::HiRes, version 1.9725
Apr  9 12:47:06.550 [15610] dbg: diag: [...] module installed: Archive::Tar, version 1.90
Apr  9 12:47:06.550 [15610] dbg: diag: [...] module installed: IO::Zlib, version 1.10
Apr  9 12:47:06.550 [15610] dbg: diag: [...] module not installed: Digest::SHA1 ('require' failed)
Apr  9 12:47:06.550 [15610] dbg: diag: [...] module installed: MIME::Base64, version 3.13
Apr  9 12:47:06.550 [15610] dbg: diag: [...] module installed: DB_File, version 1.827
Apr  9 12:47:06.550 [15610] dbg: diag: [...] module installed: Net::SMTP, version 2.31
Apr  9 12:47:06.550 [15610] dbg: diag: [...] module installed: Mail::SPF, version v2.009
Apr  9 12:47:06.550 [15610] dbg: diag: [...] module not installed: Geo::IP ('require' failed)
Apr  9 12:47:06.550 [15610] dbg: diag: [...] module not installed: Razor2::Client::Agent ('require' failed)
Apr  9 12:47:06.550 [15610] dbg: diag: [...] module not installed: IO::Socket::IP ('require' failed)
Apr  9 12:47:06.550 [15610] dbg: diag: [...] module installed: IO::Socket::INET6, version 2.71
Apr  9 12:47:06.550 [15610] dbg: diag: [...] module installed: IO::Socket::SSL, version 1.965
Apr  9 12:47:06.550 [15610] dbg: diag: [...] module installed: Compress::Zlib, version 2.06
Apr  9 12:47:06.550 [15610] dbg: diag: [...] module not installed: Mail::DKIM ('require' failed)
Apr  9 12:47:06.550 [15610] dbg: diag: [...] module installed: DBI, version 1.63
Apr  9 12:47:06.550 [15610] dbg: diag: [...] module installed: Getopt::Long, version 2.39
Apr  9 12:47:06.550 [15610] dbg: diag: [...] module installed: LWP::UserAgent, version 6.05
Apr  9 12:47:06.550 [15610] dbg: diag: [...] module installed: HTTP::Date, version 6.02
Apr  9 12:47:06.550 [15610] dbg: diag: [...] module not installed: Encode::Detect ('require' failed)
Apr  9 12:47:06.550 [15610] dbg: diag: [...] module not installed: Net::Patricia ('require' failed)
Apr  9 12:47:06.550 [15610] dbg: gpg: Searching for 'gpg'
Apr  9 12:47:06.550 [15610] dbg: util: current PATH is: /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games
Apr  9 12:47:06.550 [15610] dbg: util: executable for gpg was found at /usr/bin/gpg
Apr  9 12:47:06.551 [15610] dbg: gpg: found /usr/bin/gpg
Apr  9 12:47:06.551 [15610] dbg: gpg: release trusted key id list: 5E541DC959CB8BAC7C78DFDC4056A61A5244EC45 0C2B1D7175B852C64B3CDC716C55397824F434CE
Apr  9 12:47:06.551 [15610] dbg: channel: attempting channel updates.spamassassin.org
Apr  9 12:47:06.551 [15610] dbg: channel: using existing directory /var/lib/spamassassin/3.004000/updates_spamassassin_org
Apr  9 12:47:06.551 [15610] dbg: channel: channel cf file /var/lib/spamassassin/3.004000/updates_spamassassin_org.cf
Apr  9 12:47:06.551 [15610] dbg: channel: channel pre file /var/lib/spamassassin/3.004000/updates_spamassassin_org.pre
Apr  9 12:47:06.551 [15610] dbg: channel: metadata version = 1786853, from file /var/lib/spamassassin/3.004000/updates_spamassassin_org.cf
Apr  9 12:47:06.565 [15610] dbg: dns: 0.4.3.updates.spamassassin.org => 1786640, parsed as 1786640
Apr  9 12:47:06.565 [15610] dbg: channel: current version is 1786853, new version is 1786640, skipping channel
Apr  9 12:47:06.565 [15610] dbg: diag: updates complete, exiting with code 1

Welche Module fehlen denn?
Mit Zitat antworten
  #12  
Alt 09.04.2017, 13:46
GwenDragon GwenDragon ist offline
Registered User
 
Registriert seit: 12.2008
Ort: Franken
Alter: 57
Beiträge: 2.965
Wie sind denn deine Englischkenntnisse? Was glaubst du wird wohl das 'module not installed' bedeuten?
__________________
die Gwen, also die Drachin... nix anderscht!
Mit Zitat antworten
  #13  
Alt 09.04.2017, 13:48
hanssonny hanssonny ist offline
Registered User
 
Registriert seit: 06.2012
Beiträge: 20
ihr seid hier im forum immer äußerst hilfreich und nett das möchte ich schonmal sagen ...

blos weil da not installed steht heißt das ja noch lange nicht dass das sinnvoll ist ... geschweige denn dass es mein problem löst wenn ich jetzt einfach mal alle nicht installierten plugins rein hau ....

bisschen präziser wäre durchaus nett ....

Danke
Mit Zitat antworten
  #14  
Alt 09.04.2017, 14:27
GwenDragon GwenDragon ist offline
Registered User
 
Registriert seit: 12.2008
Ort: Franken
Alter: 57
Beiträge: 2.965
Tut mir leid, aber mir ist nicht dein Wissenstand bekannt.

Ich habe mir schon was dabei gedacht, dass du mit sa-update mal die Debug-Ausgabe ansiehst, denn da erkennt mann ob Spamassassin die Perl-Module lädt.
Das Hinzufügen der Module verbessert die Erkennungsrate.
Dann lass es erst mal wenn du das nicht brauchst.

Zu deinem angeblichen "nicht Erkennen" zurück:
Schau dir mal im syslog zum Zeitpunkt des Empfangs eines schlecht erkannten Spam irgendwelche problematischen Meldungen an.
Sie sind für 9. April gegen 14 Uhr (du musst das andere Datum einsetzen) zu finden zu finden mit:
grep "Apr 9 14:" /var/log/maillog | grep spamd


Probier doch mal die Mailkonfiguration zu reapeiren mit
plesk repair mail -y
und
/usr/local/psa/admin/sbin/mchk –with-spam

Schau dann bitte mal die Scores an mit
grep score /var/qmail/mailnames/*/*/.spamassassin/user_prefs



Sind diese nicht erkannten Spam-Mails eigentlich nur Bilder, Plain-Text oder HTML?
__________________
die Gwen, also die Drachin... nix anderscht!

Geändert von GwenDragon (09.04.2017 um 14:41 Uhr)
Mit Zitat antworten
Antwort

Lesezeichen

Stichworte
plesk, spam, spamassasin, ubuntu


Themen-Optionen
Thema bewerten
Thema bewerten:

Forumregeln
Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist aus.
HTML-Code ist aus.

Gehe zu

Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
Squirrelmail - Postfix - Spamassasin - Standart Spamordner SPAM coolsoft Mail 5 18.04.2008 12:07
Spamassasin und Emails die Spam sind aber Dürchgelassen werden maiki Dedizierte Server 6 17.09.2007 17:09
Große Probleme in den letzten 2 Tagen blob Smalltalk 0 13.07.2007 21:43
Massive technische Probleme beim neuen Hoster 1blu... Metapro Server Down 29 21.04.2007 18:57
Plesk 8.0.1 Spamassasin funktioniert nicht wirklich lawe Plesk 18 19.04.2007 11:52


Massive Spam Probleme - Spamassasin funktioniert nicht
Massive Spam Probleme - Spamassasin funktioniert nicht
Massive Spam Probleme - Spamassasin funktioniert nicht Massive Spam Probleme - Spamassasin funktioniert nicht
Powered by vBulletin® Version 3.8.11 (Deutsch)
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.