Server Support Forum
Anzeige:
Apache Module deaktivieren

Zurück   Server Support Forum > >

Anzeige:

Antwort
 
Themen-Optionen Thema bewerten
  #1  
Alt 13.02.2017, 20:12
knollsen knollsen ist offline
Registered User
 
Registriert seit: 01.2016
Beiträge: 38
Apache Module deaktivieren

Bei der Neuinstallation Plesk Onyx unter PHP-Einstellungen gibt es eine Fehlermeldung (s.Bild)
7.0.13 by OS vendor mod_php - der Händler kann nicht aktiviert werden, weil das zugehörige Apache-Modul fehlt
Habe alles probiert um dies zu deaktivieren oder es zu aktivieren, aber nicht's hilft. Ist das ein Bug? Bei Euch auch?
Miniaturansicht angehängter Grafiken
Apache Module deaktivieren-unbenannt2.jpg  
Mit Zitat antworten

  #2  
Alt 14.02.2017, 09:10
GwenDragon GwenDragon ist offline
Registered User
 
Registriert seit: 12.2008
Ort: Franken
Alter: 57
Beiträge: 2.829
Wenn für dein Betriebssystem mod_php 7.0.13 für Apache vorhanden ist, installiere es über den Paketmananger und dann kannst du es aktivieren.
__________________
die Gwen, also die Drachin... nix anderscht!
Mit Zitat antworten
  #3  
Alt 14.02.2017, 10:03
knollsen knollsen ist offline
Registered User
 
Registriert seit: 01.2016
Beiträge: 38
Ich hatte schon mod_perl, mod_bw, mod_python aktivierrt. da das nicht funktionierte, hatte ich die wieder entfernt. Was anderes ist nicht da? s.Bild
Miniaturansicht angehängter Grafiken
Apache Module deaktivieren-unbenannt.jpg  
Mit Zitat antworten
  #4  
Alt 14.02.2017, 10:40
GwenDragon GwenDragon ist offline
Registered User
 
Registriert seit: 12.2008
Ort: Franken
Alter: 57
Beiträge: 2.829
Bitte logge dich über SSH als root bei deinem System ein und starte den dort Paketmanager.
Wie das bei dir geht weiß ich nicht, da du nicht schreibst, welches Betriebssystem du nutzt.
Ich nehme an es ist Ubuntu, da du in einem früheren Post das erwähntest.
Code:
apt install libapache2-mod-php5
__________________
die Gwen, also die Drachin... nix anderscht!

Geändert von GwenDragon (14.02.2017 um 11:20 Uhr)
Mit Zitat antworten
  #5  
Alt 14.02.2017, 12:27
knollsen knollsen ist offline
Registered User
 
Registriert seit: 01.2016
Beiträge: 38
Ubuntu 16.04.2 LTS‬
Plesk Onyx Version 17.0.17

Habe ich gemacht Ausgabe: Für Paket »libapache2-mod-php5« existiert kein Installationskandidat.

Eigentlich will ich es ja aus der Liste, da ich keinen Sinn sehe.
Nutzen wollte ich nur PHP - FPM-Anwendung von nginx
Mit Zitat antworten
  #6  
Alt 14.02.2017, 12:31
Benutzerbild von DeaD_EyE
DeaD_EyE DeaD_EyE ist offline
Registered User
 
Registriert seit: 07.2010
Ort: Hagen
Alter: 34
Beiträge: 1.769
DeaD_EyE eine Nachricht über ICQ schicken
Code:
apt-get install libapache2-mod-php7.0
a2enmod php7.0
systemctl reload apache2
Die Vorherige Installation der Module sollte aber normalerweise das Postinstallscript aufrufen, welches die Module aktiviert.

Solltest du deine verwendete Distribution Debian sein und kein PHP7 zur Verfügung stehen, solltest du dir mal Dotdeb ansehen. Ubuntu Server 16.04 hat PHP7.0 im respository. Dotdeb: https://www.dotdeb.org/about/

EDIT: Da du Ubuntu nutzt, sollte sich das Paket einfach installieren lassen und dann auch sofort funktionieren.
__________________
>>> join('white', 'red', 'yellow', 'black')
'freedom'

Geändert von DeaD_EyE (14.02.2017 um 12:34 Uhr)
Mit Zitat antworten
  #7  
Alt 14.02.2017, 13:01
knollsen knollsen ist offline
Registered User
 
Registriert seit: 01.2016
Beiträge: 38
Hab ich mal versucht
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
libapache2-mod-php7.0 is already the newest version (7.0.13-0ubuntu0.16.04.1).
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert
# a2enmod php7.0
Considering conflict php5 for php7.0:
Enabling module php7.0.
To activate the new configuration, you need to run:
service apache2 restart
root@----:~# systemctl reload apache2
Job for apache2.service failed because the control process exited with error code. See "systemctl status apache2.service" and "journalctl -xe" for details

mmm - Kein Plan - deswegen vermute ich hier ein Bug
Mit Zitat antworten
  #8  
Alt 14.02.2017, 13:05
Benutzerbild von nexus
nexus nexus ist offline
Registered User
 
Registriert seit: 06.2011
Beiträge: 1.336
Was sagen die Ausgaben von:

Zitat:
Zitat von knollsen Beitrag anzeigen
See "systemctl status apache2.service" and "journalctl -xe" for details
__________________
Ist ein Server das Richtige für mich? -> Entscheidungshilfe und Erste Schritte
Lesenswert für alle Mailserver-Admins -> Best Practice für stressfreie Mailserver
Server- und Hostinganbieter, die ich empfehlen kann -> PHP-Friends, IP-Projects, Keyweb, Netcup
Hier gibt es alle Infos zu Schulferien (Insider wissen, was ich meine ) -> schulferien.org
Mit Zitat antworten
  #9  
Alt 14.02.2017, 13:20
knollsen knollsen ist offline
Registered User
 
Registriert seit: 01.2016
Beiträge: 38
in Plesk habe ich jetzt unter Apache Webserver-Einstellungen den Hacken bei PHP7.0
das ist das selbe wie bei ssh
Jetzt habe ich in Plesk folgende rote Meldung im Header! (s.Bild)
Das hatte ich schon mal versucht und hatte es dann wieder deaktiviert!
Miniaturansicht angehängter Grafiken
Apache Module deaktivieren-unbenannt.jpg  
Mit Zitat antworten
  #10  
Alt 14.02.2017, 13:27
GwenDragon GwenDragon ist offline
Registered User
 
Registriert seit: 12.2008
Ort: Franken
Alter: 57
Beiträge: 2.829
Dann hilft auf MPM Prefork umzustellen
Code:
sudo a2dismod mpm_event 
sudo a2enmod mpm_prefork
__________________
die Gwen, also die Drachin... nix anderscht!
Mit Zitat antworten
  #11  
Alt 14.02.2017, 13:36
knollsen knollsen ist offline
Registered User
 
Registriert seit: 01.2016
Beiträge: 38
in Plesk unter Apache Webserver-Einstellungen hab ich's umgestellt
Was bewirkt eigentlich Prefork? (das ist was für Experten) nicht das ich was kaputt mache! bin nicht mehr der jüngste!

NEE hat nix geholfen - Server auch neu gestartet
Stopp Warnmeldung weg hab auf "hier" geklickt in der Warnmeldung Konfigurationsdatei wurde erstellt!
was bleibt ist die warning 7.0.13 by OS vendor mod_php unter den PHP-Einstellungen, das ist geblieben!

Geändert von knollsen (14.02.2017 um 13:40 Uhr)
Mit Zitat antworten
  #12  
Alt 14.02.2017, 13:47
GwenDragon GwenDragon ist offline
Registered User
 
Registriert seit: 12.2008
Ort: Franken
Alter: 57
Beiträge: 2.829
Und was zeigen in der Shell nun
Code:
systemctl status apache2.service
journalctl -xe
als Ausgabe?
__________________
die Gwen, also die Drachin... nix anderscht!
Mit Zitat antworten
  #13  
Alt 14.02.2017, 14:02
knollsen knollsen ist offline
Registered User
 
Registriert seit: 01.2016
Beiträge: 38
Alles poste ich da aber nicht
Loaded: loaded (/etc/init.d/apache2; bad; vendor preset: enabled)
Drop-In: /lib/systemd/system/apache2.service.d
ââapache2-systemd.conf
Active: active (running) since Di 2017-02-14 13:52:56 CET; 3min 31s ago
Docs: man:systemd-sysv-generator(8)
Process: 26861 ExecStop=/etc/init.d/apache2 stop (code=exited, status=0/SUCCESS)
Process: 26937 ExecStart=/etc/init.d/apache2 start (code=exited, status=0/SUCCESS)
CGroup: /system.slice/apache2.service
ââ26952 /usr/sbin/apache2 -k start
ââ26955 /usr/sbin/apache2 -k start
ââ26956 /usr/sbin/apache2 -k start
ââ26957 /usr/sbin/apache2 -k start
ââ26958 /usr/sbin/apache2 -k start
ââ26959 /usr/sbin/apache2 -k start
ââ26960 /usr/sbin/apache2 -k start

Olles IO
Mit Zitat antworten
  #14  
Alt 14.02.2017, 14:17
GwenDragon GwenDragon ist offline
Registered User
 
Registriert seit: 12.2008
Ort: Franken
Alter: 57
Beiträge: 2.829
Hast du denn jetzt den PHP-Handler für mod_php vendor aktiviert?
__________________
die Gwen, also die Drachin... nix anderscht!
Mit Zitat antworten
  #15  
Alt 14.02.2017, 14:49
knollsen knollsen ist offline
Registered User
 
Registriert seit: 01.2016
Beiträge: 38
HA Du bist gut! Wo denn? Da gibt's nix in Plesk Komponenten, nur das was Du im 3. Post siehst! Das ganze WWW sagt nix.
Vom Prinzip brauch ichs nicht! Aber Warnmeldungen sind immer Schitt und machen die logs zu!
Mit Zitat antworten
Antwort

Lesezeichen


Themen-Optionen
Thema bewerten
Thema bewerten:

Forumregeln
Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist aus.
HTML-Code ist aus.

Gehe zu

Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
Problem mit Amavis firemaster1985 Mail 7 02.11.2013 09:56
INSPIrcd mit Atheme Services SaKe IRC 2 20.08.2012 15:55
Proftpd+MySql+VHCS2 Tuxy FTP 11 02.08.2007 16:21
Apache optimieren / Apache lahmt combat Webserver 14 20.05.2007 11:47


Apache Module deaktivieren
Apache Module deaktivieren
Apache Module deaktivieren Apache Module deaktivieren
Powered by vBulletin® Version 3.8.11 (Deutsch)
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.