Server Support Forum
Mails erscheinen trotz "delivered to mailbox" nicht

Zurück   Server Support Forum > >


Antwort
 
Themen-Optionen Thema bewerten
  #1  
Alt 07.09.2013, 12:20
janos janos ist offline
Registered User
 
Registriert seit: 10.2010
Beiträge: 5
Ausrufezeichen Mails erscheinen trotz "delivered to mailbox" nicht

Guten Tag allerseits

Ich hab folgendes Problem: Seit letzter Nacht versuche ich auf meinem vServer einen Mailserver mit Dovecot und Postfix auf die Beine zu stellen. So weit so gut, der Mail-Versand klappt auch. Allerdings gibt es Probleme wenn ich Nachrichten empfangen will. In den Logs taucht die Nachricht auf, jedoch immer mit dem Zusatz "delivered to Mailbox". Im ganzen sieht die entsprechende Log-Meldung so aus:

Code:
Sep  7 11:56:54 hostname postfix/smtpd[30912]: B539C255E8503: client=client.tld[80.237.138.58]
Sep  7 11:56:54 hostname postfix/cleanup[30422]: B539C255E8503: message-id=<406c15c8690f34ca4c73b77f70cead99-EhVcX1lDTQNZWU
Sep  7 11:56:54 hostname postfix/qmgr[30285]: B539C255E8503: from=<user@domain.tld>, size=1573, nrcpt=1 (queue active
Sep  7 11:56:54 s15378047 postfix/virtual[30437]: B539C255E8503: to=<user@vserver.tld>, relay=virtual, delay=0.01, delays=0.01/0/0/0, dsn=2.0.0, status=sent (delivered to mailbox)

Sep  7 11:56:54 hostname postfix/qmgr[30285]: B539C255E8503: removed
Der Output von dovecot -n:

Code:
# 2.1.7: /etc/dovecot/dovecot.conf
# OS: Linux 2.6.32-042stab078.27 x86_64 Debian 6.0.7 reiserfs
auth_mechanisms = plain login
disable_plaintext_auth = no
hostname = ***
log_path = /var/log/dovecot.log
mail_gid = vmail
mail_location = maildir:/var/mail/%d/%n/mail
mail_privileged_group = mail
mail_uid = vmail
namespace inbox {
  inbox = yes
  location =
  mailbox Drafts {
    special_use = \Drafts
  }
  mailbox Junk {
    special_use = \Junk
  }
  mailbox Sent {
    special_use = \Sent
  }
  mailbox "Sent Messages" {
    special_use = \Sent
  }
  mailbox Trash {
    special_use = \Trash
  }
  prefix =
}
passdb {
  driver = pam
}
passdb {
  args = /etc/dovecot/dovecot-sql.conf.ext
  driver = sql
}
postmaster_address = postmaster@****
protocols = " imap lmtp pop3"
service auth {
  unix_listener /var/spool/postfix/private/auth {
    group = postfix
    mode = 0660
    user = postfix
  }
}
ssl_cert = </etc/dovecot/dovecot.pem
ssl_key = </etc/dovecot/private/dovecot.pem
userdb {
  driver = passwd
}
userdb {
  args = uid=5000 gid=5000 home=/var/mail/%d/$n/mail allow_all_users=yes
  driver = static
}
protocol lda {
  auth_socket_path = /var/run/dovecot/auth-master
  log_path = /var/mail/dovecot-deliver.log
  mail_plugins = sieve
  postmaster_address = postmaster@****
}
und von postconf -n

Code:
address_verify_negative_cache = no
alias_database = hash:/etc/aliases
alias_maps = hash:/etc/aliases
append_dot_mydomain = no
biff = no
config_directory = /etc/postfix
disable_dns_lookups = no
disable_vrfy_command = yes
inet_interfaces = all
mailbox_size_limit = 0
mydestination = localhost.onlinehome-server.info, localhost
myhostname = ***
mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128 
myorigin = /etc/mailname
queue_directory = /var/spool/postfix
readme_directory = no
recipient_delimiter = +
relayhost =
smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
smtpd_client_restrictions =
smtpd_data_restrictions =
smtpd_delay_reject = yes
smtpd_helo_required = yes
smtpd_helo_restrictions =
smtpd_recipient_restrictions = permit_mynetworks    permit_sasl_authenticated    reject_unauth_destination
smtpd_sasl_auth_enable = yes
smtpd_sasl_local_domain = ***
smtpd_sasl_path = private/auth
smtpd_sasl_security_options = noanonymous
smtpd_sasl_type = dovecot
smtpd_tls_cert_file = /etc/ssl/certs/postfix.pem
smtpd_tls_key_file = /etc/ssl/private/postfix.pem
unverified_recipient_reject_reason = 550 5.1.1 User doesn't exist.
virtual_alias_maps = mysql:/etc/postfix/mysql-virtual-alias-maps.cf,mysql:/etc/postfix/mysql-email2email.cf
virtual_gid_maps = static:5000
virtual_mailbox_base = /var/mail
virtual_mailbox_domains = mysql:/etc/postfix/mysql-virtual-mailbox-domains.cf
virtual_mailbox_maps = mysql:/etc/postfix/mysql-virtual-mailbox-maps.cf
virtual_transport = virtual
virtual_uid_maps = static:5000
Ich vermute mal das dass irgendein Fehler in der Config. Achja, meine Mails sind unter /var/mail/{DOMAIN}/{USER}/mail/ gespeichert, das ganze ist virtuell, also mit MySQL aufgebaut.

Danke schonmal
Jan
Mit Zitat antworten

  #2  
Alt 08.09.2013, 13:44
janos janos ist offline
Registered User
 
Registriert seit: 10.2010
Beiträge: 5
Habe das Problem jetzt so gelöst, das ich statt LDA LMTP verwende um die Mails von Postfix zu Dovecot zu bekommen. Funktioniert jetzt also.

Viele Grüße
Jan
Mit Zitat antworten
Antwort

Lesezeichen

Stichworte
delivered, dovecot, mail, postfix


Themen-Optionen
Thema bewerten
Thema bewerten:

Forumregeln
Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist aus.
HTML-Code ist aus.

Gehe zu

Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
E-Mails immer "raussenden" und nicht lokal zustellen stefkey Mail 2 02.09.2011 15:06
web.de mails werden von postfix "als nicht existent" gelistet... HxD Mail 1 29.10.2010 20:47
SpamAssassin "bearbeitet" nicht alle Mails... McStefan Mail 3 08.04.2007 17:12
Postfix: "Unkown User" trotz Eintrag in /etc/postfix/virtual Senekha Mail 0 04.09.2006 15:42
eMail Versand trotz "server_args = -Rt0 ...." langsam tom10 Mail 5 12.02.2006 12:12


Mails erscheinen trotz &quot;delivered to mailbox&quot; nicht
Mails erscheinen trotz &quot;delivered to mailbox&quot; nicht
Mails erscheinen trotz &quot;delivered to mailbox&quot; nicht Mails erscheinen trotz &quot;delivered to mailbox&quot; nicht
Powered by vBulletin® Version 3.8.11 (Deutsch)
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.