Server Support Forum


Zurück   Server Support Forum > >


Antwort
 
Themen-Optionen Thema bewerten
  #1  
Alt 02.09.2010, 11:33
dicke_nudel dicke_nudel ist offline
Registered User
 
Registriert seit: 04.2010
Beiträge: 13
Postfix Paketinstallation schlägt fehl

Hallo an alle,

ich habe Probleme bei der Installation von Postfix mit Aptitude. Seit 2 Tagen kämpfe ich nun mit diesem Fall und komme nicht dahinter woran es liegt.

Code:
 aptitude install postfix
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
The following NEW packages will be installed:
  postfix
The following packages will be REMOVED:
  xmail{a}
0 packages upgraded, 1 newly installed, 1 to remove and 38 not upgraded.
Need to get 0B/1301kB of archives. After unpacking 2429kB will be used.
Do you want to continue? [Y/n/?] y
Writing extended state information... Done
Preconfiguring packages ...
dpkg: xmail: dependency problems, but removing anyway as you request:
 bsd-mailx depends on exim4 | mail-transport-agent; however:
  Package exim4 is not installed.
  Package mail-transport-agent is not installed.
  Package postfix which provides mail-transport-agent is not installed.
  Package exim4-daemon-light which provides mail-transport-agent is not installed.
  Package xmail which provides mail-transport-agent is to be removed.
(Reading database ... 24319 files and directories currently installed.)
Removing xmail ...
Stopping XMail server: XMail.
Processing triggers for man-db ...
Selecting previously deselected package postfix.
(Reading database ... 24252 files and directories currently installed.)
Unpacking postfix (from .../postfix_2.5.5-1.1_amd64.deb) ...
Processing triggers for man-db ...
Setting up postfix (2.5.5-1.1) ...

Postfix configuration was not changed.  If you need to make changes, edit
/etc/postfix/main.cf (and others) as needed.  To view Postfix configuration
values, see postconf(1).

After modifying main.cf, be sure to run '/etc/init.d/postfix reload'.

Running newaliases
newaliases: fatal: file /etc/postfix/main.cf: parameter default_privs: unknown user name value: nobody
dpkg: error processing postfix (--configure):
 subprocess post-installation script returned error exit status 75
Errors were encountered while processing:
 postfix
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install.  Trying to recover:
Setting up postfix (2.5.5-1.1) ...

Postfix configuration was not changed.  If you need to make changes, edit
/etc/postfix/main.cf (and others) as needed.  To view Postfix configuration
values, see postconf(1).

After modifying main.cf, be sure to run '/etc/init.d/postfix reload'.

Running newaliases
newaliases: fatal: file /etc/postfix/main.cf: parameter default_privs: unknown user name value: nobody
dpkg: error processing postfix (--configure):
 subprocess post-installation script returned error exit status 75
Errors were encountered while processing:
 postfix
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
Writing extended state information... Done
Eigentlich kommt immer ein Installationsscript nach erfolgreicher Paketinstallation. Bei mir bricht die Installation leider ab.

Irgend eine Idee?

Viele Dank für eure Zeit

Gruß
Mit Zitat antworten

  #2  
Alt 02.09.2010, 12:21
Roger Wilco Roger Wilco ist offline
Registered User
 
Registriert seit: 11.2006
Beiträge: 3.462
Zitat:
Zitat von dicke_nudel Beitrag anzeigen
Code:
newaliases: fatal: file /etc/postfix/main.cf: parameter default_privs: unknown user name value: nobody
Was gibt `id nobody` bei dir aus? An deinem System ist einiges faul, wenn der Benutzer "nobody" nicht mehr existiert.
Mit Zitat antworten
  #3  
Alt 02.09.2010, 21:49
dicke_nudel dicke_nudel ist offline
Registered User
 
Registriert seit: 04.2010
Beiträge: 13
Code:
id: nobody: No such user
Habe jetzt einfach mal mein Apache user verwendet. Danach gings.
Mit Zitat antworten
  #4  
Alt 02.09.2010, 21:55
siradlib siradlib ist offline
Registered User
 
Registriert seit: 10.2006
Beiträge: 411
Zitat:
Zitat von dicke_nudel Beitrag anzeigen
Code:
id: nobody: No such user
Habe jetzt einfach mal mein Apache user verwendet. Danach gings.

"nobody" wird nicht einfach so von Postfix benutzt, sondern deswegen, weil er so wenige Rechte im System hat wie kein anderer User.
Durch das leichtfertige Benutzen des Apache-Users (der deutlich mehr Rechte als "nobody" hat!) hast Du Dir meiner Meinung nach ein unsicheres System gebaut. Selbst wenns funktioniert, würde ich das System so nicht benutzen!
Mit Zitat antworten
Antwort

Lesezeichen

Stichworte
mailserver, paketinstallation, postfix


Themen-Optionen
Thema bewerten
Thema bewerten:

Forumregeln
Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist aus.
HTML-Code ist aus.

Gehe zu

Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
Mailserver missbraucht? funkuch3n Mail 5 02.07.2010 14:13
Postfix mit Postgrey Error 451 4.3.5 Server configuration problem firemaster1985 Mail 3 26.05.2010 21:10
Postfix 554 5.7.1 firemaster1985 Mail 7 17.08.2009 14:38
numothersock problem durch postfix ? rota50 Virtuelle Server 7 13.05.2007 18:03
Postfix - Alle Mails landen beim gleichen User I_Maruko_I Mail 2 22.04.2007 13:51





Powered by vBulletin® Version 3.8.11 (Deutsch)
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.