Server Support Forum


Zurück   Server Support Forum > >


Antwort
 
Themen-Optionen Thema bewerten
  #1  
Alt 24.10.2017, 17:00
MonoLoco MonoLoco ist offline
Registered User
 
Registriert seit: 10.2017
Beiträge: 2
Frage Ubuntu Server 16.04 lässt sich nicht installieren: Logisches Laufwerk aufgelöst

Hallo zusammen,

ich verzweifle gerade an einer Ubuntu-Server-Installation auf einem HPE DL160 G9. Das System lässt sich nicht installieren. Das Szenario sieht so aus:

- Es ist eine einzige SSD als Systemplatte verbaut.
- Angeschlossen am OnBoard "Dynamic Smart Array B140i" (SATA Controller).
- Im Array-Konfigurator ist diese eine SSD einem logischen Laufwerk mit RAID 0 zugewiesen.
- Bootmodus ist UEFI und natürlich wird von diesem einen logischen Laufwerk gebootet.
- Eine Installation von Windows Server 2016 über USB-Stick funktioniert einwandfrei. Es können alle Treiber im Nachgang installiert werden, das OS ist rundum glücklich und die Maschine läuft tadellos.

Wenn ich nun auf dieser Maschine Ubuntu Server installieren möchte geschehen seltsame Dinge: Ich komme immer bis zur Partitionierung. Die SSD wird gefunden und das Setup soll das gesamte Laufwerk für die Einrichtung verwenden, dabei selbst die Anzahl der Partitionen und deren Größen wählen. Bei der Partitionierung gibt es keine (Fehler-)Meldungen. Der nächste Schritt wäre dann die Installation des Grundsystems. Hierbei erhalte ich direkt zu Beginn die Meldung (sinngemäß), dass die Installation fehlgeschlagen ist. Es wird effektiv nichts installiert. Gehe ich dann im Menü einen Schritt zurück zur Partitionierung, kann ich erkennen, dass die Partitionen angelegt wurden. Sieht also gut aus. Das Seltsame nun: Während dieser Prozedur zersemmelt die Installationsroutine die Konfiguration des Controllers. Wenn ich den Server neu starte, erhalte ich sofort Meldungen, ich solle doch mal das Array konfigurieren. Ein Blick in die Konfiguration zeigt, dass das logische Laufwerk verschwunden ist. Ich kann dieses nun wieder anlegen und das Spiel beginnt von vorn. Es macht übrigens keinen Unterschied, ob ich das logische Laufwerk anlege oder nicht. Starte ich die Installation ohne der logischen Zuordnung, kann Ubuntu das Laufwerk ebenfalls finden, partitionieren und den Controller umkonfigurieren, so dass dieser beim Neusart wieder meckert.

Da ich kein Linux-Veteran bin, stehe ich momentan doch ziemlich auf dem Schlauch. Da ich das System nicht aus Jux und Dollerei installiere, muss ich das Problem irgendwie lösen (lassen). Für Ideen wäre ich sehr dankbar.
Mit Zitat antworten

  #2  
Alt 24.10.2017, 17:07
marce marce ist offline
Registered User
 
Registriert seit: 10.2009
Ort: Dettenhausen
Alter: 43
Beiträge: 1.396
https://community.hpe.com/t5/ProLian...9/td-p/6919204

Google meint übrigens auch, daß ist ein SW-Raid-Controller und es gibt wohl andere Linuxe, die für das Ding zertifiziert sind und den Treiber enthalten.
Mit Zitat antworten
  #3  
Alt 25.10.2017, 01:41
Benutzerbild von mr_brain
mr_brain mr_brain ist offline
Registered User
 
Registriert seit: 08.2007
Beiträge: 1.507
mr_brain eine Nachricht über ICQ schicken mr_brain eine Nachricht über AIM schicken mr_brain eine Nachricht über MSN schicken mr_brain eine Nachricht über Yahoo! schicken
Wenn nur eine einzige physikalische HDD verbaut ist, warum konfiguriert man diese als RAID-0? Da wäre es doch zumindest sinnvoll diese als JBOD zu confen.
__________________
goto; // Welcome 2 Inter.Net
Administration, Colocation, DDoS Mitigation, Nameserver & virtuelle Server
Produkte: www.welcome2inter.net/products
Mit Zitat antworten
  #4  
Alt 25.10.2017, 07:50
marce marce ist offline
Registered User
 
Registriert seit: 10.2009
Ort: Dettenhausen
Alter: 43
Beiträge: 1.396
naja, diesbezüglich habe ich bei Raid-Controllern schon alles mögliche gesehen, wie die mit einzelnen HDs umgegangen sind...

Im Endeffekt ist das ja auch egal - solange die HD (oder das LUN) als Device sauber nach draußen durchgereicht wird.
Mit Zitat antworten
  #5  
Alt 25.10.2017, 16:15
MonoLoco MonoLoco ist offline
Registered User
 
Registriert seit: 10.2017
Beiträge: 2
Zitat:
Zitat von marce Beitrag anzeigen
https://community.hpe.com/t5/ProLian...9/td-p/6919204

Google meint übrigens auch, daß ist ein SW-Raid-Controller und es gibt wohl andere Linuxe, die für das Ding zertifiziert sind und den Treiber enthalten.
Danke für den Tipp. Da das Treiberproblem nicht gelöst werden kann, habe ich das nun auf AHCI umgestellt. Dadurch geht mir zwar die Funktionalität des Controllers flöten, das System lässt sich jetzt aber erst einmal problemlos installieren.
Mit Zitat antworten
  #6  
Alt 25.10.2017, 17:25
Benutzerbild von danton
danton danton ist offline
Registered User
 
Registriert seit: 04.2009
Ort: Ennigerloh
Alter: 44
Beiträge: 2.492
Zitat:
Zitat von MonoLoco Beitrag anzeigen
Dadurch geht mir zwar die Funktionalität des Controllers flöten, das System lässt sich jetzt aber erst einmal problemlos installieren.
Nein, eigentlich nicht. Da es sich um ein Software-RAID (gerne auch mal FakeRAID genannt) handelt, wird die RAID-Verwaltung von der Host-CPU und (im Falle von Windows) vom Treiber übernommen. Der Linux-Kernel bringt aber ausgereifte Software-RAID Funktionalitäten mit, die stabil, ausgiebig getestet und hardwareunabhängig sind.
__________________
Event-List - PHP/MySQL-Veranstaltungskalender für die eigene Homepage
Mit Zitat antworten
Antwort

Lesezeichen


Themen-Optionen
Thema bewerten
Thema bewerten:

Forumregeln
Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist aus.
HTML-Code ist aus.

Gehe zu

Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
Prozessorlast 1und1 Root Server campmilan Dedizierte Server 11 12.03.2010 12:16
[HowTo] PHP5 installieren server4downs FAQs & Anleitungen 214 19.01.2010 20:13
Confixx 3.x Apache Reload Problem oliver-siewert Confixx 0 30.07.2007 01:27
VirtualHost wurmi Virtuelle Server 7 01.10.2003 23:20





Powered by vBulletin® Version 3.8.11 (Deutsch)
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.