Server Support Forum
IPv6 forwarding funktioniert nicht

Zurück   Server Support Forum > >


Antwort
 
Themen-Optionen Thema bewerten
  #1  
Alt 07.09.2017, 19:44
Benutzerbild von Vengance
Vengance Vengance ist offline
Registered User
 
Registriert seit: 04.2016
Beiträge: 65
IPv6 forwarding funktioniert nicht

Hallo,

Ich habe eine VM die auch über IPv6 nach außen kommunizieren soll.

Da es dabei aber zu Problemen kommt, habe ich auf dem Hostsystem den Traffic mittels tcdump angesehen, während ich in der VM Google angepingt habe.

Dabei wurde folgende Ausgabe geliefert:
Code:
tcpdump -i vmbr0 -vv ip6 

13:03:33.445124 IP6 (flowlabel 0x714fe, hlim 64, next-header ICMPv6 (58) payload length: 64) 2001:xxxx:1:b813:03:33.445124 IP6 (flowlabel 0x714fe, hlim 64, next-header ICMPv6 (58) payload length: 64) 2001:xxxx:1:b8

13:03:33.445124 IP6 (flowlabel 0x714fe, hlim 64, next-header ICMPv6 (58) 
payload length: 64) 2001:xxxx:1:b80c::6 > par10s21-in-x0e.1e100.net: 
[icmp6 sum ok] ICMP6, echo request, seq 497
13:03:33.445147 IP6 (flowlabel 0x714fe, hlim 63, next-header ICMPv6 (58) 
payload length: 64) 2001:xxxx:1:b80c::6 > par10s21-in-x0e.1e100.net: 
[icmp6 sum ok] ICMP6, echo request, seq 497
13:03:34.473103 IP6 (flowlabel 0x714fe, hlim 64, next-header ICMPv6 (58) 
payload length: 64) 2001:xxxx:1:b80c::6 > par10s21-in-x0e.1e100.net: 
[icmp6 sum ok] ICMP6, echo request, seq 498
13:03:34.473113 IP6 (flowlabel 0x714fe, hlim 63, next-header ICMPv6 (58) 
payload length: 64) 2001:xxxx:1:b80c::6 > par10s21-in-x0e.1e100.net: 
[icmp6 sum ok] ICMP6, echo request, seq 498
13:03:34.647102 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 
32) fe80::2ff:ffff:feff:fffd > ff02::1:ff00:6: [icmp6 sum ok] ICMP6, 
neighbor solicitation, length 32, who has 2001:xxxx:1:b80c::6
13:03:34.647172 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 
32) 2001:xxxx:1:b80c::6 > fe80::2ff:ffff:feff:fffd: [icmp6 sum ok] 
ICMP6, neighbor advertisement, length 32, tgt is 2001:xxxx:1:b80c::6, 
Flags [solicited, override]
13:03:35.493132 IP6 (flowlabel 0x714fe, hlim 64, next-header ICMPv6 (58) 
payload length: 64) 2001:xxxx:1:b80c::6 > par10s21-in-x0e.1e100.net: 
[icmp6 sum ok] ICMP6, echo request, seq 499
13:03:35.493149 IP6 (flowlabel 0x714fe, hlim 63, next-header ICMPv6 (58) 
payload length: 64) 2001:xxxx:1:b80c::6 > par10s21-in-x0e.1e100.net: 
[icmp6 sum ok] ICMP6, echo request, seq 499
13:03:36.517138 IP6 (flowlabel 0x714fe, hlim 64, next-header ICMPv6 (58) 
payload length: 64) 2001:xxxx:1:b80c::6 > par10s21-in-x0e.1e100.net: 
[icmp6 sum ok] ICMP6, echo request, seq 500
13:03:36.517163 IP6 (flowlabel 0x714fe, hlim 63, next-header ICMPv6 (58) 
payload length: 64) 2001:xxxx:1:b80c::6 > par10s21-in-x0e.1e100.net: 
[icmp6 sum ok] ICMP6, echo request, seq 500
13:03:37.541115 IP6 (flowlabel 0x714fe, hlim 64, next-header ICMPv6 (58) 
payload length: 64) 2001:xxxx:1:b80c::6 > par10s21-in-x0e.1e100.net: 
[icmp6 sum ok] ICMP6, echo request, seq 501
Die Requests werden scheinbar richtig über das Hostsystem weitergeleitet, nur scheinbar nicht wieder "zurück" in die VM.
IPv6 Forwarding ist aktiviert, siehe sysctl Ausgabe.

Hat jemand eine Idee woran es liegen kann?


Code:
sysctl -p
net.ipv4.ip_forward = 1
net.ipv6.conf.all.forwarding = 1
net.ipv6.conf.all.autoconf = 0
net.ipv6.conf.default.autoconf = 0
net.ipv6.conf.vmbr0.autoconf = 0
net.ipv6.conf.all.accept_ra = 0
net.ipv6.conf.default.accept_ra = 0
net.ipv6.conf.vmbr0.accept_ra = 0
net.ipv6.conf.vmbr0.accept_ra = 0
net.ipv6.conf.vmbr0.autoconf = 0
net.ipv6.conf.default.proxy_ndp = 1
net.ipv6.conf.all.proxy_ndp = 1
net.ipv6.conf.default.forwarding = 1
net.ipv6.conf.all.forwarding = 1
net.ipv6.conf.all.accept_ra_defrtr = 0
net.ipv6.conf.default.accept_ra_defrtr = 0
net.ipv6.conf.vmbr0.accept_ra_defrtr = 0
net.ipv6.conf.all.accept_ra_pinfo = 0
net.ipv6.conf.default.accept_ra_pinfo = 0
net.ipv6.conf.vmbr0.accept_ra_pinfo = 0
Mit Zitat antworten

Antwort

Lesezeichen


Themen-Optionen
Thema bewerten
Thema bewerten:

Forumregeln
Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist aus.
HTML-Code ist aus.

Gehe zu

Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
IPv6 Proxmox (OVH) funktioniert nur teilweise Vengance Dedizierte Server 6 12.08.2017 00:26
IPv6-Adresse aus /64-Netz in Virtueller Maschine nutzen Jimsem Dedizierte Server 7 23.07.2016 14:13
Root-Server Restposten ab 23,90 € / M - 92,00 € / M IP-Projects.de Biete 0 02.12.2012 09:42
Going to sleep 2bit-gehirn Virtuelle Server 7 02.04.2009 18:53
Apache2 CPU Last 100% huppsi Webserver 12 01.08.2008 11:41


IPv6 forwarding funktioniert nicht
IPv6 forwarding funktioniert nicht
IPv6 forwarding funktioniert nicht IPv6 forwarding funktioniert nicht
Powered by vBulletin® Version 3.8.11 (Deutsch)
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.