Server Support Forum


Zurück   Server Support Forum > >


Antwort
 
Themen-Optionen Thema bewerten
  #1  
Alt 19.06.2017, 03:49
crysis992 crysis992 ist offline
Registered User
 
Registriert seit: 06.2017
Beiträge: 4
dist-upgrade ging schief - unerfüllte Abhängigkeiten

Hallo,

Hoffe dies ist der richtige Bereich um das zu posten.

Ich habe heute ein dist-upgrade zu jessie zu stretch (Debian) durchführen wollen, leider ist es bei der hälfte abgebrochen und gibt mir nun folgende Fehlermeldungen:

Code:
root@knickscraft:~# apt-get dist-upgrade
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
Probieren Sie »apt --fix-broken install«, um dies zu korrigieren.
Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 python3 : Hängt ab von: python3-minimal (= 3.4.2-2) aber 3.5.3-1 ist installiert
 python3-apt : Hängt ab von: python3 (>= 3.5~) aber 3.4.2-2 ist installiert
 python3-dbus : Hängt ab von: python3 (>= 3.5~) aber 3.4.2-2 ist installiert
                Hängt ab von: libdbus-1-3 (>= 1.9.14) aber 1.8.22-0+deb8u1 ist installiert
 python3-gi : Hängt ab von: python3 (>= 3.5~) aber 3.4.2-2 ist installiert
E: Unerfüllte Abhängigkeiten. Versuchen Sie »apt --fix-broken install« ohne Angabe eines Pakets
Bei "apt --fix-broken install" gibt es folgende Fehlermeldung:
Code:
root@knickscraft:~# apt --fix-broken install
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
Abhängigkeiten werden korrigiert ... Fertig
Die folgenden Pakete wurden automatisch installiert und werden nicht mehr benötigt:
  libarchive-extract-perl libasprintf0c2 libboost-iostreams1.55.0 libcpan-meta-perl libdata-section-perl libenca0 liblog-message-perl liblog-message-simple-perl libmodplug1 libmodule-build-perl libmodule-pluggable-perl
  libmodule-signature-perl libpackage-constants-perl libperl4-corelibs-perl libpgm-5.1-0 libpod-latex-perl libpod-readme-perl libregexp-common-perl libsoftware-license-perl libtask-weaken-perl libterm-ui-perl libtext-soundex-perl
  libtext-template-perl libuuid-perl libx265-87 libzmq3 python-gdbm python-support
Verwenden Sie »apt autoremove«, um sie zu entfernen.
The following additional packages will be installed:
  dbus libapparmor1 libdbus-1-3 libpython3-stdlib python3
Vorgeschlagene Pakete:
  default-dbus-session-bus | dbus-session-bus python3-doc python3-tk python3-venv
Die folgenden NEUEN Pakete werden installiert:
  libapparmor1
Die folgenden Pakete werden aktualisiert (Upgrade):
  dbus libdbus-1-3 libpython3-stdlib python3
4 aktualisiert, 1 neu installiert, 0 zu entfernen und 167 nicht aktualisiert.
6 nicht vollständig installiert oder entfernt.
Es müssen 519 kB an Archiven heruntergeladen werden.
Nach dieser Operation werden 97,3 kB Plattenplatz freigegeben.
Möchten Sie fortfahren? [J/n] y
Holen:1 http://ftp.de.debian.org/debian stretch/main amd64 python3 amd64 3.5.3-1 [21,6 kB]
Holen:2 http://ftp.de.debian.org/debian stretch/main amd64 libpython3-stdlib amd64 3.5.3-1 [18,6 kB]
Holen:3 http://ftp.de.debian.org/debian stretch/main amd64 libapparmor1 amd64 2.11.0-3 [78,7 kB]
Holen:4 http://ftp.de.debian.org/debian stretch/main amd64 dbus amd64 1.10.18-1 [208 kB]
Holen:5 http://ftp.de.debian.org/debian stretch/main amd64 libdbus-1-3 amd64 1.10.18-1 [192 kB]
Es wurden 519 kB in 0 s geholt (3.926 kB/s).
python3.5-minimal (3.5.3-1) wird eingerichtet ...
Traceback (most recent call last):
  File "/usr/lib/python3.5/py_compile.py", line 6, in <module>
    import importlib._bootstrap_external
  File "/usr/lib/python3.5/importlib/__init__.py", line 57, in <module>
    import types
  File "/usr/lib/python3.5/types.py", line 166, in <module>
    import functools as _functools
  File "/usr/lib/python3.5/functools.py", line 23, in <module>
    from weakref import WeakKeyDictionary
  File "/usr/lib/python3.5/weakref.py", line 12, in <module>
    from _weakref import (
ImportError: cannot import name '_remove_dead_weakref'
dpkg: Fehler beim Bearbeiten des Paketes python3.5-minimal (--configure):
 Unterprozess installiertes post-installation-Skript gab den Fehlerwert 1 zurück
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von python3-minimal:
 python3-minimal hängt ab von python3.5-minimal (>= 3.5.3-1~); aber:
  Paket python3.5-minimal ist noch nicht konfiguriert.

dpkg: Fehler beim Bearbeiten des Paketes python3-minimal (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
Fehler traten auf beim Bearbeiten von:
 python3.5-minimal
 python3-minimal
E: Sub-process /usr/bin/dpkg returned an error code (1)
Hoffe es kann mir jemand bei diesem Problem helfen. Eine Schritt für Schritt Anleitung währe hilfreich, da ich mich selbst nicht als Profi in diesem Bereich sehe.

,
crysis992
Mit Zitat antworten

  #2  
Alt 19.06.2017, 08:16
Werner S Werner S ist offline
Registered User
 
Registriert seit: 04.2017
Beiträge: 124
Zitat:
E: Unerfüllte Abhängigkeiten. Versuchen Sie »apt --fix-broken install« ohne Angabe eines Pakets
Probiere es mal mit aptitude dist-upgrade
aptitude installiert die fehlenden Abhängigkeiten gleich mit
Mit Zitat antworten
  #3  
Alt 19.06.2017, 14:14
crysis992 crysis992 ist offline
Registered User
 
Registriert seit: 06.2017
Beiträge: 4
Zitat:
Zitat von Werner S Beitrag anzeigen
Probiere es mal mit aptitude dist-upgrade
aptitude installiert die fehlenden Abhängigkeiten gleich mit
Das hat sich leider mit dem dist-upgrade auch verabschiedet
Code:
root@knickscraft:~# aptitude dist-upgrade
-su: aptitude: Kommando nicht gefunden.
Lässt sich auch nicht mehr via apt-get installieren:
Code:
root@knickscraft:~# apt-get install  aptitude
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
Probieren Sie »apt --fix-broken install«, um dies zu korrigieren.
Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 aptitude : Hängt ab von: aptitude-common (= 0.8.7-1) aber 0.6.11-1 soll installiert werden
            Hängt ab von: libboost-filesystem1.62.0 soll aber nicht installiert werden
            Hängt ab von: libboost-iostreams1.62.0 soll aber nicht installiert werden
            Hängt ab von: libboost-system1.62.0 soll aber nicht installiert werden
            Hängt ab von: libcwidget3v5 soll aber nicht installiert werden
            Hängt ab von: libsigc++-2.0-0v5 (>= 2.8.0) soll aber nicht installiert werden
            Hängt ab von: libxapian30 soll aber nicht installiert werden
            Empfiehlt: libparse-debianchangelog-perl soll aber nicht installiert werden
 python3 : Hängt ab von: python3-minimal (= 3.4.2-2) aber 3.5.3-1 soll installiert werden
 python3-apt : Hängt ab von: python3 (>= 3.5~) aber 3.4.2-2 soll installiert werden
 python3-dbus : Hängt ab von: python3 (>= 3.5~) aber 3.4.2-2 soll installiert werden
                Hängt ab von: libdbus-1-3 (>= 1.9.14) aber 1.8.22-0+deb8u1 soll installiert werden
 python3-gi : Hängt ab von: python3 (>= 3.5~) aber 3.4.2-2 soll installiert werden
E: Unerfüllte Abhängigkeiten. Versuchen Sie »apt --fix-broken install« ohne Angabe eines Pakets (oder geben Sie eine Lösung an).
Mit Zitat antworten
  #4  
Alt 19.06.2017, 14:40
marce marce ist gerade online
Registered User
 
Registriert seit: 10.2009
Ort: Dettenhausen
Alter: 43
Beiträge: 1.395
Darf man fragen, wie Du denn den Weg des Dist-Upgrades gehen wolltest? Welche Vorbereitungen hast Du getroffen? ...

"eigentlich" sind DistUpgrades unter Debian mehr oder weniger idiotensicher, wenn man sich an die HowTos und Hinweise von Debian hält...
Mit Zitat antworten
  #5  
Alt 19.06.2017, 15:45
crysis992 crysis992 ist offline
Registered User
 
Registriert seit: 06.2017
Beiträge: 4
Zitat:
Zitat von marce Beitrag anzeigen
Darf man fragen, wie Du denn den Weg des Dist-Upgrades gehen wolltest? Welche Vorbereitungen hast Du getroffen? ...

"eigentlich" sind DistUpgrades unter Debian mehr oder weniger idiotensicher, wenn man sich an die HowTos und Hinweise von Debian hält...
Genauso, wie ich damals das Upgrade von Debian 7 auf 8 durchgeführt habe:
->backports in der sources.list auskommentiert
-> apt-get update
-> apt-get upgrade
-> apt-get dis-upgrade
-> Und dann kam halt der gezeigte Fehler
Mit Zitat antworten
  #6  
Alt 19.06.2017, 17:11
Orebor Orebor ist offline
Registered User
 
Registriert seit: 12.2014
Ort: Der Süden Deutschlands
Beiträge: 428
Du schreibst es wurde unterbrochen, wodurch?
Falls es die SSH-Session war, kann ich für die Zukunft nur empfehlen, dass man solche Dinge in screen oder tmux laufen lässt.

Ansonsten würde ich persönlich jetzt das Backup rauskramen, statt ewig an diesem System zu basteln, weil da manchmal nach längerer Zeit noch gerne irgendwo Probleme aufschlagen, die durch das botched Update zu Stande kamen.
Mit Zitat antworten
  #7  
Alt 20.06.2017, 07:39
Werner S Werner S ist offline
Registered User
 
Registriert seit: 04.2017
Beiträge: 124
Zitat:
Zitat von crysis992 Beitrag anzeigen
Das hat sich leider mit dem dist-upgrade auch verabschiedet
Code:
root@knickscraft:~# aptitude dist-upgrade
-su: aptitude: Kommando nicht gefunden.
Bist du dir sicher das du für einen Server das Wissen hast?

aptitude ist einfach nur nicht installier...
Mit Zitat antworten
  #8  
Alt 20.06.2017, 08:43
Benutzerbild von nexus
nexus nexus ist offline
Registered User
 
Registriert seit: 06.2011
Beiträge: 1.460
Crossposting:
https://debianforum.de/forum/viewtop...f=12&p=1135625
http://www.snaptrophies.com/dist-upg...abhangigkeiten

Wie sieht eigentlich deine aktuelle /etc/apt/sources.list aus? Liegen im Unterordner /etc/apt/sources.list.d/ weitere Konfigurationsdateien?
__________________
Ist ein Server das Richtige für mich? -> Entscheidungshilfe und Erste Schritte
Lesenswert für alle Mailserver-Admins -> Best Practice für stressfreie Mailserver
Server- und Hostinganbieter, die ich empfehlen kann -> PHP-Friends, IP-Projects, Keyweb, Netcup
Hier gibt es alle Infos zu Schulferien (Insider wissen, was ich meine ) -> schulferien.org
Mit Zitat antworten
Antwort

Lesezeichen

Stichworte
dist-upgrade


Themen-Optionen
Thema bewerten
Thema bewerten:

Forumregeln
Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist aus.
HTML-Code ist aus.

Gehe zu

Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
Plesk 11.0.9 500 - Internal Server Error jrwn Plesk 14 08.07.2016 10:20
apt-get upgrade -> unerfüllte Abhängigkeiten TAiS46 Dedizierte Server 8 19.04.2012 11:27
S4U plesk 9.01 Lizenz ? ROD Plesk 2 13.03.2009 01:45
Plesk Update 8.1.1 >> 8.2 Loxter Plesk 115 21.09.2007 21:07





Powered by vBulletin® Version 3.8.11 (Deutsch)
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.