Server Support Forum
Ioncube auf php 5.5.30 instalieren

Zurück   Server Support Forum > >


Antwort
 
Themen-Optionen Thema bewerten
  #1  
Alt 18.02.2016, 17:47
BigBen BigBen ist offline
Registered User
 
Registriert seit: 03.2007
Beiträge: 33
Ioncube auf php 5.5.30 instalieren

Hallo

ich habe schon hier in Forum gesucht aber nichts gefunden.

Meine Frage hat jemand eine Installation Anleitung?


Ich habe debian 7 und PHP 5.5.30.

PHP 5.5.30-1~dotdeb+7.1 (cli) (built: Oct 1 2015 17:38:39)
Copyright (c) 1997-2015 The PHP Group
Zend Engine v2.5.0, Copyright (c) 1998-2015 Zend Technologies
with Zend OPcache v7.0.6-dev, Copyright (c) 1999-2015, by Zend Technologies


Also ich habe zwar eine Anleitung gefunden und auch das befolgt ohne Erfolg habe immer noch diese Fehler Meldung.

Warning: realpath(): open_basedir restriction in effect. File(/usr/lib/php5/20121212) is not within the allowed path(s): (/var/www/virtual/xxxxxxxxxx.com/:/usr/share/php/) in /var/www/virtual/xxxxxxxxxx.com/htdocs/include/dbconst.php on line 16

Warning: file_exists(): open_basedir restriction in effect. File(/var/www/ioncube/ioncube_loader_lin_5.5.so) is not within the allowed path(s): (/var/www/virtual/xxxxxxxxxx.com/:/usr/share/php/) in /var/www/virtual/xxxxxxxxxx.com/htdocs/include/dbconst.php on line 16

Bitte um dringende Hilfe vielen Dank im voraus für Eure Antworten.

Gruß

Geändert von BigBen (18.02.2016 um 17:48 Uhr) Grund: verschrieben
Mit Zitat antworten

  #2  
Alt 18.02.2016, 18:29
Benutzerbild von d4f
d4f d4f ist offline
Support Guru
 
Registriert seit: 04.2007
Ort: /dev/urandom
Beiträge: 4.323
d4f eine Nachricht über ICQ schicken d4f eine Nachricht über MSN schicken
Die Fehlermeldung besagt dass open_basedir limitiert wo die Extension-Dateien liegen dürfen. Ich würde empfehlen es in den gleichen Ordner wie die anderen PHP-Erweiterungen des Systems zu legen, unterhalb /usr/share/php.
__________________
Einige Beiträge sind auf meinem Smartphone verfasst. Bitte Tippfehler und Abkürzungen entschuldigen!
Bitte keine ICQ/MSN/Skype Kontaktaufnahmen ohne vorherige persoenliche Absprache.
Mit Zitat antworten
  #3  
Alt 18.02.2016, 19:01
BigBen BigBen ist offline
Registered User
 
Registriert seit: 03.2007
Beiträge: 33
Zitat:
Zitat von d4f Beitrag anzeigen
Die Fehlermeldung besagt dass open_basedir limitiert wo die Extension-Dateien liegen dürfen. Ich würde empfehlen es in den gleichen Ordner wie die anderen PHP-Erweiterungen des Systems zu legen, unterhalb /usr/share/php.
Hi


danke für deine Antwort habe es /usr/share/php/ioncube

installiert und in php.ini das eingefügt

zend_extension = /usr/share/php/ioncube/ioncube_loader_lin_5.5.so

und in /etc/php5/conf.d in ioncube.ini
steht auch das hier
zend_extension = /usr/share/php/ioncube/ioncube_loader_lin_5.5.so

habe überall vo ioncube ordner war gelöscht aber andem fehler ändert sich garnicht.


Gruß
Mit Zitat antworten
  #4  
Alt 18.02.2016, 19:04
BigBen BigBen ist offline
Registered User
 
Registriert seit: 03.2007
Beiträge: 33
Warning: realpath(): open_basedir restriction in effect. File(/usr/lib/php5/20121212) is not within the allowed path(s): (/var/www/virtual/xxxxxxx.com/:/usr/share/php/) in /var/www/virtual/xxxxxxx.com/htdocs/include/dbconst.php on line 16

Warning: file_exists(): open_basedir restriction in effect. File(/var/www/virtual/ioncube/ioncube_loader_lin_5.5.so) is not within the allowed path(s): (/var/www/virtual/xxxxxxx.com/:/usr/share/php/) in /var/www/virtual/xxxxxxx.com/htdocs/include/dbconst.php on line 16

Warning: file_exists(): open_basedir restriction in effect. File(/var/www/ioncube/ioncube_loader_lin_5.5.so) is not within the allowed path(s): (/var/www/virtual/xxxxxxx.com/:/usr/share/php/) in /var/www/virtual/xxxxxxx.com/htdocs/include/dbconst.php on line 16

Warning: file_exists(): open_basedir restriction in effect. File(/var/ioncube/ioncube_loader_lin_5.5.so) is not within the allowed path(s): (/var/www/virtual/xxxxxxx.com/:/usr/share/php/) in /var/www/virtual/xxxxxxx.com/htdocs/include/dbconst.php on line 16
Mit Zitat antworten
  #5  
Alt 18.02.2016, 20:13
remote_mind remote_mind ist offline
Registered User
 
Registriert seit: 01.2012
Beiträge: 298
remote_mind eine Nachricht über ICQ schicken Ioncube auf php 5.5.30 instalieren
Zitat:
Zitat von BigBen Beitrag anzeigen
Warning: file_exists(): open_basedir restriction in effect. File(/var/ioncube/ioncube_loader_lin_5.5.so) is not within the allowed path(s): (/var/www/virtual/xxxxxxx.com/:/usr/share/php/) in /var/www/virtual/xxxxxxx.com/htdocs/include/dbconst.php on line 16
Was steht denn in dbconst.php in Zeile 16?

Davon abgesehen, nutzt du den opcache? In dem Fall ist nämlich die Reihenfolge relevant, erst ioncube und dann opcache.
__________________
remote_minds IT - Nils Jürgens || Emsstraße 34 || 48431 Rheine
Email: nj@remoteminds.it || Tel: 05971 9600760 || Fax: 05971 9600759
USt-IdNr.: DE279523599
Mit Zitat antworten
  #6  
Alt 18.02.2016, 20:20
BigBen BigBen ist offline
Registered User
 
Registriert seit: 03.2007
Beiträge: 33
Zitat:
Zitat von remote_mind Beitrag anzeigen
Was steht denn in dbconst.php in Zeile 16?

Davon abgesehen, nutzt du den opcache? In dem Fall ist nämlich die Reihenfolge relevant, erst ioncube und dann opcache.
Da steht


if(!extension_loaded('ionCube Loader')){$__oc=strtolower(substr(php_uname(),0,3) );$__ln='ioncube_loader_'.$__oc.'_'.substr(phpvers ion(),0,3).(($__oc=='win')?'.dll':'.so');if(functi on_exists('dl')){@dl($__ln);}if(function_exists('_ il_exec')){return _il_exec();}$__ln='/ioncube/'.$__ln;$__oid=$__id=realpath(ini_get('extension_d ir'));$__here=dirname(__FILE__);if(strlen($__id)>1 &&$__id[1]==':'){$__id=str_replace('\\','/',substr($__id,2));$__here=str_replace('\\','/',substr($__here,2));}$__rd=str_repeat('/..',substr_count($__id,'/')).$__here.'/';$__i=strlen($__rd);while($__i--){if($__rd[$__i]=='/'){$__lp=substr($__rd,0,$__i).$__ln;if(file_exists ($__oid.$__lp)){$__ln=$__lp;break;}}}if(function_e xists('dl')){@dl($__ln);}}else{die('The file '.__FILE__." is corrupted.\n");}if(function_exists('_il_exec')){re turn _il_exec();}echo('<font face=verdana size=1>This file cannot be loaded correctly [v7]. Please contact <a href=\'mailto:salman@kaonmail.com?Subject=Cannot load i-file on php:'.phpversion().'\'>support</a> for further assistance. Err:ILoad</font>');exit(199);
?>

Keine ahnung ob ich opcache wo kann ich das sehen?

Gruß
Mit Zitat antworten
  #7  
Alt 19.02.2016, 08:19
Benutzerbild von d4f
d4f d4f ist offline
Support Guru
 
Registriert seit: 04.2007
Ort: /dev/urandom
Beiträge: 4.323
d4f eine Nachricht über ICQ schicken d4f eine Nachricht über MSN schicken
Sagt phpinfo denn dass Ioncube überhaupt geladen ist nachdem du die php.ini angepasst hast?
__________________
Einige Beiträge sind auf meinem Smartphone verfasst. Bitte Tippfehler und Abkürzungen entschuldigen!
Bitte keine ICQ/MSN/Skype Kontaktaufnahmen ohne vorherige persoenliche Absprache.
Mit Zitat antworten
Antwort

Lesezeichen

Stichworte
ioncube, php 5.5.30


Themen-Optionen
Thema bewerten
Thema bewerten:

Forumregeln
Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist aus.
HTML-Code ist aus.

Gehe zu

Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
Plesk 12.0.18 - Ubuntu 14.04.3 - Plesk Update Fehler catwiesel Plesk 9 13.09.2015 17:18
Upload failed: Server returned HTTP-Status #500 eichenkranz Virtuelle Server 25 12.04.2013 16:12
500 Internal Server Error Ephram Plesk 2 11.05.2010 08:34
Log file, was ist falsch konfiguriert? flug Webserver 8 27.11.2007 15:29


Ioncube auf php 5.5.30 instalieren
Ioncube auf php 5.5.30 instalieren
Ioncube auf php 5.5.30 instalieren Ioncube auf php 5.5.30 instalieren
Powered by vBulletin® Version 3.8.11 (Deutsch)
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.