Server Support Forum
Problem mit jails/syslog

Zurück   Server Support Forum > >


Antwort
 
Themen-Optionen Thema bewerten
  #1  
Alt 22.08.2013, 10:58
homeserver homeserver ist offline
Registered User
 
Registriert seit: 11.2011
Beiträge: 62
Problem mit jails/syslog

Hallo alle zusammen, ich habe da ein kleines Problemchen^^

Und zwar erstelle ich mir gerade ein freeBSD-System (mit Hilfe des Buches von Ben ;-)).

Ich habe nun mehrere Jails eingerichtet und habe in einer Jail einen Webserver und PHP konfiguriert.
Wenn ich PHP nun aber in der jail starten möchte, bekomme ich folgende Fehlermeldung:
Code:
ERROR: unable to bind listening socket for address 'XX.XX.XX.XX:PPPP': Address already in use (48)
(die X für eine IP, die Ps für den Port)

Ergo scheint noch ein anderer Dienst auf der IP zu lauschen, also mit netstat geschaut und folgenden Eintrag:
Code:
udp4       0      0 XX.XX.XX.XX.syslog        *.*
Demnach lauscht der "globale" Syslog vom Hostsystem weiterhin auch auf der IP Adresse und hat sich an die jail gebunden, richtig?

Das hatte ich eigentlich mit folgendem Wert in der rc.conf des Hostsystems unterbunden:
Code:
syslogd_flags="-ss -a 127.0.0.1 -C"
bzw.
Code:
syslogd_flags="-ss"
oder?

Was habe ich falsch gemacht, sieht jemand vielleicht etwas?^^

Vielen Dank!

Geändert von homeserver (22.08.2013 um 11:06 Uhr)
Mit Zitat antworten

  #2  
Alt 22.08.2013, 13:18
Benutzerbild von Ben.
Ben. Ben. ist offline
Registered User
 
Registriert seit: 09.2008
Ort: Schweiz
Beiträge: 2.427
Welchen Port hast du für den FastCGI-Prozess gewählt?

Syslog krallt sich alle IP-Adressen, aber nicht alle Ports (hast du syslogd neugestartet nach der Änderung?).
Mit Zitat antworten
  #3  
Alt 22.08.2013, 13:33
Benutzerbild von Joe User
Joe User Joe User ist offline
Registered User
 
Registriert seit: 11.2008
Ort: Hamburg
Alter: 39
Beiträge: 3.823
Nur mal so zum Verständnis für FreeBSD-Newbies wie mich:
Wieso kann sich der auf dem Host laufende syslogd überhaupt an einen Netzwerk-Socket innerhalb des Jail binden?
__________________
PayPal.Me/JoeUserWings for LifeWings for Life World Run
RootForum CommunityRootForum FacebookRootForum TwitterFreeBSD Remote Installation

„If there’s more than one possible outcome of a job or task, and one of those outcomes will result in disaster or an undesirable consequence, then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.
Mit Zitat antworten
  #4  
Alt 22.08.2013, 13:34
Benutzerbild von Ben.
Ben. Ben. ist offline
Registered User
 
Registriert seit: 09.2008
Ort: Schweiz
Beiträge: 2.427
Der sich in der Jail befindliche syslogd bindet sich an an die lokale IP. Sonst nix.
Mit Zitat antworten
  #5  
Alt 22.08.2013, 13:40
homeserver homeserver ist offline
Registered User
 
Registriert seit: 11.2011
Beiträge: 62
Ja, ich hab sogar den ganzen Server nach der Änderung einfach mal rebootet, hat aber nichts gebracht.

Die Konfigurationsdatei, die an die php-fpm.conf angefügt wird lässt auf port 9000 horchen.
In der /usr/local/etc/php-fpm.conf habe ich den Wert bei listen auf dem default, also 127.0.0.1:9000 gelassen.

Gruß
Mit Zitat antworten
  #6  
Alt 22.08.2013, 13:41
Benutzerbild von Ben.
Ben. Ben. ist offline
Registered User
 
Registriert seit: 09.2008
Ort: Schweiz
Beiträge: 2.427
Falls es möglich und dir recht ist, darfst du mir mal eine Email schicken mit den Zugangsdaten und Angaben zur Jail. Dann schaue ich mir das schnell an.
Mit Zitat antworten
  #7  
Alt 22.08.2013, 14:13
Benutzerbild von Ben.
Ben. Ben. ist offline
Registered User
 
Registriert seit: 09.2008
Ort: Schweiz
Beiträge: 2.427
Zwei Punkte, aber nur einer ist relevant:

1. Du hast die syslogd-Flags nur auf dem Host gesetzt, nicht aber in der Jail. In der Jail ist das eigentlich egal bzw. hat nichts mit deinem Problem zu tun.

2. Du hast in der php-fpm.conf einen Standardpool definiert "[WWW]". Den habe ich jetzt deaktiviert. Dieser war bereits auf Port 9000 eingestellt. Dein "Custom-Pool" verwendete den gleichen Port => PHP-FPM startet den WWW-Pool, der nimmt sich die 9000, dann kommt deiner, der will auch die 9000 *bumm*

Ich habe nur deine php-fpm.conf in der Form abgeändert, dass ich die Parameter für den WWW-Pool deaktiviert habe. Jetzt läuft PHP.
Mit Zitat antworten
  #8  
Alt 22.08.2013, 16:01
homeserver homeserver ist offline
Registered User
 
Registriert seit: 11.2011
Beiträge: 62
Herzlichen Dank für deine schnelle Hilfe!

Dann kann ich mich die nächsten Tage weiter in dein literarisches Werk vertiefen ;-)))

Gruß
Mit Zitat antworten
  #9  
Alt 22.08.2013, 16:03
Benutzerbild von Ben.
Ben. Ben. ist offline
Registered User
 
Registriert seit: 09.2008
Ort: Schweiz
Beiträge: 2.427
Mach das. Ich verrate dir aber nicht wie es ausgeht.

Falls du Fragen / Probleme hast, darfst du sie mir gerne stellen.
Mit Zitat antworten
Antwort

Lesezeichen


Themen-Optionen
Thema bewerten
Thema bewerten:

Forumregeln
Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist aus.
HTML-Code ist aus.

Gehe zu

Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
Jemand Interesse an FreeBSD Jails? minimike Privatmarktplatz 2 07.06.2011 11:36
pub ip routing / Debian Host, Freebsd Guest, Jails masei Virtualisierung 3 03.03.2011 23:44
Jemand Interesse an OpenSolaris Zones oder FreeBSD Jails minimike Privatmarktplatz 2 05.07.2010 18:36
syslog-ng und iptables Problem feiaweng Linux 0 03.06.2009 16:38
/var/log/syslog leer Fireball22 Virtuelle Server 11 24.10.2008 16:38


Problem mit jails/syslog
Problem mit jails/syslog
Problem mit jails/syslog Problem mit jails/syslog
Powered by vBulletin® Version 3.8.11 (Deutsch)
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.