Server Support Forum
Neue php Version in Plesk regestrieren?

Zurück   Server Support Forum > >


Antwort
 
Themen-Optionen Bewertung: Bewertung: 2 Stimmen, 1,00 durchschnittlich.
  #1  
Alt 25.11.2014, 21:11
netzreiter netzreiter ist offline
Registered User
 
Registriert seit: 12.2012
Beiträge: 90
Neue php Version in Plesk regestrieren?

Hallo ich habe es nun endlisch geschaft eine andere php Version zu Installieren aber nun muss ich es ja mit Folgendem befehl in Plesk Regestrieren.
Code:
/usr/local/psa/bin/php_handler --add -displayname <NN> -path <path to php cgi> -phpini <path to php.ini> -type <php handler> -id <NN-custom>
Aber ich weiss nun nicht wo ich den Pfad für die cgi,fascgi und apache finde?
Mit Zitat antworten
  #2  
Alt 26.11.2014, 16:32
GwenDragon GwenDragon ist offline
Registered User
 
Registriert seit: 12.2008
Ort: Franken
Alter: 57
Beiträge: 2.962
Du findest sie dort wo DU die PHP-Versionen installiert hast!


Beispiel (nicht finktionsfähig):
Code:
php_handler --add -id cgi56 -displayname 5.6.999 \
   -path /usr/bin/php52/php-cgi -phpini \
   /etc/php56/cgi/php.ini -type cgi 
 
php_handler --add -id fastcgi56 -displayname 5.6.999 \
   -path /usr/bin/php56/php-cgi -phpini \
   /etc/php56/cgi/php.ini -type fastcgi
Du kannst auch gern die /etc/psa/php_versions.json erweitern und mit php_handler --reread die neu einlesen..
__________________
die Gwen, also die Drachin... nix anderscht!

Geändert von GwenDragon (26.11.2014 um 16:35 Uhr)
Mit Zitat antworten
  #3  
Alt 26.11.2014, 20:35
netzreiter netzreiter ist offline
Registered User
 
Registriert seit: 12.2012
Beiträge: 90
Vielen dank das habe ich nun hin bekommen php wurde Installiert und in Plesk regestriert,aber wenn ich es nun anwenden möchte bekomme ich nur eine Weisse Seite angezeigt u nd die error.log der Betroffenen Domain gibt zu dem Zeitpunkt einen Fehler der eigentlich Ignoriert werden kann.

Nun bin ich auf der suche was schief gelaufen ist das die php Installation nicht verwendet werden kann.
Mit Zitat antworten
  #4  
Alt 26.11.2014, 21:32
Benutzerbild von nexus
nexus nexus ist offline
Registered User
 
Registriert seit: 06.2011
Beiträge: 1.431
Zitat:
Zitat von netzreiter Beitrag anzeigen
bekomme ich nur eine Weisse Seite angezeigt u nd die error.log der Betroffenen Domain gibt zu dem Zeitpunkt einen Fehler der eigentlich Ignoriert werden kann.
Schön, deine Logfiles (alle relevanten?) hast du also schon analysiert...

Zitat:
Zitat von netzreiter Beitrag anzeigen
Nun bin ich auf der suche was schief gelaufen ist das die php Installation nicht verwendet werden kann.
Ohne spezifischere Infos wird das nur blindes Herumraten...
Also wie wäre es denn für den Anfang mal mit Auszügen aus den relevanten Logfiles zum Zeitpunkt des Aufrufs der entsprechenden Seite?

P.S.:
Logfileeinträge werden nicht ohne Grund geschrieben, in den meisten Fällen sollte man diese also nicht einfach ignorieren.
Mit Zitat antworten
  #5  
Alt 26.11.2014, 22:24
netzreiter netzreiter ist offline
Registered User
 
Registriert seit: 12.2012
Beiträge: 90
In der error.log steht zu diesem zeitpunkt.
Code:
[Wed Nov 26 15:22:33 2014] [warn] RSA server certificate CommonName (CN) `Parallels Panel' does NOT match server name!?
[Wed Nov 26 15:22:34 2014] [warn] RSA server certificate CommonName (CN) `Parallels Panel' does NOT match server name!?
[Wed Nov 26 15:23:01 2014] [warn] RSA server certificate CommonName (CN) `Parallels Panel' does NOT match server name!?
[Wed Nov 26 15:23:01 2014] [warn] RSA server certificate CommonName (CN) `Parallels Panel' does NOT match server name!?
Über Google habe ich Folgenden Shell-Befehl zum beheben gefunden und diesen auch ausgeführt.
Code:
# for i in `ls /usr/local/psa/var/certificates/`; do echo -n $i": "; openssl x509 -in /usr/local/psa/var/certificates/$i -subject -noout; done
Aber der fehlt ist nicht weg.
Mit Zitat antworten
  #6  
Alt 26.11.2014, 23:25
Benutzerbild von Joe User
Joe User Joe User ist offline
Registered User
 
Registriert seit: 11.2008
Ort: Hamburg
Alter: 39
Beiträge: 3.856
Und was diese Warnung nun mit PHP zu tun? Richtig, gar nichts.

Du bist jetzt seit zwei Jahren im SSF registriert, betreibst mindestens ebenso lange einen Server und hast noch immer nicht gelernt wie man Logfiles liest?
Wer so lernresistent ist, der soll einen Admin bezahlen und nicht hier rumheulen. Wir haben Besseres zu tun als unsere Zeit an Lernunwillige wie Dich zu verschwenden.

Sorry, aber das muss mal gesagt werden...
__________________
PayPal.Me/JoeUserWings for LifeWings for Life World Run
RootForum CommunityFreeBSD Remote InstallationFreeBSD Web Hosting System

„If there’s more than one possible outcome of a job or task, and one of those outcomes will result in disaster or an undesirable consequence, then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.
Mit Zitat antworten
  #7  
Alt 27.11.2014, 04:49
netzreiter netzreiter ist offline
Registered User
 
Registriert seit: 12.2012
Beiträge: 90
Ich verstehe diesen vorwurf nicht,ich habe die erorr.log file nach dem Fehler durchsucht und sogar über Google nach einer Lösung gesucht die leider nicht geklappt hat den Fehler zu beheben.

Was genau kann ich nicht lesen?
Mit Zitat antworten
  #8  
Alt 27.11.2014, 08:10
Benutzerbild von danton
danton danton ist offline
Registered User
 
Registriert seit: 04.2009
Ort: Ennigerloh
Alter: 44
Beiträge: 2.396
Neue php Version in Plesk regestrieren?
Du solltest mal in dein PHP-Logfile schauen, ob PHP evtl. mit einem Fatal-Error aussteigt. GGfl. in deiner korrekten php.ini für die neue Version eintragen, falls noch nicht geschehen.
__________________
Event-List - PHP/MySQL-Veranstaltungskalender für die eigene Homepage
Mit Zitat antworten
  #9  
Alt 27.11.2014, 10:11
Thorsten Thorsten ist offline
Moderator
 
Registriert seit: 07.2003
Alter: 46
Beiträge: 15.973
Hallo!
Zitat:
Zitat von netzreiter Beitrag anzeigen
Ich verstehe diesen vorwurf nicht,ich habe die erorr.log file nach dem Fehler durchsucht ...
Welche error.log denn? Ist das die Richtige? Mal als Hinweis:

/var/log/apache2/access.log
/var/log/apache2/error.log
/var/log/apache2/other_vhosts_access.log
/var/log/apache2/suexec.log

Plus die Logfiles der Domain, für die du die neue PHP Version installiert hast:

/var/www/vhosts/examples.com/error_log
/var/www/vhosts/examples.com/access_log
/var/www/vhosts/examples.com/proxy_access_log
/var/www/vhosts/examples.com/proxy_error_log

Plus, falls vorhanden, die zugehörigen SSL Logs.

Und du findest in keiner Datei irgendeinen relevanten Hinweis auf einen PHP Fehler?

mfG
Thorsten
Mit Zitat antworten
  #10  
Alt 27.11.2014, 10:21
GwenDragon GwenDragon ist offline
Registered User
 
Registriert seit: 12.2008
Ort: Franken
Alter: 57
Beiträge: 2.962
Ob das zusätzliche PHP für die Domain wirklich beim Web-Server registriert ist, siehst du nur in deiner VHost-Konfiguration der Domain. Und je nachdem es als CGI, FastCGI registriert wurde, steht bei Fehlern garantiert auch was im Logfile.
Vielleicht solltest du einfach mal eine index.php erstellen, die nur
PHP-Code:
<?php phpinfo(); ?>
enthält.
__________________
die Gwen, also die Drachin... nix anderscht!
Mit Zitat antworten
  #11  
Alt 27.11.2014, 14:25
Benutzerbild von nexus
nexus nexus ist offline
Registered User
 
Registriert seit: 06.2011
Beiträge: 1.431
Zitat:
Zitat von GwenDragon Beitrag anzeigen
Vielleicht solltest du einfach mal eine index.php erstellen
Dann sollte er die aber phpinfo.php oder sonstwie nennen...nicht daß er dann seine ursprüngliche index.php nicht mehr findet
Mit Zitat antworten
  #12  
Alt 27.11.2014, 16:55
GwenDragon GwenDragon ist offline
Registered User
 
Registriert seit: 12.2008
Ort: Franken
Alter: 57
Beiträge: 2.962
Meine Herren! Dass man das Original sichern sollte, wenn mann es noch braucht, setze ich voraus bei jemannd der einen Server besitzt.
__________________
die Gwen, also die Drachin... nix anderscht!
Mit Zitat antworten
  #13  
Alt 27.11.2014, 21:15
netzreiter netzreiter ist offline
Registered User
 
Registriert seit: 12.2012
Beiträge: 90
Ich habe in der richtigen error.log geschaut und da steht zum Zeitpunkt des Fehlers.
Code:
[Wed Nov 26 03:47:04 2014] [warn] RSA server certificate CommonName (CN) `Parallels Panel' does NOT match server name!?
[Wed Nov 26 03:47:04 2014] [warn] RSA server certificate CommonName (CN) `Parallels Panel' does NOT match server name!?
[Wed Nov 26 03:47:04 2014] [warn] RSA server certificate CommonName (CN) `Parallels Panel' does NOT match server name!?
[Wed Nov 26 03:47:04 2014] [warn] RSA server certificate CommonName (CN) `Parallels Panel' does NOT match server name!?
[Wed Nov 26 03:47:04 2014] [warn] Init: Name-based SSL virtual hosts only work for clients with TLS server name indication support (RFC 4366)
[Wed Nov 26 03:47:04 2014] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
[Wed Nov 26 03:47:04 2014] [notice] Digest: generating secret for digest authentication ...
[Wed Nov 26 03:47:04 2014] [notice] Digest: done
[Wed Nov 26 03:47:04 2014] [error] python_init: Python version mismatch, expected '2.7.2+', found '2.7.3'.
[Wed Nov 26 03:47:04 2014] [error] python_init: Python executable found '/usr/bin/python'.
[Wed Nov 26 03:47:04 2014] [error] python_init: Python path being used '/usr/lib/python2.7/:/usr/lib/python2.7/plat-linux2:/usr/lib/python2.7/lib-tk:/usr/lib/python2.7/lib-old:/usr/lib/python2.7/lib-dynload'.
[Wed Nov 26 03:47:04 2014] [notice] mod_python: Creating 8 session mutexes based on 150 max processes and 0 max threads.
[Wed Nov 26 03:47:04 2014] [notice] mod_python: using mutex_directory /tmp 
[Wed Nov 26 03:47:04 2014] [warn] RSA server certificate CommonName (CN) `Parallels Panel' does NOT match server name!?
[Wed Nov 26 03:47:04 2014] [warn] RSA server certificate CommonName (CN) `Parallels Panel' does NOT match server name!?
[Wed Nov 26 03:47:04 2014] [warn] RSA server certificate CommonName (CN) `Parallels Panel' does NOT match server name!?
[Wed Nov 26 03:47:04 2014] [warn] RSA server certificate CommonName (CN) `Parallels Panel' does NOT match server name!?
[Wed Nov 26 03:47:04 2014] [warn] Init: Name-based SSL virtual hosts only work for clients with TLS server name indication support (RFC 4366)
[Wed Nov 26 03:47:04 2014] [notice] Apache/2.2.22 (Debian) DAV/2 mod_fcgid/2.3.9 mod_python/3.3.1 Python/2.7.3 mod_ssl/2.2.22 OpenSSL/1.0.1e mod_perl/2.0.7 Perl/v5.14.2 configured -- resuming normal operations
In der info.php steht nur die PHP Version die mit dem Server Installiert wurde.
http://www.wbb-support.eu/info.php

Ich vermute das ich bei der Regestrierung etwas Falsch gemacht habe oder Vergessen.
Mit Zitat antworten
  #14  
Alt 27.11.2014, 21:47
GwenDragon GwenDragon ist offline
Registered User
 
Registriert seit: 12.2008
Ort: Franken
Alter: 57
Beiträge: 2.962
Steht doch im Plesk-Admin-Handbuch wie die Registrierung geht: http://download1.parallels.com/Plesk...Name=72042.htm
http://download1.parallels.com/Plesk...Name=72490.htm
__________________
die Gwen, also die Drachin... nix anderscht!
Mit Zitat antworten
  #15  
Alt 27.11.2014, 22:26
netzreiter netzreiter ist offline
Registered User
 
Registriert seit: 12.2012
Beiträge: 90
Ja die Anleitung kenne ich und danach habe ich es auch gemacht über Shell mit Putty und mir wurde auch angezeigt das das Regestrieren in Plesk erfolgreich war,aber etwas muss ja schief gelaufen sein weil ja das Problem mit der Weissen Seite ist wenn ich die Neue PHP Version anwenden möchte.
Mit Zitat antworten
Antwort

Lesezeichen

Stichworte
nun, php, plesk, regestrieren, version

Themen-Optionen
Thema bewerten
Thema bewerten:

Forumregeln
Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist aus.
HTML-Code ist aus.

Gehe zu

Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
Neue Confixx Version txc Confixx 1 02.11.2008 19:01
Plesk zeigt neue PHP Version nicht an FiffiWM2006 Plesk 0 21.09.2006 17:12
Dump aus Version 4.1.10a in neue Version einspielen Soulfly SQL 5 19.08.2006 16:55


Neue php Version in Plesk regestrieren?
Neue php Version in Plesk regestrieren?
Neue php Version in Plesk regestrieren? Neue php Version in Plesk regestrieren?
Powered by vBulletin® Version 3.8.11 (Deutsch)
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.