Server Support Forum
php update geht nicht

Zurück   Server Support Forum > >


Antwort
 
Themen-Optionen Thema bewerten
  #1  
Alt 17.10.2013, 08:36
mchenzi mchenzi ist offline
Registered User
 
Registriert seit: 06.2010
Beiträge: 2
php update geht nicht

Hallo
Ich hatte mal 2012 auf meinem Server das EPEL package zum php kompilieren genommen. Ich benötigte damals eine bestimmtes Zusatzmodul für Typo3. Jetzt scheint das EPEL paket keinen Support mehr zu bekommen und ich sitze auf einer alten PHP Version.

Wenn ich versuche von anderen Paketen. zb. webtactic ein update zu machen dann bekomme ich Fehler (siehe CODE1 )

Meine Fragen:

1. kann ich einfach alle zusätlichen Repos abschalten (enable=0 in der jeweiligen yum.repo.de/xxxxx.repo

2. Falls ja. Wie bekomme ich eine neue Version von php 5.3 (derzeit 5.3.3 und ich hätte gerne > 5.3.20 )

3. falls ich es von hand machen muss ... gibt es irgendwo eine anleitung und wie kann ich sicherstellen das ich keine Module vergesse.

4. Wenn ich --skip-broken option dazufüge bekomme ich auch nur Fehler.. siehe CODE2

Würde mich über eine Antwort freuen.

### CODE 1 ###
Code:
yum update php
Failed to set locale, defaulting to C
Loaded plugins: fastestmirror, priorities
Loading mirror speeds from cached hostfile
 * epel: mirror.fraunhofer.de
 * webtatic: uk.repo.webtatic.com
webtatic                                                          | 2.5 kB     00:00     
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package php.x86_64 0:5.3.3-23.el6_4 will be updated
---> Package php.x86_64 0:5.3.27-2.w5 will be an update
--> Processing Dependency: php-common = 5.3.27-2.w5 for package: php-5.3.27-2.w5.x86_64
--> Processing Dependency: php-cli = 5.3.27-2.w5 for package: php-5.3.27-2.w5.x86_64
--> Processing Dependency: libssl.so.6()(64bit) for package: php-5.3.27-2.w5.x86_64
--> Processing Dependency: libcrypto.so.6()(64bit) for package: php-5.3.27-2.w5.x86_64
--> Running transaction check
---> Package openssl098e.x86_64 0:0.9.8e-17.el6.centos.2 will be installed
---> Package php-cli.x86_64 0:5.3.3-23.el6_4 will be updated
---> Package php-cli.x86_64 0:5.3.27-2.w5 will be an update
--> Processing Dependency: libtermcap.so.2()(64bit) for package: php-cli-5.3.27-2.w5.x86_64
--> Processing Dependency: libreadline.so.5()(64bit) for package: php-cli-5.3.27-2.w5.x86_64
---> Package php-common.x86_64 0:5.3.3-23.el6_4 will be updated
--> Processing Dependency: php-common(x86-64) = 5.3.3-23.el6_4 for package: php-imap-5.3.3-23.el6_4.x86_64
--> Processing Dependency: php-common(x86-64) = 5.3.3-23.el6_4 for package: php-mbstring-5.3.3-23.el6_4.x86_64
--> Processing Dependency: php-common(x86-64) = 5.3.3-23.el6_4 for package: php-mysql-5.3.3-23.el6_4.x86_64
--> Processing Dependency: php-common(x86-64) = 5.3.3-23.el6_4 for package: php-soap-5.3.3-23.el6_4.x86_64
--> Processing Dependency: php-common(x86-64) = 5.3.3-23.el6_4 for package: php-pdo-5.3.3-23.el6_4.x86_64
--> Processing Dependency: php-common(x86-64) = 5.3.3-23.el6_4 for package: php-gd-5.3.3-23.el6_4.x86_64
--> Processing Dependency: php-common(x86-64) = 5.3.3-23.el6_4 for package: php-xml-5.3.3-23.el6_4.x86_64
---> Package php-common.x86_64 0:5.3.27-2.w5 will be an update
--> Processing Dependency: libcurl.so.3()(64bit) for package: php-common-5.3.27-2.w5.x86_64
--> Running transaction check
---> Package compat-libtermcap.x86_64 0:2.0.8-49.el6 will be installed
---> Package compat-readline5.x86_64 0:5.2-17.1.el6 will be installed
---> Package php-common.x86_64 0:5.3.27-2.w5 will be an update
--> Processing Dependency: libcurl.so.3()(64bit) for package: php-common-5.3.27-2.w5.x86_64
---> Package php-gd.x86_64 0:5.3.3-23.el6_4 will be updated
---> Package php-gd.x86_64 0:5.3.27-2.w5 will be an update
---> Package php-imap.x86_64 0:5.3.3-23.el6_4 will be updated
---> Package php-imap.x86_64 0:5.3.27-2.w5 will be an update
--> Processing Dependency: libc-client.so.1()(64bit) for package: php-imap-5.3.27-2.w5.x86_64
---> Package php-mbstring.x86_64 0:5.3.3-23.el6_4 will be updated
---> Package php-mbstring.x86_64 0:5.3.27-2.w5 will be an update
---> Package php-mysql.x86_64 0:5.3.3-23.el6_4 will be updated
---> Package php-mysql.x86_64 0:5.3.27-2.w5 will be an update
--> Processing Dependency: libmysqlclient.so.15(libmysqlclient_15)(64bit) for package: php-mysql-5.3.27-2.w5.x86_64
--> Processing Dependency: libmysqlclient.so.15()(64bit) for package: php-mysql-5.3.27-2.w5.x86_64
---> Package php-pdo.x86_64 0:5.3.3-23.el6_4 will be updated
---> Package php-pdo.x86_64 0:5.3.27-2.w5 will be an update
---> Package php-soap.x86_64 0:5.3.3-23.el6_4 will be updated
---> Package php-soap.x86_64 0:5.3.27-2.w5 will be an update
---> Package php-xml.x86_64 0:5.3.3-23.el6_4 will be updated
---> Package php-xml.x86_64 0:5.3.27-2.w5 will be an update
--> Running transaction check
---> Package libmysqlclient15.x86_64 0:5.0.95-5.w5 will be installed
---> Package php-common.x86_64 0:5.3.27-2.w5 will be an update
--> Processing Dependency: libcurl.so.3()(64bit) for package: php-common-5.3.27-2.w5.x86_64
---> Package php-imap.x86_64 0:5.3.27-2.w5 will be an update
--> Processing Dependency: libc-client.so.1()(64bit) for package: php-imap-5.3.27-2.w5.x86_64
--> Finished Dependency Resolution
Error: Package: php-common-5.3.27-2.w5.x86_64 (webtatic)
           Requires: libcurl.so.3()(64bit)
Error: Package: php-imap-5.3.27-2.w5.x86_64 (webtatic)
           Requires: libc-client.so.1()(64bit)
 You could try using --skip-broken to work around the problem
** Found 1 pre-existing rpmdb problem(s), 'yum check' output follows:
epel-release-6-8.noarch is a duplicate with epel-release-6-7.noarch

### CODE2 ###
Code:
yum update --skip-broken php
Failed to set locale, defaulting to C
Loaded plugins: fastestmirror, priorities
Loading mirror speeds from cached hostfile
 * epel: mirror.fraunhofer.de
 * webtatic: uk.repo.webtatic.com
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package php.x86_64 0:5.3.3-23.el6_4 will be updated
---> Package php.x86_64 0:5.3.27-2.w5 will be an update
--> Processing Dependency: php-common = 5.3.27-2.w5 for package: php-5.3.27-2.w5.x86_64
--> Processing Dependency: php-cli = 5.3.27-2.w5 for package: php-5.3.27-2.w5.x86_64
--> Processing Dependency: libssl.so.6()(64bit) for package: php-5.3.27-2.w5.x86_64
--> Processing Dependency: libcrypto.so.6()(64bit) for package: php-5.3.27-2.w5.x86_64
--> Running transaction check
---> Package openssl098e.x86_64 0:0.9.8e-17.el6.centos.2 will be installed
---> Package php-cli.x86_64 0:5.3.3-23.el6_4 will be updated
---> Package php-cli.x86_64 0:5.3.27-2.w5 will be an update
--> Processing Dependency: libtermcap.so.2()(64bit) for package: php-cli-5.3.27-2.w5.x86_64
--> Processing Dependency: libreadline.so.5()(64bit) for package: php-cli-5.3.27-2.w5.x86_64
---> Package php-common.x86_64 0:5.3.3-23.el6_4 will be updated
--> Processing Dependency: php-common(x86-64) = 5.3.3-23.el6_4 for package: php-imap-5.3.3-23.el6_4.x86_64
--> Processing Dependency: php-common(x86-64) = 5.3.3-23.el6_4 for package: php-mbstring-5.3.3-23.el6_4.x86_64
--> Processing Dependency: php-common(x86-64) = 5.3.3-23.el6_4 for package: php-mysql-5.3.3-23.el6_4.x86_64
--> Processing Dependency: php-common(x86-64) = 5.3.3-23.el6_4 for package: php-soap-5.3.3-23.el6_4.x86_64
--> Processing Dependency: php-common(x86-64) = 5.3.3-23.el6_4 for package: php-pdo-5.3.3-23.el6_4.x86_64
--> Processing Dependency: php-common(x86-64) = 5.3.3-23.el6_4 for package: php-gd-5.3.3-23.el6_4.x86_64
--> Processing Dependency: php-common(x86-64) = 5.3.3-23.el6_4 for package: php-xml-5.3.3-23.el6_4.x86_64
---> Package php-common.x86_64 0:5.3.27-2.w5 will be an update
--> Processing Dependency: libcurl.so.3()(64bit) for package: php-common-5.3.27-2.w5.x86_64
--> Running transaction check
---> Package compat-libtermcap.x86_64 0:2.0.8-49.el6 will be installed
---> Package compat-readline5.x86_64 0:5.2-17.1.el6 will be installed
---> Package php-common.x86_64 0:5.3.27-2.w5 will be an update
--> Processing Dependency: libcurl.so.3()(64bit) for package: php-common-5.3.27-2.w5.x86_64
---> Package php-gd.x86_64 0:5.3.3-23.el6_4 will be updated
---> Package php-gd.x86_64 0:5.3.27-2.w5 will be an update
---> Package php-imap.x86_64 0:5.3.3-23.el6_4 will be updated
---> Package php-imap.x86_64 0:5.3.27-2.w5 will be an update
--> Processing Dependency: libc-client.so.1()(64bit) for package: php-imap-5.3.27-2.w5.x86_64
---> Package php-mbstring.x86_64 0:5.3.3-23.el6_4 will be updated
---> Package php-mbstring.x86_64 0:5.3.27-2.w5 will be an update
---> Package php-mysql.x86_64 0:5.3.3-23.el6_4 will be updated
---> Package php-mysql.x86_64 0:5.3.27-2.w5 will be an update
--> Processing Dependency: libmysqlclient.so.15(libmysqlclient_15)(64bit) for package: php-mysql-5.3.27-2.w5.x86_64
--> Processing Dependency: libmysqlclient.so.15()(64bit) for package: php-mysql-5.3.27-2.w5.x86_64
---> Package php-pdo.x86_64 0:5.3.3-23.el6_4 will be updated
---> Package php-pdo.x86_64 0:5.3.27-2.w5 will be an update
---> Package php-soap.x86_64 0:5.3.3-23.el6_4 will be updated
---> Package php-soap.x86_64 0:5.3.27-2.w5 will be an update
---> Package php-xml.x86_64 0:5.3.3-23.el6_4 will be updated
---> Package php-xml.x86_64 0:5.3.27-2.w5 will be an update
--> Running transaction check
---> Package libmysqlclient15.x86_64 0:5.0.95-5.w5 will be installed
---> Package php-common.x86_64 0:5.3.27-2.w5 will be an update
--> Processing Dependency: libcurl.so.3()(64bit) for package: php-common-5.3.27-2.w5.x86_64
---> Package php-imap.x86_64 0:5.3.27-2.w5 will be an update
--> Processing Dependency: libc-client.so.1()(64bit) for package: php-imap-5.3.27-2.w5.x86_64
--> Running transaction check
---> Package libmysqlclient15.x86_64 0:5.0.95-5.w5 will be installed
--> Processing Dependency: libssl.so.6()(64bit) for package: libmysqlclient15-5.0.95-5.w5.x86_64
--> Processing Dependency: libcrypto.so.6()(64bit) for package: libmysqlclient15-5.0.95-5.w5.x86_64
---> Package php.x86_64 0:5.3.3-23.el6_4 will be updated
---> Package php-gd.x86_64 0:5.3.3-23.el6_4 will be updated
---> Package php-mbstring.x86_64 0:5.3.3-23.el6_4 will be updated
---> Package php-mysql.x86_64 0:5.3.3-23.el6_4 will be updated
---> Package php-mysql.x86_64 0:5.3.27-2.w5 will be an update
--> Processing Dependency: php-pdo = 5.3.27-2.w5 for package: php-mysql-5.3.27-2.w5.x86_64
--> Processing Dependency: libssl.so.6()(64bit) for package: php-mysql-5.3.27-2.w5.x86_64
--> Processing Dependency: libcrypto.so.6()(64bit) for package: php-mysql-5.3.27-2.w5.x86_64
---> Package php-pdo.x86_64 0:5.3.3-23.el6_4 will be updated
---> Package php-soap.x86_64 0:5.3.3-23.el6_4 will be updated
---> Package php-xml.x86_64 0:5.3.3-23.el6_4 will be updated
--> Running transaction check
---> Package libmysqlclient15.x86_64 0:5.0.95-5.w5 will be installed
---> Package php-mysql.x86_64 0:5.3.3-23.el6_4 will be updated
--> Processing Dependency: php-pdo(x86-64) for package: php-mysql-5.3.3-23.el6_4.x86_64
---> Package php-mysql.x86_64 0:5.3.27-2.w5 will be an update
--> Running transaction check
---> Package php-mysql.x86_64 0:5.3.3-23.el6_4 will be updated
---> Package php-pdo.x86_64 0:5.3.3-23.el6_4 will be updated

Packages skipped because of dependency problems:
    compat-libtermcap-2.0.8-49.el6.x86_64 from base
    compat-readline5-5.2-17.1.el6.x86_64 from base
    libmysqlclient15-5.0.95-5.w5.x86_64 from webtatic
    openssl098e-0.9.8e-17.el6.centos.2.x86_64 from base
    php-5.3.27-2.w5.x86_64 from webtatic
    php-cli-5.3.27-2.w5.x86_64 from webtatic
    php-common-5.3.27-2.w5.x86_64 from webtatic
    php-gd-5.3.27-2.w5.x86_64 from webtatic
    php-imap-5.3.27-2.w5.x86_64 from webtatic
    php-mbstring-5.3.27-2.w5.x86_64 from webtatic
    php-mysql-5.3.27-2.w5.x86_64 from webtatic
    php-pdo-5.3.27-2.w5.x86_64 from webtatic
    php-soap-5.3.27-2.w5.x86_64 from webtatic
    php-xml-5.3.27-2.w5.x86_64 from webtatic
Mit Zitat antworten

Antwort



Themen-Optionen
Thema bewerten
Thema bewerten:

Forumregeln
Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist aus.
HTML-Code ist aus.

Gehe zu

Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
PHP geht nach Apache-Update nicht mehr Fantasyelf Dedizierte Server 45 16.08.2012 13:38
Plesk 10.4.4 Update #7 - Traffic-Statistik geht nicht ric0 Plesk 13 17.12.2011 02:25
Update geht nicht Vagabundo Webmin 0 13.09.2011 18:13
[Open-Suse 11.1] Online Update geht nicht DHMH Virtuelle Server 2 30.01.2010 10:50
Horde geht nach 8.3.0 update nicht mehr pro---studio Plesk 3 19.02.2008 17:57


php update geht nicht
php update geht nicht
php update geht nicht php update geht nicht
Powered by vBulletin® Version 3.8.11 (Deutsch)
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.