Server Support Forum
Anzeige:


Zurück   Server Support Forum > Server > Virtuelle Server


Antwort
 
LinkBack Themen-Optionen Thema bewerten
  #1  
Alt 05.09.2007, 06:43
Registered User
 
Registriert seit: 08.2007
Beiträge: 8
php -v zeigt andere Version als phpinfo() nach Udate unter Suse 9.3

kurze Frage zur Version nach php Update nach -> 4.4.7

Das Update hat eigentlich wunderbar funktioniert und auch phpinfo zeigt die richtige Version an.
PHP Version 4.4.7
Build Date Sep 5 2007 04:25:11

Wenn ich nun in der ssh Console "php -v" eingebe kommt folgende Info:
PHP 4.3.10 (cli) (built: Sep 24 2005 08:15:45)

liegt das daran das ich das von Hand gemacht habe ??


Ein weitere Punkt ist folgendes:
Code:
echo "$_SERVER['$REMOTE_ADDR']"; // zeigt nichts
ABER
$ip = getenv ("REMOTE_ADDR");
echo $ip; // zeigt es richtig
???


Danke .-)

Geändert von Thorsten (05.09.2007 um 08:26 Uhr) Grund: Code Tags gesetzt.
Mit Zitat antworten

  #2  
Alt 05.09.2007, 08:29
Benutzerbild von Thorsten
Moderator
 
Registriert seit: 07.2003
Alter: 43
Beiträge: 15.477
Blog-Einträge: 78
Thorsten eine Nachricht über ICQ schicken

Hallo!
Das dürfte daran liegen, dass PHP für den Apache (wahrscheinlich mod_php4) und das PHP Command Line Interface (cli) zwei unterschiedliche Pakete sind. Was wurde denn genau upgedatet?

mfG
Thorsten
Mit Zitat antworten
  #3  
Alt 05.09.2007, 08:46
Registered User
 
Registriert seit: 08.2007
Beiträge: 8

Der "standard" vServer hatte noch php4.3.10 drauf
da dachte ich mal php4.4.7 wäre etwas besser !?
(das ganze unter SUSE 9.3)


Also ich habe folgende Schritte durchgeführt:


Code:
cd /usr/local/src
wget http://de3.php.net/get/php-4.4.7.tar.gz/from/this/mirror
gzip -d -c php-4.4.7.tar.gz | tar xvf -
cp /etc/php.ini /etc/php.ini.sav
cd /php-4.4.7

./configure --prefix=/usr --datadir=/usr/share/php --mandir=/usr/share/man --bindir=/usr/bin --libdir=/usr/share --includedir=/usr/include --sysconfdir=/etc --with-_lib=lib --with-config-file-path=/etc --with-exec-dir=/usr/lib/php/bin --disable-debug --enable-inline-optimization --enable-memory-limit --enable-magic-quotes --enable-safe-mode --enable-sigchild --disable-ctype --disable-session --without-mysql --disable-cli --without-pear --with-openssl --with-apxs2=/usr/sbin/apxs2-prefork i586-suse-linux

rcapache2 stop
make
make install
rcapache2 start

ich habe die ./configure von der vorherigen phpinfo() übernommen und mit howtos für vServer abgeglichen.
Mit Zitat antworten
  #4  
Alt 05.09.2007, 09:06
Benutzerbild von Thorsten
Moderator
 
Registriert seit: 07.2003
Alter: 43
Beiträge: 15.477
Blog-Einträge: 78
Thorsten eine Nachricht über ICQ schicken

Hallo!
Fällt dir bei deinem configure etwas auf?
Code:
... --disable-cli
mfG
Thorsten
Mit Zitat antworten
  #5  
Alt 05.09.2007, 09:25
Registered User
 
Registriert seit: 08.2007
Beiträge: 8

JA !!

... deswegen ist es ja so seltsam ...

als ich phpinfo() unter 4.3.10 gemacht habe
bekam ich unter "Configure Command" die identischen
einträge wie nun unter php 4.4.7 ...

in beiden fällen ... --disable-cli

*grübel*
Mit Zitat antworten
  #6  
Alt 05.09.2007, 09:27
Benutzerbild von Thorsten
Moderator
 
Registriert seit: 07.2003
Alter: 43
Beiträge: 15.477
Blog-Einträge: 78
Thorsten eine Nachricht über ICQ schicken

Hallo!
Du hast für die 4.4.7 kein neues php-cli gebaut. Genau das bewirkt doch der Parameter --disable-cli. Ergo ist noch das alte da.

mfG
Thorsten
Mit Zitat antworten
  #7  
Alt 05.09.2007, 10:16
Registered User
 
Registriert seit: 08.2007
Beiträge: 8

... wer lesen kann ich klar im Vorteil !!


Die Nacht war wohl etwas lang ....

einfach "make install-cli" nach "make install" und es funkt !!

Danke .-)


CLOSE
Mit Zitat antworten
Antwort

Lesezeichen


Themen-Optionen
Thema bewerten
Thema bewerten:

Forumregeln
Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist aus.
HTML-Code ist aus.
Trackbacks sind aus
Pingbacks sind aus
Refbacks sind aus


Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
V-Power Server (Suse 9.3) Probleme nach Firewall Aktivierung unter Yast dogsch Virtuelle Server 7 23.03.2007 10:01
Plesk zeigt neue PHP Version nicht an FiffiWM2006 Plesk 0 21.09.2006 16:12
PHP Version unter SuSe updaten Klawutke Virtuelle Server 2 16.04.2006 01:52
Probleme mit confixx nach update auf Version 3.0.9 shadowsnake Confixx 10 27.05.2005 19:12
Webftp unter Confixx 3.0 zeigt keinen Inhalt an enueske Confixx 4 10.01.2005 18:22





Powered by vBulletin® Version 3.8.8 (Deutsch)
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.