Server Support Forum
Anzeige:
451 4.3.0 Error queue file write error

Zurück   Server Support Forum > >


Antwort
 
Themen-Optionen Thema bewerten
  #1  
Alt 18.02.2009, 14:14
kenny_g kenny_g ist offline
Registered User
 
Registriert seit: 09.2007
Beiträge: 209
451 4.3.0 Error queue file write error

Hallo,

ich habe Plesk 9 mit openSuse und Postfix am laufen. Wenn ich Mails verschicken möchte, die größer als 1,5 Mb sind bekomme ich immer die Fehlermeldung 451 4.3.0 Error queue file write error. Nach meinen Recherchen konnte ich das soweit ermitteln, wenn ein Virenscanner etc. dazwischen funkt, spricht die Datei scannt, das er bei größeren Mailanhängen dann irgenwann die benannte Fehlermeldung 451 4.3.0 Error queue file write error rausfeuert, welches wohl darauf zurück zu führen ist, das die Übermittlung an Postfix zu lange dauert. Wie kann ich das hinbekommen, das Postfix nicht so schnell ungeduldig wird und die Fehlermeldung raushaut? ich würde mich sehr freuen, wenn mir einer helfen würde.

Gruß

Kenny
Mit Zitat antworten

  #2  
Alt 18.02.2009, 19:37
Benutzerbild von LinuxAdmin
LinuxAdmin LinuxAdmin ist offline
Moderator
 
Registriert seit: 07.2007
Ort: Basel
Beiträge: 3.605
Blog-Einträge: 1
Die Fehlermeldung, die Du bekommst ist eine generische Fehlermeldung, die nicht unbedingt zur Lösung beiträgt. Du solltest in /var/log/mail und /var/log/mail.err nach der genauen Ursache des Problems suchen.
Mit Zitat antworten
  #3  
Alt 19.02.2009, 03:25
kenny_g kenny_g ist offline
Registered User
 
Registriert seit: 09.2007
Beiträge: 209
Fehler ist nicht zu finden, da sieht alles OK aus...

Gruß

Kenny

Geändert von kenny_g (19.02.2009 um 03:30 Uhr)
Mit Zitat antworten
  #4  
Alt 19.02.2009, 19:54
Benutzerbild von LinuxAdmin
LinuxAdmin LinuxAdmin ist offline
Moderator
 
Registriert seit: 07.2007
Ort: Basel
Beiträge: 3.605
Blog-Einträge: 1
Glaube ich nicht. Postfix gibt keine Fehlermeldungen raus, ohne das zu protokollieren.
Mit Zitat antworten
  #5  
Alt 19.02.2009, 20:14
Roger Wilco Roger Wilco ist offline
Registered User
 
Registriert seit: 11.2006
Beiträge: 3.464
Zitat:
Zitat von LinuxAdmin Beitrag anzeigen
Glaube ich nicht. Postfix gibt keine Fehlermeldungen raus, ohne das zu protokollieren.
In diesem Fall durchaus möglich. Ich tippe darauf, dass die Partition mit dem Mailspool bzw. -queue vollgelaufen ist. Normalerweise ist das /var und welches Verzeichnis liegt noch auf /var und endet auf 'og'?
Mit Zitat antworten
  #6  
Alt 20.02.2009, 01:33
kenny_g kenny_g ist offline
Registered User
 
Registriert seit: 09.2007
Beiträge: 209
Hallo Ihr beiden,

erst einaml vielen Dank dafür das Ihr mir weiterhelfen wollt, aber....

@LinuxAdmin: Ich habe da wirklich keine Fehlermeldung ausser das ich eine Meldung bekommen habe, wenn einer an eine eMail an eine nicht vorhandene Adresse schreibt, die es bei mir auf dem Server nicht gibt.

@Roger Danke für die Info, ich bin im /var/log/ aber stehe auf der Leitung, wo ich da schauen muss....! Greifst Du mir mal bitte unter die Arme? Danke für Deine Hilfsbereitschaft.

Gruß

Kenny
Mit Zitat antworten
  #7  
Alt 20.02.2009, 02:57
kenny_g kenny_g ist offline
Registered User
 
Registriert seit: 09.2007
Beiträge: 209
So, mich hat es nun mal gereizt meinen Virenscanner nach dem ich ein Image von meinem System gemacht habe, zu löschen. Ich habe mir dann mal eine Datei gesucht und versucht 5 MB, was mit Virenscanner nicht ging, zu verschicken. Und was soll ich sagen, es geht. Also kann das meines erachtens nicht an meinen Mailserver ansich liegen,oder sehe ich das falsch? Wenn ich das falsch sehe, dann bitte eine alternative Erklärung. Zumindest habe ich die Problematik gefunden, aber wie kann ich diese lösen? Ich nutze GATA und die Option, das ausgehende Mails nicht gescannt werden sollen wurden gesetzt und die andere was angeblich eine Zeitüberschreitung verhindern sollte ist auch aktiviert. Ich sehe mal kommen, das ich morgen bei GDATA anrufen werde und denen mal auf die Klöten gehe. Ein Bekannter nutzt von Norten so ein Scanner und hat das gleiche Problem.

Hmmm, hat sonst noch einer eine IDee, wie man das hinbekommt, das Postfx nicht so schnell nervös wird und die Leitung kappt?

Nochmal Gruß vom

Kenny
Mit Zitat antworten
  #8  
Alt 22.02.2009, 19:23
Benutzerbild von LinuxAdmin
LinuxAdmin LinuxAdmin ist offline
Moderator
 
Registriert seit: 07.2007
Ort: Basel
Beiträge: 3.605
Blog-Einträge: 1
Du könntest noch auf Roger Wilcos Bemerkung eingehen und die Ausgabe von
Code:
df -k
posten.
Mit Zitat antworten
  #9  
Alt 23.02.2009, 07:56
kenny_g kenny_g ist offline
Registered User
 
Registriert seit: 09.2007
Beiträge: 209
dann werde ich das nochmal machen, mal sehen was gann passiert.

Gruß

Kenny
Mit Zitat antworten
  #10  
Alt 12.03.2009, 01:33
kenny_g kenny_g ist offline
Registered User
 
Registriert seit: 09.2007
Beiträge: 209
MOD: Bitte keine Fullquotes! Danke

Sorry, irgendwie stehe ich auf den Schlauch, bzw. schein hier gerade eine Wissenslücke vorhanden zu sein. Kannst du mir da mal bitte genaueres posten?

So, ich habe aber schon viele andere Dinge geklärt und komme immer wieder auf das Timeout Problem, wenn die Daten nicht fix zum SMTP Server kommen. Mit anderen Worten, will einer eine Datei via 2000er DSL Leitung zum Postfix senden bekommt er die genannte Fehlermeldung, wenn der Anhang größer als 1 MB ist. Das gleiche mit einer 16Mbit und 7 Mb Datei ist das kein Problem. Nun habe ich mir auch noch etwas angeschaut, als ich mir Webmin installiert habe. Da sehe ich eine Konfigurationsebene des SMTP Servers von Postfix und sehe da eine Einstellung: Timeout bis Senden von 4xx/5xx-Fehlerantwort. Das ist das was ich bekomme. Der Wert ist dort auf 1 Sekunde eingestellt. Kann man den Wert ohne weiteres erhöhen? Kommt Plesk damit klar, wenn ich via Webmin den Wert erhöhe? Und um wieviel sollte man max. erhöhen?

Ist einer so nett und übersieht mal die Wissenslücke und hilft mir genauer weiter? Vielen Dank!

Gruß

Kenny

Geändert von LinuxAdmin (12.03.2009 um 10:09 Uhr) Grund: FQ gelöscht
Mit Zitat antworten
  #11  
Alt 22.03.2009, 22:42
kenny_g kenny_g ist offline
Registered User
 
Registriert seit: 09.2007
Beiträge: 209
so nun habe ich mal df -k ausgeführt hier die Werte:
Code:
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/sda2            305592212  23938592 266130416   9% /
udev                    997104        76    997028   1% /dev
Ich würde mich freuen, wenn mir einer weiterhelfen könnte. Danke!

Gruß

Kenny

Geändert von Huschi (23.03.2009 um 13:55 Uhr) Grund: CODE-Tag gesetzt
Mit Zitat antworten
  #12  
Alt 23.03.2009, 00:43
Benutzerbild von fuchzga
fuchzga fuchzga ist offline
Registered User
 
Registriert seit: 03.2008
Ort: München
Alter: 40
Beiträge: 401
fuchzga eine Nachricht über MSN schicken
IMHO ist das eine klassische "before-queue content filter" Konfiguration.
Du kannst danach mal googeln.
Du stösst dann u.a. auf diesen Link: Postfix Before-Queue Content Filter

Wo es dafür in Plesk oder Webmin einen Schalter gibt, weiss ich leider nicht. Mit sowas ärger ich mich nicht rum.
Mit Zitat antworten
  #13  
Alt 23.03.2009, 13:17
kenny_g kenny_g ist offline
Registered User
 
Registriert seit: 09.2007
Beiträge: 209
MOD: Full-Quote entfernt!
Kannst du mir sonst bitte sagen, wie und wo ich das manuell ändern kann?

Gruß

Kenny

Geändert von Huschi (23.03.2009 um 13:54 Uhr)
Mit Zitat antworten
  #14  
Alt 23.03.2009, 14:08
Benutzerbild von Huschi
Huschi Huschi ist offline
Moderator
 
Registriert seit: 09.2003
Ort: Nürnberg
Beiträge: 15.412
Blog-Einträge: 5
@fuchzga
Wenn ich Kenny richtig verstanden habe, dann hat er den Virusfilter auf seinem Desktop ausgeschaltet.

@Kenny
Bei den meisten Virenscannern kann man das Scannen der ausgehenden Emails abstellen. Denn der Fehler liegt hier nicht beim Server. Der Timeout liegt standardmäßig bei 300 Sekunden (== 5 Minuten). Aber der wahrscheinlich ist es der smtpd_error_sleep_time, der die Verbindung unterbricht. Und dann hat es bereits mind. 10 Fehler innerhalb einer Sekunde im SMTP-Dialog gegeben. Und die Fehler macht wohl nicht Dein Email-Client sondern derjenige, der sich in die Kommunikation einklinkt: der Virenscanner.

huschi.
__________________
huschi.net - Linux-Server-Admin FAQ
Consult-N.de - kommerzieller Linux-Support
Mit Zitat antworten
  #15  
Alt 23.03.2009, 18:17
Benutzerbild von fuchzga
fuchzga fuchzga ist offline
Registered User
 
Registriert seit: 03.2008
Ort: München
Alter: 40
Beiträge: 401
fuchzga eine Nachricht über MSN schicken
Jetzt wo du's sagst... Ich dachte GDATA wird als Milter verwendet.
Ok, dann ist das Problem wohl doch eher am Client.
Mit Zitat antworten
Antwort

Lesezeichen


Themen-Optionen
Thema bewerten
Thema bewerten:

Forumregeln
Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist aus.
HTML-Code ist aus.

Gehe zu

Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
Wie installiere ich mod_security auf Strato Power Server ? nero Dedizierte Server 16 22.01.2010 15:18
Problem mit Install dereine Confixx 11 01.05.2008 21:36
Unbekannte Fehlermeldung professor Virtuelle Server 5 07.06.2007 22:49
Confixx Install. Problem knoppers Confixx 3 11.10.2006 09:25


451 4.3.0 Error queue file write error
451 4.3.0 Error queue file write error
451 4.3.0 Error queue file write error 451 4.3.0 Error queue file write error
Powered by vBulletin® Version 3.8.9 (Deutsch)
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.