Server Support Forum
Anzeige:


Zurück   Server Support Forum > >


Antwort
 
Themen-Optionen Thema bewerten
  #1  
Alt 27.04.2012, 22:25
Freakshow1000 Freakshow1000 ist offline
Registered User
 
Registriert seit: 04.2012
Beiträge: 64
apt-get spielt verrückt

Hallo,

ich habe eine frisch aufgesetze Debian VM die aktuell leider nur Probleme macht.
Zum Kompilieren von Paketen wollte ich einige Pakete installieren, leider macht mir die Paketverwaltung einen strich durch die Rechnung

Code:
root@ts3:/var/www/test/smokeping-2.6.8# apt-get install build-essential gettext make g++ libwrap0-dev postgresql-server-dev-all libldap2-dev libmysql++-dev libpam0g-dev libssl-dev libsqlite3-dev unixodbc-dev libncurses5-dev libacl1-dev libcap-dev
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut
Statusinformationen werden eingelesen... Fertig
gettext ist schon die neueste Version.
libcap-dev ist schon die neueste Version.
make ist schon die neueste Version.
libldap2-dev ist schon die neueste Version.
postgresql-server-dev-all ist schon die neueste Version.
libwrap0-dev ist schon die neueste Version.
unixodbc-dev ist schon die neueste Version.
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 build-essential : Hängt ab von: libc6-dev soll aber nicht installiert werden oder
                                  libc-dev
 g++ : Hängt ab von: g++-4.4 (>= 4.4.5-1~) soll aber nicht installiert werden
 libacl1-dev : Hängt ab von: libc6-dev soll aber nicht installiert werden oder
                              libc-dev
               Hängt ab von: libattr1-dev (>= 2.4.4) soll aber nicht installiert werden
 libmysql++-dev : Hängt ab von: libmysqlclient15-dev
 libncurses5-dev : Hängt ab von: libc-dev
 libpam0g-dev : Hängt ab von: libc6-dev soll aber nicht installiert werden oder
                               libc-dev
 libsqlite3-dev : Hängt ab von: libc6-dev soll aber nicht installiert werden
 libssl-dev : Hängt ab von: zlib1g-dev soll aber nicht installiert werden
E: Beschädigte Pakete
Ich habe jetzt schon versucht einige dieser Pakete einzeln zu installieren, leider ohne Erfolg.

Code:
aptitude install g++
Die folgenden NEUEN Pakete werden zusätzlich installiert:
  g++ g++-4.4{a} libc-dev-bin{a} libc6-dev{ab} libstdc++6-4.4-dev{a}
  linux-libc-dev{a} manpages-dev{a}
0 Pakete aktualisiert, 7 zusätzlich installiert, 0 werden entfernt und 0 nicht aktualisiert.
Muss 9.625 kB/12,3 MB an Archiven herunterladen. Nach dem Entpacken werden 41,9 MB zusätzlich belegt sein.
Die folgenden Pakete haben verletzte Abhängigkeiten:
  libc6-dev: Hängt ab von: libc6 (= 2.11.3-2) aber 2.11.3-3 ist installiert.
Die folgenden Aktionen werden diese Abhängigkeiten auflösen:

     Beibehalten der folgenden Pakete in ihrer aktuellen Version:
1)     g++ [Nicht installiert]
2)     g++-4.4 [Nicht installiert]
3)     libc6-dev [Nicht installiert]
4)     libstdc++6-4.4-dev [Nicht installiert]



Diese Lösung akzeptieren? [Y/n/q/?] Y
Es werden keine Pakete installiert, aktualisiert oder entfernt.
0 Pakete aktualisiert, 0 zusätzlich installiert, 0 werden entfernt und 0 nicht aktualisiert.
Muss 0 B an Archiven herunterladen. Nach dem Entpacken werden 0 B zusätzlich belegt sein.
Code:
Die folgenden Aktionen werden diese Abhängigkeiten auflösen:

     Beibehalten der folgenden Pakete in ihrer aktuellen Version:
1)     g++ [Nicht installiert]
2)     g++-4.4 [Nicht installiert]
3)     libc6-dev [Nicht installiert]
4)     libstdc++6-4.4-dev [Nicht installiert]
Das versteh ich jetzt hinten und vorne nicht. Wie soll ich Pakete beibehalten wenn diese nicht installiert sind?!

Die Lösung scheint wohl das Downgrade von 2.11.3-3 auf 2.11.3-2 zusein.
Leider fällt mir dafür kein Weg ein.

Code:
apt-get install -f
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut
Statusinformationen werden eingelesen... Fertig
Abhängigkeiten werden korrigiert... fehlgeschlagen.
Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 libc6 : Hängt ab von: libc-bin (= 2.11.3-2) aber 2.11.3-3 ist installiert
 libc6-i386 : Hängt ab von: libc6 (= 2.11.3-3) aber 2.11.3-2 ist installiert
E: Fehler: Unterbrechungen durch pkgProblemResolver::Resolve hervorgerufen; dies könnte durch zurückgehaltene Pakete verursacht worden sein.
E: Abhängigkeiten konnten nicht korrigiert werden
mfG

Geändert von Freakshow1000 (28.04.2012 um 00:07 Uhr)
Mit Zitat antworten

  #2  
Alt 28.04.2012, 00:02
Benutzerbild von mr_brain
mr_brain mr_brain ist offline
Registered User
 
Registriert seit: 08.2007
Beiträge: 1.388
mr_brain eine Nachricht über ICQ schicken mr_brain eine Nachricht über AIM schicken mr_brain eine Nachricht über MSN schicken mr_brain eine Nachricht über Yahoo! schicken
Bitte mal die Ausgabe von

cat /etc/apt/sources.list

und

cat /etc/debian_version

posten.
__________________
goto; // Welcome 2 Inter.Net
Administration, Colocation, DDoS Mitigation, Nameserver & virtuelle Server
Produkte: www.welcome2inter.net/products
Mit Zitat antworten
  #3  
Alt 28.04.2012, 00:03
Freakshow1000 Freakshow1000 ist offline
Registered User
 
Registriert seit: 04.2012
Beiträge: 64
Hallo,

es handelt sich um Debian Squeeze.

Code:
cat /etc/apt/sources.list
deb http://ftp.de.debian.org/debian/ squeeze main
deb http://packages.dotdeb.org squeeze all
deb-src http://packages.dotdeb.org squeeze all
deb http://security.debian.org/ squeeze/updates main
deb-src http://security.debian.org/ squeeze/updates main
mfG
Mit Zitat antworten
  #4  
Alt 28.04.2012, 04:44
PapaBaer PapaBaer ist offline
Registered User
 
Registriert seit: 09.2010
Ort: Halle (Saale)
Beiträge: 1.754
Das werden die dotdeb-Repos sein. Entweder rausnehmen oder mit Apt-Pinning niedriger priorisieren.
Mit Zitat antworten
  #5  
Alt 28.04.2012, 09:39
bjo bjo ist offline
Registered User
 
Registriert seit: 08.2010
Ort: Oldenburg
Beiträge: 134
bjo eine Nachricht über ICQ schicken
dotdeb stellt aber nicht libc6 zur Verfügung.
Mit Zitat antworten
  #6  
Alt 28.04.2012, 09:50
Benutzerbild von danton
danton danton ist offline
Registered User
 
Registriert seit: 04.2009
Ort: Ennigerloh
Alter: 41
Beiträge: 1.685
danton eine Nachricht über ICQ schicken danton eine Nachricht über AIM schicken
Dotdeb liefert keine libc6 aus, daher kann es daher nicht kommen. Ich nutze Dotdeb auch und habe keine Probleme. Allerdings ist bei mir die Version 2.11.3-3 von der libc6 die aktuelle - kommt vom Security-Repository. Aktualisiere noch mal deine Paketliste, dann sollten normalerweise auch die restlichen Pakete der libc6 auf diese Version angehoben werden.
__________________
Event-List - PHP/MySQL-Veranstaltungskalender für die eigene Homepage
Mit Zitat antworten
  #7  
Alt 28.04.2012, 13:07
Freakshow1000 Freakshow1000 ist offline
Registered User
 
Registriert seit: 04.2012
Beiträge: 64
Code:
proot@ts3:~# apt-get update
OK   http://security.debian.org squeeze/updates Release.gpg
Ign http://security.debian.org/ squeeze/updates/main Translation-de
Ign http://security.debian.org/ squeeze/updates/main Translation-en
OK   http://security.debian.org squeeze/updates Release
OK   http://packages.dotdeb.org squeeze Release.gpg
Ign http://packages.dotdeb.org/ squeeze/all Translation-de
Ign http://packages.dotdeb.org/ squeeze/all Translation-en
OK   http://security.debian.org squeeze/updates/main Sources
OK   http://ftp.de.debian.org squeeze Release.gpg
OK   http://ftp.de.debian.org/debian/ squeeze/main Translation-de
OK   http://security.debian.org squeeze/updates/main amd64 Packages
OK   http://packages.dotdeb.org squeeze Release
Ign http://ftp.de.debian.org/debian/ squeeze/main Translation-en
OK   http://ftp.de.debian.org squeeze Release
OK   http://packages.dotdeb.org squeeze/all Sources
OK   http://packages.dotdeb.org squeeze/all amd64 Packages
OK   http://ftp.de.debian.org squeeze/main amd64 Packages
Paketlisten werden gelesen... Fertig
root@ts3:~# apt-get upgrade
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut
Statusinformationen werden eingelesen... Fertig
Probieren Sie »apt-get -f install«, um dies zu korrigieren.
Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 libc6 : Hängt ab von: libc-bin (= 2.11.3-2) aber 2.11.3-3 ist installiert
 libc6-i386 : Hängt ab von: libc6 (= 2.11.3-3) aber 2.11.3-2 ist installiert
E: Unerfüllte Abhängigkeiten. Versuchen Sie, -f zu benutzen.
root@ts3:~# apt-get install -f
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut
Statusinformationen werden eingelesen... Fertig
Abhängigkeiten werden korrigiert... fehlgeschlagen.
Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 libc6 : Hängt ab von: libc-bin (= 2.11.3-2) aber 2.11.3-3 ist installiert
 libc6-i386 : Hängt ab von: libc6 (= 2.11.3-3) aber 2.11.3-2 ist installiert
E: Fehler: Unterbrechungen durch pkgProblemResolver::Resolve hervorgerufen; dies könnte durch zurückgehaltene Pakete verursacht worden sein.
E: Abhängigkeiten konnten nicht korrigiert werden
root@ts3:~#

Geändert von Freakshow1000 (28.04.2012 um 13:10 Uhr)
Mit Zitat antworten
  #8  
Alt 28.04.2012, 22:03
PapaBaer PapaBaer ist offline
Registered User
 
Registriert seit: 09.2010
Ort: Halle (Saale)
Beiträge: 1.754
Hast du irgendwann vorher schonmal mit weiteren Fremd-Repos oder Testing-Quellen ein Update/eine Installation versucht, die auf halbem Wege fehlgeschlagen ist?
Mit Zitat antworten
  #9  
Alt 28.04.2012, 23:48
Benutzerbild von Joe User
Joe User Joe User ist offline
R​o​o​t​F​o​r​u​m Team
 
Registriert seit: 11.2008
Ort: Hamburg
Alter: 36
Beiträge: 2.892
libc in 32Bit installiert haben aber in der sources.lst amd64 angeben passt nicht zusammen...
__________________
Ist ein dedizierter Server das Richtige für mich? ¤ Vorgehensweise bei gehacktem Server ¤ FreeBSD Remote Installation ¤ RootForum Community ¤ RootWiki
„If there’s more than one possible outcome of a job or task, and one of those outcomes will result in disaster or an undesirable consequence, then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.
Mit Zitat antworten
  #10  
Alt 29.04.2012, 10:16
bjo bjo ist offline
Registered User
 
Registriert seit: 08.2010
Ort: Oldenburg
Beiträge: 134
bjo eine Nachricht über ICQ schicken
@Joe:
libc6-i386 existiert neben libc6.

@Freakshow:
Böser Workaround: In /var/cache/apt/archives mit "dpkg -i" libc6, libc6-bin und libc6-i386 auf dieselbe Version bringen.
Mit Zitat antworten
  #11  
Alt 29.04.2012, 23:51
Freakshow1000 Freakshow1000 ist offline
Registered User
 
Registriert seit: 04.2012
Beiträge: 64
Zitat:
Zitat von bjo Beitrag anzeigen
@Freakshow:
Böser Workaround: In /var/cache/apt/archives mit "dpkg -i" libc6, libc6-bin und libc6-i386 auf dieselbe Version bringen.
Code:
apt-get install -d libc6
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut
Statusinformationen werden eingelesen... Fertig
libc6 ist schon die neueste Version.
Probieren Sie »apt-get -f install«, um dies zu korrigieren:
Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 libc6 : Hängt ab von: libc-bin (= 2.11.3-2) aber 2.11.3-3 soll installiert werden
 libc6-i386 : Hängt ab von: libc6 (= 2.11.3-3) aber 2.11.3-2 soll installiert werden
E: Unerfüllte Abhängigkeiten. Versuchen Sie »apt-get -f install« ohne Angabe eines Pakets (oder geben Sie eine Lösung an).


Zitat:
Zitat von PapaBaer Beitrag anzeigen
Hast du irgendwann vorher schonmal mit weiteren Fremd-Repos oder Testing-Quellen ein Update/eine Installation versucht, die auf halbem Wege fehlgeschlagen ist?
Nein das habe ich nicht


mfG


--nachtrag--

Hat sich erledigt!
Lag doch an den Repos.
Sehr seltsam

Code:
root@ts3:/tmp/proftpd-1.3.4a# cat /etc/apt/sources.list
#deb http://ftp.de.debian.org/debian/ squeeze main
#deb http://packages.dotdeb.org squeeze all
#deb-src http://packages.dotdeb.org squeeze all
#deb http://security.debian.org/ squeeze/updates main
#deb-src http://security.debian.org/ squeeze/updates main
deb http://ftp.informatik.uni-frankfurt.de/debian/ squeeze main
deb-src http://ftp.informatik.uni-frankfurt.de/debian/ squeeze main

deb http://security.debian.org/ squeeze/updates main
deb-src http://security.debian.org/ squeeze/updates main

# squeeze-updates, previously known as 'volatile'
deb http://ftp.informatik.uni-frankfurt.de/debian/ squeeze-updates main
deb-src http://ftp.informatik.uni-frankfurt.de/debian/ squeeze-updates main
Jetzt geht es!
Danke für die Mithilfe!

Geändert von Freakshow1000 (30.04.2012 um 00:18 Uhr)
Mit Zitat antworten
  #12  
Alt 30.04.2012, 17:29
Benutzerbild von danton
danton danton ist offline
Registered User
 
Registriert seit: 04.2009
Ort: Ennigerloh
Alter: 41
Beiträge: 1.685
danton eine Nachricht über ICQ schicken danton eine Nachricht über AIM schicken
Die Lösung dürfte dieser Eintrag hier sein:
Code:
deb http://ftp.informatik.uni-frankfurt.de/debian/ squeeze-updates main
Denn die squeeze-updates hattest du vorher nicht drin - und darüber kommt eigentlich die neuere libc-Version.
__________________
Event-List - PHP/MySQL-Veranstaltungskalender für die eigene Homepage
Mit Zitat antworten
Antwort

Lesezeichen


Themen-Optionen
Thema bewerten
Thema bewerten:

Forumregeln
Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist aus.
HTML-Code ist aus.

Gehe zu

Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
Webmaster ist im Urlaub und Server spielt verrückt blondie0708 Virtuelle Server 14 12.08.2011 14:21
Company of Heroes - Spielt das jemand? Ben. Smalltalk 0 06.02.2010 14:40
MySQL++ 2.3.2 auf Debian Lenny x64 - ICH WERD VERRÜCKT! dark alex Linux 16 19.04.2009 19:35
ISPCP spielt verückt snufy99 ispCP 23 19.01.2009 21:00
datenbank spielt verrückt IMMERDRAUF Virtuelle Server 21 17.10.2003 01:47





Powered by vBulletin® Version 3.8.8 (Deutsch)
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
System Monitoring by Bloonix